aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-06-30 19:33:37 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-06-30 19:33:37 +0000
commit2b53f3fc508ff85be8a138d181ab3c06178c809d (patch)
treedef8cd9e2df85e6662d3c2efb4c937148196d7b0
parent2dd0f1d5befc29367d12419a2869ab20ba125c2e (diff)
downloadports-2b53f3fc508ff85be8a138d181ab3c06178c809d.tar.gz
ports-2b53f3fc508ff85be8a138d181ab3c06178c809d.zip
www/firefox-esr: update to 102.13.0 (rc2)
-rw-r--r--www/firefox-esr/Makefile5
-rw-r--r--www/firefox-esr/distinfo6
-rw-r--r--www/firefox-esr/files/patch-rust-1.70.033
3 files changed, 5 insertions, 39 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index adf78ef81829..bb65478efc3a 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -1,10 +1,9 @@
PORTNAME= firefox
-DISTVERSION= 102.12.0
-PORTREVISION= 1
+DISTVERSION= 102.13.0
PORTEPOCH= 1
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}esr-candidates/build1/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}esr-candidates/build2/source
PKGNAMESUFFIX= -esr
DISTFILES= ${DISTNAME}esr.source${EXTRACT_SUFX}
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index ea7ca95ffe7a..d2016d2e274b 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1685387497
-SHA256 (firefox-102.12.0esr.source.tar.xz) = d7296d0e6cf572a5604498d19801faf274ba64b195add5231e90cf8edacd31a1
-SIZE (firefox-102.12.0esr.source.tar.xz) = 483008152
+TIMESTAMP = 1688143890
+SHA256 (firefox-102.13.0esr.source.tar.xz) = fc3fab3de4bf65d1ec7fc30ae776144097b70a35d37c36663e11ffa618c13a2c
+SIZE (firefox-102.13.0esr.source.tar.xz) = 485854020
diff --git a/www/firefox-esr/files/patch-rust-1.70.0 b/www/firefox-esr/files/patch-rust-1.70.0
deleted file mode 100644
index 233e51bee164..000000000000
--- a/www/firefox-esr/files/patch-rust-1.70.0
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/mozilla/mp4parse-rust/commit/8b5b652d38e007e736bb442ccd5aa5ed699db100
-
-From 8b5b652d38e007e736bb442ccd5aa5ed699db100 Mon Sep 17 00:00:00 2001
-From: Matthew Gregan <kinetik@flim.org>
-Date: Thu, 16 Jun 2022 13:54:02 +1200
-Subject: [PATCH] Fix `unstable-name-collisions` warning by using fully
- qualified path.
-
----
- mp4parse/src/lib.rs | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/mp4parse/src/lib.rs b/mp4parse/src/lib.rs
-index 567ee21d..4f3d7153 100644
---- third_party/rust/mp4parse/src/lib.rs
-+++ third_party/rust/mp4parse/src/lib.rs
-@@ -3506,8 +3506,13 @@ macro_rules! impl_mul {
- type Output = $output;
-
- fn mul(self, rhs: $rhs) -> Self::Output {
-- static_assertions::const_assert!(<$output>::MAX <= <$inner>::MAX as u64);
-- static_assertions::const_assert!(<$lhs>::MAX * <$rhs>::MAX <= <$output>::MAX);
-+ static_assertions::const_assert!(
-+ <$output as UpperBounded>::MAX <= <$inner>::MAX as u64
-+ );
-+ static_assertions::const_assert!(
-+ <$lhs as UpperBounded>::MAX * <$rhs as UpperBounded>::MAX
-+ <= <$output as UpperBounded>::MAX
-+ );
-
- let lhs: $inner = self.get().into();
- let rhs: $inner = rhs.get().into();
-