aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-09-07 12:02:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-09-09 19:13:43 +0000
commit2bc82370c34f7d9bab28ce0cc841defbaba4569c (patch)
tree025769eba841e96ed031dd758057575508972a91
parent295016f09df4b77252991dc72e80adeafde9e83d (diff)
downloadports-2bc82370c34f7d9bab28ce0cc841defbaba4569c.tar.gz
ports-2bc82370c34f7d9bab28ce0cc841defbaba4569c.zip
games/reminiscence: update to 0.4.9
-rw-r--r--games/reminiscence/Makefile9
-rw-r--r--games/reminiscence/distinfo6
-rw-r--r--games/reminiscence/files/patch-Makefile12
3 files changed, 13 insertions, 14 deletions
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index b9d6c6942ba7..432801347973 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -1,5 +1,5 @@
PORTNAME= REminiscence
-PORTVERSION= 0.4.8
+PORTVERSION= 0.4.9
CATEGORIES= games
MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
https://mirror.amdmi3.ru/distfiles/
@@ -7,18 +7,17 @@ MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Rewritten engine for Flashback
-LIB_DEPENDS= libmodplug.so:audio/libmodplug \
- libvorbisidec.so:audio/libtremor
+LIB_DEPENDS= libmodplug.so:audio/libmodplug
+BUILD_DEPENDS= ${LOCALBASE}/include/stb/stb_vorbis.c:devel/stb
USES= compiler:c++11-lang gmake pkgconfig sdl tar:bzip2
USE_SDL= sdl2
-
ALL_TARGET= rs
+CPPFLAGS+= -I${LOCALBASE}/include/stb
SUB_FILES= pkg-message
PORTDOCS= README.txt
-
PLIST_FILES= bin/remin
PLIST_DIRS= %%DATADIR%%/data
diff --git a/games/reminiscence/distinfo b/games/reminiscence/distinfo
index a27bfe2e7351..1a7bbb0d0580 100644
--- a/games/reminiscence/distinfo
+++ b/games/reminiscence/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622558150
-SHA256 (REminiscence-0.4.8.tar.bz2) = 1cb6ccb4ac9ec38fa80dd80dbdb24ccf16cf58d2de42a030776a3a7c691cabf8
-SIZE (REminiscence-0.4.8.tar.bz2) = 158116
+TIMESTAMP = 1630952496
+SHA256 (REminiscence-0.4.9.tar.bz2) = 3447099affd9f0d3f3e13815dcf0974d7818a4cbfbe409d20c717bff1365ba11
+SIZE (REminiscence-0.4.9.tar.bz2) = 159577
diff --git a/games/reminiscence/files/patch-Makefile b/games/reminiscence/files/patch-Makefile
index a640ae6cc23d..2343096f806e 100644
--- a/games/reminiscence/files/patch-Makefile
+++ b/games/reminiscence/files/patch-Makefile
@@ -1,20 +1,20 @@
---- Makefile.orig 2019-12-29 13:19:15 UTC
+--- Makefile.orig 2021-09-05 12:10:10 UTC
+++ Makefile
@@ -2,11 +2,13 @@
SDL_CFLAGS := `sdl2-config --cflags`
SDL_LIBS := `sdl2-config --libs`
-MODPLUG_LIBS := -lmodplug
--TREMOR_LIBS := -lvorbisidec -logg
+-TREMOR_LIBS := #-lvorbisidec -logg
-ZLIB_LIBS := -lz
+MODPLUG_CFLAGS := `pkg-config --cflags libmodplug`
+MODPLUG_LIBS := `pkg-config --libs libmodplug`
-+TREMOR_CFLAGS := `pkg-config --cflags vorbisidec`
-+TREMOR_LIBS := `pkg-config --libs vorbisidec`
++TREMOR_CFLAGS := #`pkg-config --cflags vorbisidec`
++TREMOR_LIBS := #`pkg-config --libs vorbisidec`
+ZLIB_LIBS := -lz
--CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
-+CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) $(MODPLUG_CFLAGS) $(TREMOR_CFLAGS) -DUSE_MODPLUG -DUSE_TREMOR -DUSE_ZLIB
+-CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_STB_VORBIS -DUSE_ZLIB
++CXXFLAGS += -Wall -Wpedantic -MMD $(SDL_CFLAGS) $(MODPLUG_CFLAGS) $(TREMOR_CFLAGS) -DUSE_MODPLUG -DUSE_STB_VORBIS -DUSE_ZLIB
SRCS = collision.cpp cpc_player.cpp cutscene.cpp decode_mac.cpp file.cpp fs.cpp game.cpp graphics.cpp main.cpp \
menu.cpp mixer.cpp mod_player.cpp ogg_player.cpp piege.cpp protection.cpp resource.cpp resource_aba.cpp \