aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-05 15:18:19 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-05 15:47:51 +0000
commit2c299bdb450e3e1c7ad36fa66f9540c468c25552 (patch)
tree28d9a6394403340304cca28bb63e646076e6219e
parente55a580b4efac99ed788b645af574ed04fc44422 (diff)
downloadports-2c299bdb450e3e1c7ad36fa66f9540c468c25552.tar.gz
ports-2c299bdb450e3e1c7ad36fa66f9540c468c25552.zip
devel/py-astroid: Update to 2.13.3
-rw-r--r--devel/py-astroid/Makefile9
-rw-r--r--devel/py-astroid/distinfo6
-rw-r--r--devel/py-astroid/files/setup.py3
3 files changed, 12 insertions, 6 deletions
diff --git a/devel/py-astroid/Makefile b/devel/py-astroid/Makefile
index ee759bb0bdb7..018616714ed8 100644
--- a/devel/py-astroid/Makefile
+++ b/devel/py-astroid/Makefile
@@ -1,5 +1,5 @@
PORTNAME= astroid
-PORTVERSION= 2.12.14
+PORTVERSION= 2.13.3
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -27,8 +27,11 @@ CONFLICTS= ${PYTHON_PKGNAMEPREFIX}astroid253
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typed-ast>=1.4.0<2.0:devel/py-typed-ast@${PY_FLAVOR}
.endif
-.if ${PYTHON_REL} < 31000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.10:devel/py-typing-extensions@${PY_FLAVOR}
+.if ${PYTHON_REL} < 31100
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.0.0:devel/py-typing-extensions@${PY_FLAVOR}
.endif
+post-patch:
+ @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
+
.include <bsd.port.post.mk>
diff --git a/devel/py-astroid/distinfo b/devel/py-astroid/distinfo
index fee77d1f845c..6cc24c574fde 100644
--- a/devel/py-astroid/distinfo
+++ b/devel/py-astroid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674589732
-SHA256 (astroid-2.12.14.tar.gz) = b573ed96112061150eade70851c277a92fba544812b781836ab16fedbbddb497
-SIZE (astroid-2.12.14.tar.gz) = 218227
+TIMESTAMP = 1675190987
+SHA256 (astroid-2.13.3.tar.gz) = 6afc22718a48a689ca24a97981ad377ba7fb78c133f40335dfd16772f29bcfb1
+SIZE (astroid-2.13.3.tar.gz) = 223593
diff --git a/devel/py-astroid/files/setup.py b/devel/py-astroid/files/setup.py
new file mode 100644
index 000000000000..606849326a40
--- /dev/null
+++ b/devel/py-astroid/files/setup.py
@@ -0,0 +1,3 @@
+from setuptools import setup
+
+setup()