aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2023-07-31 13:02:36 +0000
committerWen Heping <wen@FreeBSD.org>2023-07-31 13:04:48 +0000
commit2c6084bebcc1cca164aa38f20eab5a8cd56dd668 (patch)
tree45701f478b696d5b38374afc5c90dda446ee266b
parent29ba47177136c846abf3a603397db2b3dfb870ff (diff)
downloadports-2c6084bebcc1cca164aa38f20eab5a8cd56dd668.tar.gz
ports-2c6084bebcc1cca164aa38f20eab5a8cd56dd668.zip
astro/viking: Resurrect and update
PR: 272076 Reported by: lantw44@gmail.com
-rw-r--r--astro/Makefile1
-rw-r--r--astro/viking/Makefile88
-rw-r--r--astro/viking/distinfo3
-rw-r--r--astro/viking/files/pkg-message.in13
-rw-r--r--astro/viking/pkg-descr6
-rw-r--r--astro/viking/pkg-plist95
6 files changed, 206 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 10fd52b16dea..8cc9e700b354 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -127,6 +127,7 @@
SUBDIR += swe
SUBDIR += tclgeomap
SUBDIR += tkgeomap
+ SUBDIR += viking
SUBDIR += wcslib
SUBDIR += weather
SUBDIR += wmglobe
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
new file mode 100644
index 000000000000..43764589328b
--- /dev/null
+++ b/astro/viking/Makefile
@@ -0,0 +1,88 @@
+PORTNAME= viking
+PORTVERSION= 1.10
+CATEGORIES= astro
+MASTER_SITES= SF/${PORTNAME}/
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Program to manage GPS data (tracks, waypoints, etc.)
+WWW= https://sourceforge.net/p/viking/wikiallura/Main_Page/
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= itstool:textproc/itstool \
+ ${LOCALBASE}/share/aclocal/yelp.m4:textproc/yelp-tools \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libexpat.so:textproc/expat2 \
+ libgeoclue-2.so:net/geoclue \
+ libharfbuzz.so:print/harfbuzz \
+ libjson-glib-1.0.so:devel/json-glib \
+ libnettle.so:security/nettle \
+ liboauth.so:net/liboauth \
+ libzip.so:archivers/libzip
+RUN_DEPENDS= gpsbabel:astro/gpsbabel
+
+USES= compiler:c++11-lib desktop-file-utils gettext gmake gnome \
+ iconv localbase perl5 pkgconfig tar:bzip2 xorg
+USE_XORG= x11
+USE_GNOME= cairo gdkpixbuf2 gtk30 intlhack
+USE_PERL5= run
+GNU_CONFIGURE= yes
+
+PORTDOCS= AUTHORS ChangeLog NEWS README.md
+
+OPTIONS_DEFINE= DOCS GEOCACHES NLS GEOTAG GPSD MAPNIK MBTILES
+OPTIONS_DEFAULT= GEOTAG GPSD JOSM MAPNIK MBTILES
+
+OPTIONS_MULTI= EDITOR
+OPTIONS_MULTI_EDITOR= JOSM MERKAATOR
+
+EDITOR_DESC= OpenStreetMap editor
+GEOCACHES_DESC= GeoCaches Acquire support
+GEOTAG_DESC= Geotag support
+GPSD_DESC= Realtime GPS tracking
+MAPNIK_DESC= Mapnik support
+MBTILES_DESC= MBTiles support
+JOSM_DESC= Edit OpenStreetMap via JOSM
+MERKAATOR_DESC= Edit OpenStreetMap via Merkaartor
+
+OPTIONS_SUB= yes
+
+GEOCACHES_CONFIGURE_ENABLE= geocaches
+GEOCACHES_SUB_FILES= pkg-message
+
+NLS_CONFIGURE_ENABLE= nls
+
+GEOTAG_LIB_DEPENDS= libgexiv2.so:graphics/gexiv2
+GEOTAG_CONFIGURE_ENABLE=geotag
+
+GPSD_LIB_DEPENDS= libgps.so:astro/gpsd
+GPSD_CONFIGURE_ENABLE= realtime-gps-tracking
+
+MAPNIK_LIB_DEPENDS= libmapnik.so:graphics/mapnik
+MAPNIK_CONFIGURE_ENV= ac_cv_lib_icuuc_main=no # indirect
+MAPNIK_CONFIGURE_ENABLE= mapnik
+MAPNIK_CPPFLAGS= -I${LOCALBASE}/include/mapnik
+
+MBTILES_USES= sqlite
+MBTILES_CONFIGURE_ENABLE= mbtiles
+
+JOSM_RUN_DEPENDS= josm:astro/josm
+MERKAATOR_RUN_DEPENDS= merkaartor:astro/merkaartor
+
+post-patch:
+ @${REINPLACE_CMD} -e '/as_fn_error.*libicuuc/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^AM_CFLAGS/s| -g | |' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|Science;|Education;Science;|' \
+ ${WRKSRC}/src/viking.desktop.in
+
+post-install:
+ ${LN} -sf ../icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/astro/viking/distinfo b/astro/viking/distinfo
new file mode 100644
index 000000000000..f80f3085bd10
--- /dev/null
+++ b/astro/viking/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1690759184
+SHA256 (viking-1.10.tar.bz2) = 9455c895f98bc13de24bd6b234cd0f1d5ecdc1b068b4cbc6eb6644f6126e45ac
+SIZE (viking-1.10.tar.bz2) = 5035598
diff --git a/astro/viking/files/pkg-message.in b/astro/viking/files/pkg-message.in
new file mode 100644
index 000000000000..462f12f71131
--- /dev/null
+++ b/astro/viking/files/pkg-message.in
@@ -0,0 +1,13 @@
+[
+{ type: install
+ message: <<EOM
+Viking has been installed.
+
+When you wish to use GeoCaches Acquire Option, please make an account at
+
+ http://www.geocaching.com/
+
+Have fun!
+EOM
+}
+]
diff --git a/astro/viking/pkg-descr b/astro/viking/pkg-descr
new file mode 100644
index 000000000000..b66fff119f1d
--- /dev/null
+++ b/astro/viking/pkg-descr
@@ -0,0 +1,6 @@
+Viking is a free/open source program to manage GPS data.
+
+You can import and plot tracks, routes and waypoints, show OpenStreetMap,
+Terraserver, Bing Aerial and other maps in it, download geocaches for
+an area on the map, make new tracks and waypoints, geotag images,
+see real-time GPS position, etc.
diff --git a/astro/viking/pkg-plist b/astro/viking/pkg-plist
new file mode 100644
index 000000000000..6bdf4a07d917
--- /dev/null
+++ b/astro/viking/pkg-plist
@@ -0,0 +1,95 @@
+bin/viking
+man/man1/viking.1.gz
+share/applications/viking.desktop
+%%PORTDOCS%%share/help/C/viking/attribution.xml
+%%PORTDOCS%%share/help/C/viking/commandline.xml
+%%PORTDOCS%%share/help/C/viking/dem_layer.xml
+%%PORTDOCS%%share/help/C/viking/edit_view_menus.xml
+%%PORTDOCS%%share/help/C/viking/figures/Aggregate_heatmap.png
+%%PORTDOCS%%share/help/C/viking/figures/Aggregate_statistics.png
+%%PORTDOCS%%share/help/C/viking/figures/Aggregate_statistics_years.png
+%%PORTDOCS%%share/help/C/viking/figures/DEM_Example.png
+%%PORTDOCS%%share/help/C/viking/figures/DEM_file_info_dialog.png
+%%PORTDOCS%%share/help/C/viking/figures/Goto_Main_Window.png
+%%PORTDOCS%%share/help/C/viking/figures/LayersTracksList.png
+%%PORTDOCS%%share/help/C/viking/figures/LayersTracksStatistics.png
+%%PORTDOCS%%share/help/C/viking/figures/Maps_download_region_dialog.png
+%%PORTDOCS%%share/help/C/viking/figures/Panel_Stats_Tab.png
+%%PORTDOCS%%share/help/C/viking/figures/Track_elevation_graph.png
+%%PORTDOCS%%share/help/C/viking/figures/Track_properties.png
+%%PORTDOCS%%share/help/C/viking/figures/Track_statistics.png
+%%PORTDOCS%%share/help/C/viking/figures/Track_time_splits.png
+%%PORTDOCS%%share/help/C/viking/figures/Trackpoint_edit_dialog.png
+%%PORTDOCS%%share/help/C/viking/figures/Viking-OSM-CycleMap-ManyTracks.jpg
+%%PORTDOCS%%share/help/C/viking/figures/Viking-TAC.png
+%%PORTDOCS%%share/help/C/viking/figures/WaypointProperties.png
+%%PORTDOCS%%share/help/C/viking/figures/WaypointsList.png
+%%PORTDOCS%%share/help/C/viking/figures/addtr_18.png
+%%PORTDOCS%%share/help/C/viking/figures/addwp_18.png
+%%PORTDOCS%%share/help/C/viking/figures/customize_toolbar_dialog.png
+%%PORTDOCS%%share/help/C/viking/figures/demdl_18.png
+%%PORTDOCS%%share/help/C/viking/figures/edtr_18.png
+%%PORTDOCS%%share/help/C/viking/figures/edwp_18.png
+%%PORTDOCS%%share/help/C/viking/figures/geomove_18.png
+%%PORTDOCS%%share/help/C/viking/figures/geozoom_18.png
+%%PORTDOCS%%share/help/C/viking/figures/map_tile_info_dialog.png
+%%PORTDOCS%%share/help/C/viking/figures/mapdl_18.png
+%%PORTDOCS%%share/help/C/viking/figures/mover_22.png
+%%PORTDOCS%%share/help/C/viking/figures/properties_degree.png
+%%PORTDOCS%%share/help/C/viking/figures/properties_units.png
+%%PORTDOCS%%share/help/C/viking/figures/route_finder_18.png
+%%PORTDOCS%%share/help/C/viking/figures/ruler_18.png
+%%PORTDOCS%%share/help/C/viking/figures/select_18.png
+%%PORTDOCS%%share/help/C/viking/figures/showpic_18.png
+%%PORTDOCS%%share/help/C/viking/figures/trw_statusbar.png
+%%PORTDOCS%%share/help/C/viking/figures/vik_new_route_18.png
+%%PORTDOCS%%share/help/C/viking/figures/zoom_18.png
+%%PORTDOCS%%share/help/C/viking/figures/zoom_status_popup.png
+%%PORTDOCS%%share/help/C/viking/geoclue_layer.xml
+%%PORTDOCS%%share/help/C/viking/georef_layer.xml
+%%PORTDOCS%%share/help/C/viking/index.docbook
+%%PORTDOCS%%share/help/C/viking/legal.xml
+%%PORTDOCS%%share/help/C/viking/mapnik_rendering_layer.xml
+%%PORTDOCS%%share/help/C/viking/recommends.xml
+share/icons/hicolor/48x48/apps/viking.png
+%%NLS%%share/locale/ast/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/da/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/de/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/el/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/es/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/he/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/id/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/it/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/jv/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/ku/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/viking.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/viking.mo
+share/pixmaps/viking.png
+%%DATADIR%%/datasources.xml
+%%DATADIR%%/external_tools.xml
+%%DATADIR%%/goto_tools.xml
+%%DATADIR%%/latlontz.txt
+%%DATADIR%%/maps.xml
+%%DATADIR%%/routing.xml
+%%DATADIR%%/unreachable_tiles.txt