aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2024-01-21 15:37:17 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2024-01-21 15:37:17 +0000
commit2c7013fff5963d9faa72770b006f99c60d5fa1df (patch)
tree43fc9145ba842d8471b71025566034439e044226
parent1f508a87ef632665ba30b40c505cbeb2d19f7db6 (diff)
sysutils/ntfy: fix build with Python 3.11
Obtained from here: https://github.com/dschep/ntfy/issues/262 PR: 275494 Approved by: portmgr (blanket approval)
-rw-r--r--sysutils/ntfy/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/sysutils/ntfy/Makefile b/sysutils/ntfy/Makefile
index b7990e62acc0..f1d8c90207bf 100644
--- a/sysutils/ntfy/Makefile
+++ b/sysutils/ntfy/Makefile
@@ -15,11 +15,16 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>0:devel/py-appdirs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ruamel.yaml>0:devel/py-ruamel.yaml@${PY_FLAVOR}
-USES= python
+USES= python:3.11
USE_GITHUB= yes
GH_ACCOUNT= dschep
USE_PYTHON= distutils noflavors autoplist
NO_ARCH= yes
+post-patch:
+# Fix build with Python 3.11
+ @${REINPLACE_CMD} -e 's|getargspec|getfullargspec|' \
+ ${WRKSRC}/ntfy/__init__.py
+
.include <bsd.port.mk>