aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-09-10 05:23:20 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-09-10 05:23:20 +0000
commit2cab4551df7cf66a0c377f2d53f692f9ddd5f8c9 (patch)
treebdcd31176698becb7abe081ab8550b3f3d7337a9
parent0f3252481849b37a5c22714553231ca91d80e182 (diff)
downloadports-2cab4551df7cf66a0c377f2d53f692f9ddd5f8c9.tar.gz
ports-2cab4551df7cf66a0c377f2d53f692f9ddd5f8c9.zip
lang/gforth: unbreak the build in the -Werror=int-conversion mode
Missing ecvt() function prototype was causing couple of warnings which had become hard errors with recent versions of GCC (14+). Getting rid of USE_GCC, while desirable, is not straightforward and requires more work. While here, set the TEST_TARGET which is part of the upstream's default ALL_TARGET, but we override that. PR: 281238
-rw-r--r--lang/gforth/Makefile2
-rw-r--r--lang/gforth/files/patch-engine_forth.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 4791cbb4bd42..aba8fcb1d346 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -20,10 +20,10 @@ USES= gmake libtool:build localbase makeinfo
USE_GCC= yes
USE_LDCONFIG= ${PREFIX}/lib/gforth/${PORTVERSION}/libcc-named
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ENV= GFORTHHIST=${WRKSRC}
MAKE_ENV= GFORTHHIST=${WRKSRC}
ALL_TARGET= kernel/version.fs more info
+TEST_TARGET= check
MAKE_JOBS_UNSAFE=yes
STRIP= #none
diff --git a/lang/gforth/files/patch-engine_forth.h b/lang/gforth/files/patch-engine_forth.h
new file mode 100644
index 000000000000..0ac980204cf2
--- /dev/null
+++ b/lang/gforth/files/patch-engine_forth.h
@@ -0,0 +1,11 @@
+--- engine/forth.h.orig 2013-10-11 21:31:28 UTC
++++ engine/forth.h
+@@ -490,7 +490,7 @@ extern double asinh(double r1);
+ extern double acosh(double r1);
+ #endif
+ #ifndef HAVE_ECVT
+-/* extern char* ecvt(double x, int len, int* exp, int* sign);*/
++extern char* ecvt(double x, int len, int* exp, int* sign);
+ #endif
+ #ifndef HAVE_MEMMOVE
+ /* extern char *memmove(char *dest, const char *src, long n); */