aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-05 19:13:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-06 14:39:01 +0000
commit2cc4a1675ec9739de14b5695f786a5fa211041a5 (patch)
treebb582d131a6298213bca765678209e6e401a93c7
parent82310c2cc1818b093e0069722fd3a9da8785601e (diff)
downloadports-2cc4a1675ec9739de14b5695f786a5fa211041a5.tar.gz
ports-2cc4a1675ec9739de14b5695f786a5fa211041a5.zip
UPDATING: Trim upto stable/10 release
Approved by: portmgr
-rw-r--r--UPDATING3491
1 files changed, 0 insertions, 3491 deletions
diff --git a/UPDATING b/UPDATING
index 2c38fddde2f2..66dbb95d30b2 100644
--- a/UPDATING
+++ b/UPDATING
@@ -11975,3494 +11975,3 @@ leave you without networking.
If you are interested in upgrading now already, we have instructions
at <https://wiki.freebsd.org/Ports/BerkeleyDBCleanup>.
-
-20131209:
- AFFECTS: users of dns/bind96, dns/bind98 and bind99 on FreeBSD 10.0
- AUTHOR: erwin@FreeBSD.org
-
- Bind versions before 9.6.3.2.ESV.R10_2, 9.8.6_2, and 9.9.4_2 on
- FreeBSD 10.0 will replace named.conf on upgrade. Make sure to
- backup any local changes before upgrading to the _2 versions.
-
-20131208:
- AFFECTS: users of java/subversion-java
- AUTHOR: ohauer@FreeBSD.org
-
- java/subversion-java was moved to java/java-subversion.
- Please do the following according to package manager used.
-
- # portmaster -o java/java-subversion java/subversion-java
- or
- # portupgrade -fo java/java-subversion java/subversion-java
- or
- # pkg set -o java/subversion-java:java/java-subversion
-
-20131208:
- AFFECTS: users of x11-toolkits/vte
- AUTHOR: kwm@FreeBSD.org
-
- The gnome-pty-helper program has been split off from the vte package
- to allow both vte and vte3 to be installed at the same time. To update
- after this change please do the following:
-
- # pkg_delete -f vte\*
- or
- # pkg delete -fg vte\*
- followed by
- # portmaster x11-toolkits/vte
- or
- # portupgrade x11-toolkits/vte
-
-20131207:
- AFFECTS: users of mail/opensmtpd
- AUTHOR: ashish@FreeBSD.org
-
- There has been changes to the OpenSMTPD configuration. Please refer to
- smtpd.conf(5), and use "smtpd -nf smtpd.conf" to validate.
-
-20131203:
- AFFECTS: users of graphics/opencv, graphics/opencv-core
- AUTHOR: jhale@FreeBSD.org
-
- OpenCV has been updated to 2.4.7. Due to movement of files between the
- opencv port and the opencv-core port, it will be necessary to remove
- both packages before updating.
-
- # pkg_delete -f opencv\*
- or
- # pkg delete -fg opencv\*
- followed by
- # portmaster -a
- or
- # portupgrade -a
-
-20131127:
- AFFECTS: users of devel/py-distribute (i.e you)
- AUTHOR: wg@FreeBSD.org
-
- devel/py-distribute was replaced with devel/py-setuptools. Please do
- the following according to package manager used. py-distribute port
- will be removed shortly.
-
- # portmaster -o devel/py-setuptools devel/py-distribute
- or
- # portupgrade -fo devel/py-setuptools devel/py-distribute
- or
- # pkg set -o devel/py-distribute:devel/py-setuptools
- # pkg install -f devel/py-setuptools
-
-20131125:
- AFFECTS: users of www/mod_wsgi
- AUTHOR: ohauer@FreeBSD.org
-
- The port www/mod_wsgi moved to www/mod_wsgi2 to reflect the port version.
-
- # portmaster -o www/mod_wsgi2 www/mod_wsgi
- or
- # portupgrade -fo www/mod_wsgi2 www/mod_wsgi
- or
- # pkg set -o www/mod_wsgi:www/mod_wsgi2
-
-20131120:
- AFFECTS: users of lang/perl5.12 lang/perl5.14 lang/perl5.16 and lang/perl5.18
- AUTHOR: mat@FreeBSD.org
-
- The THREADS option has been enabled by default in all Perl. If you're using
- binary packages you need to do :
-
- # pkg install -Rf perl5
-
- If you're not using binary packages, and want to switch from non threaded
- Perl to threaded Perl, you need to recompile and reinstall most ports
- depending on Perl. Supposing you have Perl 5.16, you would do:
-
- Portupgrade users:
- 0) Fix pkgdb.db (for safety):
- pkgdb -Ff
-
- 1) Change the option in lang/perl5.16:
- make -C /usr/ports/lang/perl5.16 config
-
- 2) Reinstall everything that depends on Perl:
- portupgrade -fr lang/perl5.16
-
- Portmaster users:
- 1) Change the option in lang/perl5.16:
- make -C /usr/ports/lang/perl5.16 config
-
- 2) Reinstall everything that depends on Perl:
- portmaster -r perl5-
-
- Note: The installed Perl package was named perl and is now named perl5, if
- you have not updated your installation in a long time, you may need to
- use "perl-" here.
-
-20131112:
- AFFECTS: users of dns/nsd
- AUTHOR: erwin@FreeBSD.org
-
- dns/nsd was updated to the new 4.0.0 major release.
-
- This version replaces the nsdc control program with nsd-control.
- This requires some manual setup with nsd-control-setup and editing
- of the config files. nsd-control is incompatible with nsdc so when
- that is used in scripts, these should be adapted. More information:
- http://www.nlnetlabs.nl/svn/nsd/tags/NSD_4_0_0_REL/doc/NSD-4-features
-
- NSD version 3 is still supported in dns/nsd3. To keep the old
- version:
- # portmaster -o dns/nsd3 dns/nsd
- or
- # portupgrade -fo dns/nsd3 dns/nsd
- or
- # pkg set -o dns/nsd:dns/nsd3
-
-20131112:
- AFFECTS: users of dns/bind9*
- AUTHOR: erwin@FreeBSD.org
-
- All bind9 ports have been updated to support FreeBSD 10.x after
- BIND was removed from the base system. It is now self-contained
- in ${PREFIX}/etc/namedb, and chroot and symlinking options are
- no longer supported out of the box.
-
- For users of FreeBSD 9.x and earlier, the LINKS option is no longer
- enabled by default, but still supported. No other changes should
- affect those users, and updating without changing already set options
- will keep the system in the same state.
-
-20131103:
- AFFECTS: users of security/libtasn1 and any port that depends on it
- AUTHOR: novel@FreeBSD.org
-
- libtasn1 has been updated to 3.3 and all shared libraries versions have
- been bumped. So you need to rebuild all applications that depend on
- libtasn1.
-
- # portmaster -r libtasn1
- or
- # portupgrade -fr security/libtasn1
- or
- # pkg install -fR security/libtasn1
-
-20131031:
- AFFECTS: users of multimedia/rtmpdump
- AUTHOR: hrs@FreeBSD.org
-
- The library part of multimedia/rtmpdump is split into multimedia/librtmp.
- multimedia/rtmpdump now depends on the library port.
-
- A build error can occur if you built and installed old rtmpdump by
- using stock OpenSSL, and then install security/openssl and try to build
- multimedia/rtmpdump without deinstalling the installed one. Please
- make sure if the old rtmpdump is removed before building the new version.
-
-20131028:
- AFFECTS: users of comms/dcf77pi
- AUTHOR: rene@FreeBSD.org
-
- As of version 1.0.5 the configuration file was renamed from
- hardware.txt to config.txt and the format has been made more flexible.
-
- If you have customized any parameters, be sure to copy them to
- config.txt after which hardware.txt can be removed.
-
-20131028:
- AFFECTS: users of multimedia/ffmpeg1 and multimedia/ffmpeg-devel
- AUTHOR: wg@FreeBSD.org
-
- The port ffmpeg was updated, ffmpeg1 and ffmpeg-devel were removed in
- favor of ffmpeg.
-
- # portmaster -o multimedia/ffmpeg multimedia/ffmpeg1
- or
- # portupgrade -fo multimedia/ffmpeg multimedia/ffmpeg1
- or
- # pkg set -o multimedia/ffmpeg1:multimedia/ffmpeg
-
- and
-
- # portmaster -o multimedia/ffmpeg multimedia/ffmpeg-devel
- or
- # portupgrade -fo multimedia/ffmpeg multimedia/ffmpeg-devel
- or
- # pkg set -o multimedia/ffmpeg-devel:multimedia/ffmpeg
-
-20131023:
- AFFECTS: users of lang/perl5.12 lang/perl5.14
- AUTHOR: mat@FreeBSD.org
-
- The default Perl has been switched to lang/perl5.16. These examples
- are for switching from lang/perl5.14, if you are running another
- version, replace lang/perl5.14 with the origin of the Perl you have
- installed.
-
- Pkgng users:
-
- # pkg set -o lang/perl5.14:lang/perl5.16
- # pkg install -Rf lang/perl5.16
-
- Portupgrade users:
- 0) Fix pkgdb.db (for safety):
- pkgdb -Ff
-
- 1) Reinstall new version of Perl (5.16):
- portupgrade -o lang/perl5.16 -f lang/perl5.14
-
- 2) Reinstall everything that depends on Perl:
- portupgrade -fr lang/perl5.16
-
- Portmaster users:
- portmaster -o lang/perl5.16 lang/perl5.14
-
- Conservative:
- portmaster p5-
-
- Comprehensive (but perhaps overkill):
- portmaster -r perl-
-
- Note: If the "perl-" glob matches more than one port you will need to specify
- the name of the Perl directory in /var/db/pkg explicitly.
-
-20131020:
- AFFECTS: users of mail/squirrelmail
- AUTHOR: adamw@adamw.org
-
- The default location for user data files and attachments has changed.
- This will only affect new installations, and upgrading SquirrelMail
- WILL NOT break your current installation.
-
- To make use of the new locations, do the following:
-
- # cp -rp /var/spool/squirrelmail/pref/* /usr/local/www/squirrelmail/data
- # cp -rp /var/spool/squirrelmail/attach/* /usr/local/www/squirrelmail/attach
-
- and then run /usr/local/www/squirrelmail/configure and tell SM about
- it ("Data Directory" and "Attachment Directory" under "General Options").
-
- This version of SquirrelMail is a SNAPSHOT that brings in PHP 5.4 and 5.5
- compatibility.
-
-20131020:
- AFFECTS: users of security/gpgme
- AUTHOR: jhale@FreeBSD.org
-
- The library version of security/gpgme has changed, and PORTREVISION has
- been bumped in all dependent ports. If you have external software that
- depends on gpgme, this software needs to be recompiled.
- To recompile all software dependent on gpgme, run:
-
- # portmaster -r gpgme
- or
- # portupgrade -rf gpgme
-
-20131008:
- AFFECTS: all users
- AUTHOR: bapt@FreeBSD.org
-
- A new USES has been added: compiler.mk, this uses allows porters to
- select a compiler for a given port based on the features the port needs
- By default this will always try to find Clang > 3.3.
- If the user prefers using GCC then the following macro should be added
- to user's make.conf: FAVORITE_COMPILER=gcc
-
-20131004:
- AFFECTS: users of net-mgmt/nrpe2
- AUTHOR: ohauer@FreeBSD.org
-
- The port nrpe2 was updated and moved to nrpe
-
- # portmaster -o net-mgmt/nrpe net-mgmt/nrpe2
- or
- # portupgrade -fo net-mgmt/nrpe net-mgmt/nrpe2
- or
- # pkg set -o net-mgmt/nrpe2:net-mgmt/nrpe
-
-20131003:
- AFFECTS: users of lang/python* and ports
- AUTHOR: mva@FreeBSD.org
-
- The default versions of lang/python* have been changed to support the
- new DEFAULT_VERSIONS variable.
-
- PYTHON_DEFAULT_VERSION, PYTHON2_DEFAULT_VERSION and
- PYTHON3_DEFAULT_VERSION are deprecated. If you have set them in your
- make.conf, you should change them something like
-
- DEFAULT_VERSIONS=python=2.7 python2=2.7 python3=3.3
-
-20130929:
- AFFECTS: users of x11/pixman
- AUTHOR: zeising@FreeBSD.org
-
- The library version of x11/pixman has changed, and PORTREVISION has
- been bumped in all dependent ports. If you have external software that
- depends on pixman, this software needs to be recompiled.
- To recompile all software dependent on pixman, run:
-
- # portmaster -r pixman
- or
- # portupgrade -rf pixman
-
-20130929:
- AFFECTS: users of graphics/libGL, graphics/dri and other MESA ports
- AUTHOR: zeising@FreeBSD.org
-
- The graphics/libGL, graphics/dri and related MESA ports have been
- updated to 9.1 when compiled with WITH_NEW_XORG= set. It is necessary
- to remove the old versions of both ports before updating.
-
- # pkg_delete -f libGL-\* dri-\*
- or
- # pkg delete -f libGL dri
- followed by
- # portmaster -a
-
-20130925:
- AFFECTS: users of print/qpdf
- AUTHOR: d.y.kazarov@mail.ru
-
- Due to the changes in libqpdf.so, please deinstall qpdf first if you
- are updating from 4.0.0 to 4.0.1+
-
-20130920:
- AFFECTS: users of ptlib, opal and/or ekiga
- AUTHOR: kwm@FreeBSD.org
-
- The ptlib26, opal3 and ekiga3 ports where updated to the latest version
- and moved to the location of the old ports. If the ekiga (2.0) port is
- installed the same line as for ekiga3 can be used except without the 3 at
- the end.
-
- # portmaster -o devel/ptlib devel/ptlib26
- # portmaster -o net/opal net/opal3
- # portmaster -o net/ekiga3 net-im/ekiga
- or
- # portupgrade -fo devel/ptlib devel/ptlib26
- # portupgrade -fo net/opal net/opal3
- # portupgrade -fo net/ekiga3 net-im/ekiga
- or
- # pkg set -o devel/ptlib26 devel/ptlib
- # pkg set -o net/opal3 net/opal
- # pkg set -o net/ekiga3 net-im/ekiga
-
-20130920:
- AFFECTS: users of ports
- AUTHOR: bapt@FreeBSD.org
-
- New way to override the default version of a language in the ports
- tree.
-
- The make variable, DEFAULT_VERSIONS, allows users to override the
- default version defined by the ports tree.
-
- For example, to declare specific versions for Perl, Ruby and Tcl/Tk,
- it would be defined as:
-
- DEFAULT_VERSIONS= perl5=5.18 ruby=2.0 tcltk=8.6
-
- Today, this only is supported by Perl, Ruby, and Tcl/Tk.
-
-20130920:
- AFFECTS: users of ports
- AUTHOR: bdrewery@FreeBSD.org
-
- Optional Stack Protector [1] support has been added with the WITH_SSP_PORTS
- knob.
-
- WITH_SSP_PORTS= yes
-
- This currently is only supported on FreeBSD 10 amd64/i386 and earlier
- releases on amd64.
-
- The default SSP_CLFAGS is -fstack-protector, but -fstack-protector-all
- may optionally be set instead.
-
- To enable support, add WITH_SSP_PORTS=yes to your make.conf and rebuild all
- ports.
-
- # portmaster -af
- or
- # portupgrade -af
-
- [1] https://en.wikipedia.org/wiki/Buffer_overflow_protection
-
-20130904:
- AFFECTS: 10-CURRENT users with any port depending on converters/libiconv
- AUTHOR: madpilot@FreeBSD.org
-
- 10-CURRENT after r254273 (committed on August 13, 2013) has an
- implementation of iconv enabled by default in libc.
-
- NOTE: after r341775 (committed on January 29, 2014) and other
- following commits, a few ports, including devel/glib20, depend
- on the converters/libiconv again due to missing functionality in the
- base iconv implementation.
-
- Due to this change some major overhauling of the ports tree has
- been necessary to move the ports to using that implementation.
-
- People using pkgng binary packages should have little problems,
- "pkg upgrade" will update all software to not depend on libiconv
- anymore, once updated packages are available. Please make sure to
- perform a "pkg autoremove" after that and check that libiconv is
- correctly removed by it.
-
- If you are using ports the update requires some manual intervention.
- The following procedure should be followed:
-
- # pkg query %ro libiconv >ports_to_update
- # pkg delete -f libiconv
- # cat ports_to_update | xargs portmaster
-
- or:
-
- # pkg query %ro libiconv >ports_to_update
- # pkg delete -f libiconv
- # cat ports_to_update | xargs portupgrade -f
-
-20130831:
- AFFECTS: users of graphics/gdal
- AUTHOR: sunpoet@FreeBSD.org
-
- Due to changes in header files, please deinstall gdal first while updating
- from 1.9.x to 1.10.x.
-
-20130830:
- AFFECTS: users of mail/meta1
- AUTHOR: dinoex@FreeBSD.org
-
- The on disk format has changed.
- Please make sure that queue is empty before you update.
-
-20130817:
- AFFECTS: users of lang/python*
- AUTHOR: mva@FreeBSD.org
-
- The lang/python* ports do not install links to 2to3, idle, pydoc, python
- and other binaries anymore. Those were moved into the lang/python2 and
- lang/python3 ports respectively. This change brings us closer to the goal
- of making Python ports usable with different Python versions at the same
- time.
-
- If you have lang/python2* or lang/python3* installed, please also install
- the associated lang/python2 or lang/python3 port.
-
- 1. update lang/python2* and/or lang/python3*
- 2. install lang/python2 and/or lang/python3
- 3. install/update lang/python
-
-20130816:
- AFFECTS: users of graphics/opendx and math/octave-forge-octcdf
- AUTHOR: stephen@FreeBSD.org
-
- These two ports have changed the science/netcdf dependency to
- science/netcdf4. It is recommended that the science/netcdf package
- be deinstalled before rebuilding these ports, otherwise you are likely
- to face port conflicts when building future ports.
-
-20130806:
- AFFECTS: users of devel/eric4
- AUTHOR: bsam@FreeBSD.org
-
- Since PKGVERSION=4.5.13_1 the default file destination has changed from
- ${PYTHON_SITELIBDIR}/eric4 to ${DATADIR}.
-
-20130731:
- AFFECTS: users of glib20
- AUTHOR: kwm@FreeBSD.org
-
- The devel/gio-fam-backend port was removed in the glib 2.36 update.
- Since the gio-fam-backend port was used in USE_GNOME=glib20, all
- dependencies need to be rebuilt. The removal of gio-fam-backend isn't
- critical, glib20 using programs should work just fine if the port is still
- installed. It is not clear however, if glib20 will use the new kqueue
- backend or the old fam backend.
-
- Note that users of pkg packages can just run the pkg delete command after
- their next update.
-
- # portmaster -r gio-fam-backend
- # pkg_delete gio-fam-backend-\* (for pkgng: pkg delete gio-fam-backend)
- # portmaster -a
-
- or
-
- # portupgrade -rf gio-fam-backend
- # pkg_delete gio-fam-backend-\* (for pkgng: pkg delete gio-fam-backend)
- # portupgrade -a
-
-20130726:
- AFFECTS: users of Qt 3 and KDE 3
- AUTHOR: rene@FreeBSD.org
-
- All ports based on Qt 3 (including KDE 3 but also ports which used Qt 3
- as a graphical toolkit) expired on 20130701 because Qt 3 and KDE 3 were
- no longer maintained upstream. These ports have been removed today.
-
- Users of KDE 3 are advised to switch to another desktop environment
- provided in the Ports Collection, e.g. KDE 4 or Xfce.
-
- Users of Qt 3 are advised to upgrade to the Qt 4 counterpart(s).
-
-20130725:
- AFFECTS: users of net/openafs
- AUTHOR: bjk@FreeBSD.org
-
- The OpenAFS 1.6.5 release is a security release which requires substantial
- configuration changes to the AFS servers in addition to the software update,
- in order to be fully protected. The entry for OPENAFS-SA-2013-003 on
- http://www.openafs.org/security/ has links to the upgrade documentation.
- The procedure involves rekeying the cell to a non-DES krb5 key, stored in
- a krb5 keytab named rxkad.keytab in PREFIX/etc/openafs/server/.
-
-20130720:
- AFFECTS: users of japanese/mozc-server and japanese/mozc-el
- AUTHOR: hrs@FreeBSD.org
-
- The bin/mozc_emacs_helper program is now built and installed by
- japanese/mozc-server because the build processes are heavily
- overlapped with each other and the helper program does not depend on
- most of what mozc-server does actually. To upgrade them, please remove
- mozc-el first to prevent a conflict with the installed bin/mozc_emacs_helper.
-
-20130719:
- AFFECTS: users of sysutils/bacula-server, sysutils/bacula-client, sysutils/bacula-bat
- AUTHOR: dvl@FreeBSD.org
-
- The configuration files for bacula have been moved to PREFIX/etc/bacula.
- Move your existing configuration files to this directory after
- upgrading.
-
-20130718:
- AFFECTS: users of security/logcheck
- AUTHOR: glarkin@FreeBSD.org
-
- The logcheck port now provides a configuration option controlling
- installation of the crontab file. When installing the port interactively,
- the port option is enabled by default to mimic previous behavior.
-
- When the port is installed non-interactively (BATCH=yes) the crontab
- file *will not* be installed automatically. If the EXAMPLES port option
- is enabled, the crontab file can be installed manually at a later time
- from EXAMPLESDIR/crontab.in.
-
-20130718:
- AFFECTS: users of www/zend-framework
- AUTHOR: wg@FreeBSD.org
-
- zend-framework has been updated to 2.2.1 and old 1.12.0 has been copied
- to www/zend-framework1. If you wish to stay with the older version run:
-
- # portmaster -o www/zend-framework1 www/zend-framework
- or
- # portupgrade -fo www/zend-framework1 www/zend-framework
- or
- # pkg set -o www/zend-framework:www/zend-framework1
-
-20130714:
- AFFECTS: users of net/avahi-gtk
- AUTHOR: kwm@FreeBSD.org
-
- Avahi was updated to 0.6.31, due to changes in the avahi-gtk port it will
- be necessary to remove the avahi-gtk port before updating.
- Users of pkg packages can skip this step.
-
- # pkg_delete -f avahi-gtk\*
- or
- # pkg delete -f avahi-gtk
- followed by
- # portmaster net/avahi-gtk
- or
- # portupgrade net/avahi-gtk
-
-20130711:
- AFFECTS: users of dns/py-ldns
- AUTHOR: mat@FreeBSD.org
-
- The dns/py-ldns port now only installs the Python bits, and depends on
- dns/ldns. Because of that, you cannot just do a regular upgrade, it
- would install dns/ldns overwriting existing files and removing them when
- removing the old version of dns/py-ldns.
-
- # pkg_delete -f py-ldns-\*
- # cd /usr/ports/dns/py-ldns && make clean && make install clean
- or
- # pkg delete -fg py-ldns-\*
- # pkg install -f dns/py-ldns
-
-20130707:
- AFFECTS: users of www/ajaxplorer
- AUTHOR: madpilot@FreeBSD.org
-
- Ajaxplorer was updated to 5.0.1. This is a major update and some
- manual intervention may be needed.
-
- Before upgrading you should preserve the following files in WWWDIR
- (defaults to PREFIX/www/ajaxplorer) if you have customized them:
-
- conf/bootstrap_conf.php
- conf/bootstrap_context.php
- conf/bootstrap_plugins.php
- conf/bootstrap_repositories.php
-
- and put them back after the upgrade.
-
- If you are using a database backend you will need to manually
- update your database table using the sql script the port will
- install at WWWDIR/conf/conf/4.2.3-5.0.0-db-upgrade.sql
-
- Don't forget to check the documentation about upgrading from
- version 4.x at:
- http://ajaxplorer.info/ajaxplorer-5-0-0:/#Upgrade_from_4X_to_500
-
-20130706:
- AFFECTS: users of devel/apr1
- AUTHOR: ohauer@FreeBSD.org
-
- APR was updated to 1.4.8 and APR-util was updated to 1.5.2.
-
- Please rebuild all ports which are using functions from APR/APR-util
- such as Apache, Subversion, etc.
-
- # portmaster -r apr
- or
- # portupgrade -r devel/apr1
- or
- # pkg install -fR devel/apr1
-
-20130705:
- AFFECTS: users of x11/kdelibs4
- AUTHOR: kde@FreeBSD.org
-
- The KDE Software Compilation 4.10.4 was committed a few days ago, and
- version 4.10.5 was committed today.
-
- They include better support for using clang as the compiler, but that
- requires recompiling all KDE ports which depend on x11/kdelibs4. Most
- ports which fall into this category are already part of the KDE Software
- Compilation and have been updated to version 4.10.5, but those released
- separately need to be rebuilt manually.
-
- If you are building your KDE ports with clang, doing the following is
- recommended:
-
- # portmaster -r kdelibs-4\*
- or
- # portupgrade -fr x11/kdelibs4
- or
- # pkg install -fR x11/kdelibs4
-
- Alternatively, to avoid rebuilding the ports which are part of the 4.10.5
- update:
-
- # portmaster -x \*-4.10.5\* -r kdelibs-4\*
- or
- # portupgrade -x \*-4.10.5\* -fr x11/kdelibs4
-
-20130703:
- AFFECTS: users of comms/trustedqsl and comms/tqsllib
- AUTHOR: db@FreeBSD.org
-
- Upstream have removed the need for a separate port for the library
- formerly found in comms/tqsllib. Please remove tqsllib before installing
- trustedqsl
-
-20130627:
- AFFECTS: users of ports-mgmt/portmaster
- AUTHOR: bdrewery@FreeBSD.org
-
- Since June 22nd, portmaster no longer relies on 'WITH_PKGNG' to be defined,
- or ports to be checked out to enable pkgng support.
-
- It now considers whether or not pkg is installed and registered with itself.
-
- I.e., if this returns data, pkgng is considered in use:
-
- # pkg info pkg
-
- It's possible that you may have tested pkgng in the past, ran pkg2ng, and
- never fully committed to it by setting WITH_PKGNG. If this is the case,
- uninstall pkg with pkg_info/pkg_delete and also remove the stale database,
- rm /var/db/pkg/local.sqlite.
-
- This could manifest itself as portmaster -L showing the wrong versions, or
- portmaster no longer detecting installed packages correctly.
-
- Note that PORTS still require WITH_PKGNG=yes in make.conf if you are not
- running CURRENT.
-
-20130627:
- AFFECTS: users of net/samba36
- AUTHOR: timur@FreeBSD.org
-
- Samba has updated format of it's printing tdbs (ntprinting.tdb, ntforms.tdb,
- ntdrivers.tdb) to include character encoding. When updating from Samba 3.5
- or earlier to Samba 3.6 or 4.0 these tdbs need to be migrated to new registry
- based printing management. This implies also character conversion.
-
- You have to specify the correct code page for the conversion, see iconv -l.
- The mostly used one is Windows Latin1 which is CP1252.
-
- You can correctly view the tdb with:
-
- # net printing dump encoding=CP1252 /path/to/ntprinters.tdb
-
- or migrate it with e.g.:
-
- # net printing migrate encoding=CP1252 /path/to/ntprinters.tdb
-
- If you migrate printers it is suggest to do it in the following order:
-
- ntforms.tdb
- ntdrivers.tdb
- ntprinting.tdb
-
- Don't forget to rename, move or delete these files in /var/db/samba after
- the migration.
-
-20130623:
- AFFECTS: users of net-im/mikutter003
- AUTHOR: tota@FreeBSD.org
-
- net-im/mikutter003 has been removed from the ports tree because the
- Twitter API version 1.0 was deprecated on 2013-05-07 and mikutter003,
- which uses the API 1.0, won't work.
- Please consider using net-im/mikutter instead of this.
-
- 1. deinstall mikutter003
- 2. upgrade Ruby to 1.9( or later) (see the entry 20130527)
- 3. install net-im/mikutter
-
-20130623:
- AFFECTS: users of www/magento
- AUTHOR: melvyn@magemana.nl
-
- Magento has been updated to 1.7.0.2 on 2013-06-03. With it a stricter file
- system policy is enforced on the port. If you (or your customer) rely heavily
- on Magento Connect via the backend to install extensions, your quickfix is:
-
- # chown -R www: ${PREFIX}/www/magento
- # chmod -R u+w ${PREFIX}/www/magento
-
- The more conservative approach:
- # chown -R www: ${PREFIX}/www/magento/app/code/{local,community} \
- ${PREFIX}/www/magento/app/{design,locale} \
- ${PREFIX}/www/magento/{downloader,skin}
-
- # chmod -R u+w ${PREFIX}/www/magento/app/code/{local,community} \
- ${PREFIX}/www/magento/app/{design,locale} \
- ${PREFIX}/www/magento/{downloader,skin}
-
- The conservative approach will alert you to extensions that try to write in
- Magento core, while allowing clean extensions to install properly (corner
- cases may exist).
-
-20130619:
- AFFECTS: users of devel/subversion
- AUTHOR: ohauer@FreeBSD.org
-
- devel/subversion has been upgraded from 1.7.10 to 1.8.0
-
- If you want to upgrade, and use http/https access to repositories,
- please check, that the SERF option is enabled, as NEON support
- is gone. Also, mod_dontdothat and svnauthz_validate are
- now enabled with one option TOOLS, among other new tools
- and SVNMUCC is enabled always.
-
- subversion-1.7.x is available as devel/subversion17
-
- To stay on subversion-1.7.x set in /etc/make.conf
- WITH_SUBVERSION_VER=17
- and use the following command
-
- # pkg set -o devel/subversion:devel/subversion17
- or
- # portmaster -o devel/subversion17 devel/subversion
-
-20130614:
- AFFECTS: users who set port options in make.conf
- AUTHOR: tijl@FreeBSD.org
-
- Configuring options in make.conf using variables like OPTIONS_SET and
- OPTIONS_UNSET now also suppresses the option dialog for those options.
- This means that when building a port the option dialog will only appear if
- there are truly new options that have not been configured before using either
- the dialog or make.conf. This allows you to set options like DOCS, NLS,
- X11, etc. once for all ports and not have option dialogs pop up if those are
- the only options. For a list of variables you can set in make.conf to
- control options see Mk/bsd.options.mk.
-
-20130612:
- AFFECTS: users of lang/perl* and any port that depends on it
- AUTHOR: az@FreeBSD.org
-
- lang/perl5.12 has been upgraded from version 5.12.4 to 5.12.5
- lang/perl5.14 has been upgraded from version 5.14.2 to 5.14.4
- lang/perl5.16 has been upgraded from version 5.16.2 to 5.16.3
-
- The directory structure where Perl is installed has also been modified:
- "major.minor" is now used instead of "major.minor.patchlevel".
-
- The "perl-after-upgrade" script has been removed.
-
- Please rebuild all Perl ports and all ports that depend on it:
-
- # portmaster -r perl
- or
- # portupgrade -rf perl
- or
- # pkg install -fR perl
-
-20130609:
- AFFECTS: users of audio/flac and any port that depends on it
- AUTHOR: naddy@FreeBSD.org
-
- FLAC has been updated to 1.3.0 and the shared library versions
- have been bumped. Please rebuild all ports that depend on it:
-
- # portmaster -r flac
- or
- # portupgrade -fr audio/flac
- or
- # pkg install -fR audio/flac
-
-20130607:
- AFFECTS: Nobody
- AUTHOR: wxs@FreeBSD.org
-
- FreeBSD 8.4 released.
-
-20130604:
- AFFECTS: users of lang/ghc and */hs-*
- AUTHOR: haskell@FreeBSD.org
-
- The Glorious Glasgow Haskell Compiler has been updated to version
- 7.6.3 and Haskell Platform to 2013.2.0.0. Hence it is recommended to
- rebuild or reinstall all the dependent ports by one of the following
- commands:
-
- # portmaster -w -r ghc
- or
- # portupgrade -fr lang/ghc
- or
- # pkg install -fR lang/ghc
-
- Note that prefixes used for hs- ports (Cabal packages) have been
- changed to PREFIX/{lib,share,share/doc}/cabal/ghc-GHC_VERSION to
- enable more seamless upgrades in the future.
-
-20130603:
- AFFECTS: users of dns/opendnssec
- AUTHOR: wg@FreeBSD.org
-
- Some database changes have been made between version 1.3 and 1.4,
- upgrading needs to be done manually by running the following scripts:
-
- For MySQL users:
- PREFIX/share/opendnssec/migrate_adapters_1.mysql
-
- For SQLite users:
- PREFIX/share/opendnssec/migrate_adapters_1.sqlite3
-
- For the full migration explanation see:
- PREFIX/share/doc/opendnssec/MIGRATION
-
- opendnssec 1.3 version was preserved as dns/opendnssec13 port.
-
-20130601:
- AFFECTS: users of textproc/ack
- AUTHOR: rakuco@FreeBSD.org
-
- ack has been updated to version 2.04. It is slightly incompatible with some
- options present in ack1. For more information, see
- http://beyondgrep.com/ack-2.0.
-
-20130530:
- AFFECTS: users of irc/inspircd
- AUTHOR: swills@FreeBSD.org
-
- The irc/inspircd port has been updated to 2.0.12. Some of the config option
- names in the rc script have been changed. Check the script for more detail.
-
-20130527:
- AFFECTS: users of lang/ruby18
- AUTHOR: swills@FreeBSD.org
-
- The default ruby version has been updated from 1.8 to 1.9. First, stop any
- software that uses ruby. Then, you'll need to rebuild all ports that depend
- on ruby:
-
- If you use portmaster:
- # portmaster -o lang/ruby19 lang/ruby18
- # portmaster -R -r ruby-1.9
-
- If you use portupgrade:
- # portupgrade -f lang/ruby18
- # portupgrade -f lang/ruby19 # if you have it installed
- # portupgrade -f ports-mgmt/portupgrade
- # portupgrade -x ruby-1.8.\* -fr lang/ruby18
-
- After these steps are complete, you can pkg_delete ruby 1.8 if you
- no longer need it.
-
- If you use pkgng:
- # pkg set -o lang/ruby18:lang/ruby19
- # pkg install -fR lang/ruby19
-
- If you wish to keep the 1.8 version as default, add the following lines
- to your /etc/make.conf file:
-
- #
- # Keep ruby 1.8 as default version.
- #
- RUBY_DEFAULT_VER=1.8
-
-20130525:
- AFFECTS: users of sysutils/rsyslog5*
- AUTHOR: brd@FreeBSD.org
-
- Rsyslog 5.x has reached end of life status and has therefore been removed.
- While sysutils/rsyslog6* exists, please consider migrating to
- sysutils/rsyslog7 as that is the currently supported release.
-
-20130525:
- AFFECTS: users of mail/postgrey
- AUTHOR: Darren Pilgrim <ports.maintainer@evilphi.com>
-
- The RC script for postgrey has been modified. If you use the
- default value for postgrey_flags this does not affect you.
-
- If you have postgrey listening on a Unix socket or set any optional
- values, please read the comments in the RC scripts and check your
- settings in rc.conf prior to restarting postgrey.
-
-20130525:
- AFFECTS: users of x11/xorg and all xorg ports
- AUTHOR: zeising@FreeBSD.org
-
- X.Org, including libraries and some drivers, was updated. If you are
- running the default X.Org distribution, no special upgrade procedure
- should be necessary.
-
- If you are running with WITH_NEW_XORG= make sure to update and rebuild
- all installed drivers since xorg-server has been updated.
-
-20130520:
- AFFECTS: users of textproc/elasticsearch
- AUTHOR: tj@FreeBSD.org
-
- This is the first stable release based on Lucene 4. We recommend testing
- the upgrade before doing it in production.
-
- Upgrading from 0.20 requires a full cluster restart.
-
- In order to be able to downgrade, stop indexing new data, issue a flush
- request, do the upgrade and only enable indexing of new data once you
- are certain that you no longer need to downgrade. Once new data has
- been indexed, downgrading is no longer possible. To be extra safe, back
- up your data before upgrading.
-
-20130519:
- AFFECTS: users of net/activemq
- AUTHOR: tj@FreeBSD.org
-
- The JVM used by activemq has changed to OpenJDK 7. You will need to
- make sure javavmwrapper is configured to use the installed
- java/openjdk7 JVM.
-
-20130512:
- AFFECTS: users of devel/hs-git-annex
- AUTHOR: haskell@FreeBSD.org
-
- On FreeBSD, git-annex incorrectly calculated SHA256 hashes for files
- added to the annex repository due to the BSD-style output of
- /sbin/sha256. The result of this is silent data corruption.
-
- This problem has been fixed, but every file stored in an annex
- repository will fail a `git-annex fsck` after the upgrade. Thus,
- before updating, it is wise to issue the command below and restore the
- files.
-
- $ git-annex uninit
-
- Corruptions can then be found by finding all files with the same hash.
- Note that only files that were mishashed to the same location are a
- problem.
-
-20130511:
- AFFECTS: users of TeX
- AUTHOR: hrs@FreeBSD.org
-
- One can now choose TeXLive or teTeX by using TEX_DEFAULT.
- Specifying TEX_DEFAULT=texlive, almost all of ports which use TeX
- will install and depend on TeXLive-based ones. Note that the
- default value is still "tetex" and the two cannot coexist. You need
- to remove all of the TeX-related packages based on teTeX to try
- TeXLive.
-
-20130507:
- AFFECTS: users of comms/usbmuxd or comms/libimobiledevice
- AUTHOR: avilla@FreeBSD.org
-
- libusbmuxd and libimobiledevice versions have changed. Please, rebuild
- all the ports that depend on them:
-
- # portmaster -r usbmuxd
- or
- # portupgrade -fr comms/usbmuxd
- or
- # pkg install -fR comms/usbmuxd
-
-20130507:
- AFFECTS: users of devel/libplist
- AUTHOR: avilla@FreeBSD.org
-
- libplist Python bindings were split from the main port. To get them you
- need to install devel/py-libplist.
-
-20130506:
- AFFECTS: users of TeX
- AUTHOR: hrs@FreeBSD.org
-
- TeXLive ports have been imported. Although most of ports still depend
- on teTeX at this moment, they will be converted to use TeXLive.
-
- The directory layout of them is as follows. Please use print/texlive-full
- if you are not familiar with how each component works. Finer-grained
- ports will be added (specifically, meta ports for smaller installation
- and so on). Note that the full installation needs around 3GB of disk space.
-
- teTeX-based ports and TeXLive are mutually exclusive. This means TeXLive
- ports cannot be installed when teTeX is already installed. You need
- to remove all of the TeX-related packages based on teTeX to try TeXLive.
- Migration procedure will be announced when conversion of the port
- dependency is completed.
-
- * Meta port
- - print/texlive-full: meta port to install all of the TeXLive components
-
- * Libraries
- - devel/tex-kpathsea: kpathsea library
- - devel/tex-web2c: WEB2C toolchain and TeX engines
- - print/tex-ptexenc: character code conversion library for pTeX
-
- * Base part of the TeXLive
- - print/texlive-base: binary programs in TeXLive
- - print/texlive-texmf: macro and font data in TeXLive
- - print/texlive-infra: tlmgr dependency (Perl modules)
- - print/tex-formats:
-
- * TeX Formats
- - print/tex-formats: TeX, LaTeX, PDFTeX, AMSTeX, ConTeXT, CSLaTeX,
- EplainTeX, METAFONT, MLTeX, PDFTeX, TeXsis
- - print/tex-aleph: Aleph/Lambda
- - print/tex-xetex: XeTeX
- - print/tex-luatex: LuaTeX
- - print/tex-jadetex: JadeTeX
- - print/tex-xmltex: XMLTeX
- - japanese/tex-ptex: pTeX
-
- * DVI ware
- - print/tex-xdvik: XDvi
-
-20130503:
- AFFECTS: users of security/libgcrypt and any port that depends on it
- AUTHOR: ehaupt@FreeBSD.org
-
- The libgcrypt port has been updated to 1.5.2 and all shared libraries
- versions have been bumped. So you need to rebuild all applications that
- depend on libgcrypt. Do something like:
-
- # portmaster -r libgcrypt
- or
- # portupgrade -rf libgcrypt
-
- Alternatively, you may install sysutils/bsdadminscripts, run pkg_libchk and
- rebuild all detected ports:
-
- # pkg_libchk | tee /tmp/rebuild
- # awk -F':' '/libgcrypt.so/ {print $1}' /tmp/rebuild | sort | uniq \
- | xargs portmaster -D
-
-20130502:
- AFFECTS: users of ports-mgmt/pkg, ports-mgmt/poudriere, ports-mgmt/tinderbox
- AUTHOR: bdrewery@FreeBSD.org
-
- This only affects people who are _building_ binary packages for pkgng. If you
- are building from ports please ignore this. This step is optional.
-
- It is recommended to rebuild all packages and then have your users run 'pkg
- check -Ba' and 'pkg upgrade' on their servers once. This will allow the new
- shlib tracking to reinstall packages that have changed shlib requirements.
-
-20130427:
- AFFECTS: users of print/a2ps-{a4,letter}, print/c2ps-{a4,letter}, print/lprps-{a4,letter}, or graphics/jpeg2ps-{a4,letter}
- AUTHOR: hrs@FreeBSD.org
-
- The affected ports have been converted to use libpaper for the default paper
- size as print/psutils did. For more detail, see 20130424 below.
-
-20130424:
- AFFECTS: users of print/psutils-a4 or print/psutils-letter
- AUTHOR: hrs@FreeBSD.org
-
- print/psutils-a4 and print/psutils-letter have been merged into a single port
- print/psutils. The default paper size in psnup(1), psresize(1), and
- pstops(1) is now selected via an environment variable and/or a configuration
- file of libpaper(3). For more detail, see papersize(5) and paperconfig(8)
- manual page. If you prefer A4 or letter size by default as the old
- version did, please install print/papersize-default-a4 or
- print/papersize-default-letter, which installs a papersize configuration
- file without manual configuration.
-
-20130423:
- AFFECTS: users of mail/postfix
- AUTHOR: sahil@FreeBSD.org
-
- This is a significant update; so, please carefully review the
- RELEASE_NOTES to identify which incompatible changes impact your
- environment.
-
-20130408:
- AFFECTS: users of astro/libkgeomap, graphics/digikam-kde4, graphics/kipi-plugins-kde4
- AUTHOR: makc@FreeBSD.org
-
- Digikam ports have been updated and split. Previous versions have
- to be deinstalled before upgrade:
-
- # pkg_delete -f digikam-2\* kipi-plugins-2\* libkgeomap-2\*
- or
- # pkg delete -fg digikam-2\* kipi-plugins-2\* libkgeomap-2\*
-
-20130403:
- AFFECTS: users of mail/thunderbird-esr*
- AUTHOR: flo@FreeBSD.org
-
- Mozilla stopped providing 2 versions of thunderbird. The only one lives
- in mail/thunderbird if you are using thunderbird-esr please switch to
- thunderbird by running on of the following commands.
-
- # portupgrade -o mail/thunderbird mail/thunderbird-esr
- # portupgrade -o mail/thunderbird-i18n \
- mail/thunderbird-esr-i18n (if installed)
-
- or
-
- # portmaster -o mail/thunderbird mail/thunderbird-esr
- # portmaster -o mail/thunderbird-i18n \
- mail/thunderbird-esr-i18n (if installed)
-
-20130331:
- AFFECTS: users of */hs-*
- AUTHOR: haskell@FreeBSD.org
-
- Due to some unexpected dynamic linking problems, Haskell Cabal ports with
- binaries that link to their own libraries may not work. With default
- configuration, the following ports are known to have this problem:
- Agda, BNFC, pandoc, and uuagc. (Their port revision are now bumped.)
-
- In general, it is recommended to rebuild the port if you are
- experiencing that the corresponding binary will not start, e.g.:
-
- % agda
- Shared object "libHSAgda-2.3.2-ghc7.4.2.so" not found, required by "agda"
-
-20130329:
- AFFECTS: users of ports-mgmt/portmaster
- AUTHOR: bdrewery@FreeBSD.org
-
- Portmaster 3.15 should be skipped if you are not using pkgng and are on
- 9.1, 8-STABLE, 9-STABLE, or CURRENT. It may require manual upgrading to
- 3.16:
-
- # make -C /usr/ports/ports-mgmt/portmaster build deinstall install clean
-
-20130329:
- AFFECTS: users of net/kio-upnp-ms
- AUTHOR: avilla@FreeBSD.org
-
- A wrong setting in x11/kdelibs4 was causing some unlisted files to
- be installed. Remember to delete them after updating x11/kdelibs4 to
- 4.10.1_1:
-
- # rm /usr/local/kde4/bin/upnpmstest
- # rm /usr/local/kde4/bin/stattest
- # rm /usr/local/kde4/bin/recursive_upnp
-
-20130327:
- AFFECTS: users of mail/opensmtpd
- AUTHOR: ashish@FreeBSD.org
-
- Privilege separation is enabled in OpenSMTPD port from 5.3,1. Users
- upgrading from version 201303011853 or earlier are required to follow
- the instructions in pkg-message to fix the filesystem permissions on
- OpenSMTPD spool directories.
-
-20130327:
- AFFECTS: users of KDE SC 4
- AUTHOR: kde@FreeBSD.org
-
- KDE SC ports have been updated to 4.10.1. kdelibs4 does no longer
- directly use aspell or hspell, to regain their functionality enable
- corresponding option in textproc/enchant.
- A number of ports have been split and must be deinstalled before
- upgrading:
-
- # pkg_delete -f kdegames-4\* kde-workspace-4\* kde-wallpapers-4\*
- or
- # pkg delete -fg kdegames-4\* kde-workspace-4\* kde-wallpapers-4\*
-
-20130326:
- AFFECTS: users of deskutils/strigi
- AUTHOR: makc@FreeBSD.org
-
- Strigi port has been split on libraries, client, daemon, and utilities.
- Manual update is required:
-
- # cd /usr/ports/deskutils/strigi && make deinstall && \
- make clean && make install clean
- or
- # pkg delete -f strigi && pkg upgrade && pkg install deskutils/strigi
-
-20130323:
- AFFECTS: users of archivers/libarchive
- AUTHOR: glewis@FreeBSD.org
-
- The archivers/libarchive port has been updated to 3.1.2. The shared library
- version has changed from 12 to 14. Please rebuild all ports that depend on
- it:
-
- # portmaster -r libarchive
- or
- # portupgrade -fr archivers/libarchive
- or
- # pkg install -fR archivers/libarchive
-
-20130319:
- AFFECTS: users of ports
- AUTHOR: bdrewery@FreeBSD.org
-
- Ports now use ports-mgmt/dialog4ports to render and interact with the
- options dialog in 'make config'. This will be automatically built and
- installed on the first use.
-
- dialog4ports provides a new UI able to represent all the features provided
- by the new options framework.
-
-20130319:
- AFFECTS: users of net/freerdp
- AUTHOR: fluffy@FreeBSD.org
-
- The net/freerdp package was changed API and require to deinstall previous
- version first to avoid build conflicts.
-
-20130317:
- AFFECTS: users of graphics/poppler
- AUTHOR: gnome@FreeBSD.org
-
- The graphics/poppler has been updated to 0.22.2. The shared library version
- has changed from 18 to 34. Please rebuild all ports that depends on it:
-
- # portmaster -r poppler-0
- or
- # portupgrade -fr graphics/poppler
- or
- # pkg install -fR graphics/poppler
-
-20130317:
- AFFECTS: users of devel/protobuf
- AUTHOR: vanilla@FreeBSD.org
-
- The devel/protobuf has been updated to 2.5.0. The shared library version
- has changed from 7 to 8. Please rebuild all ports that depends on it:
-
- # portmaster -r protobuf
- or
- # portupgrade -fr devel/protobuf
- or
- # pkg install -fR devel/protobuf
-
-20130316:
- AFFECTS: users of converters/libiconv and devel/gettext
- AUTHOR: bapt@FreeBSD.org
-
- libiconv now handles the lib/charset.alias file instead of devel/gettext.
- If you are using pkgng 'and' upgrading from source with portupgrade or
- portmaster, first delete gettext, upgrade libiconv, then reinstall gettext.
-
- This will break sudo, so you *must* do this in a root shell (sudo -i)
- if you use sudo.
-
- # pkg delete -f devel/gettext
- # portmaster converters/libiconv devel/gettext
- or
- # pkg delete -f devel/gettext
- # portupgrade converters/libiconv devel/gettext
-
-20130308:
- AFFECTS: users of net-im/folks and devel/libgee
- AUTHOR: kwm@FreeBSD.org
-
- folks and libgee have been repocopied net-im/folks04 and devel/libgee06
- respectively. Please do the following according to package manager used.
-
- # portmaster -o devel/libgee06 devel/libgee
- # portmaster -o net-im/folks04 net-im/folks
- or
- # portupgrade -fo devel/libgee06 devel/libgee
- # portupgrade -fo net-im/folks04 net-im/folks
- or
- # pkg set -o devel/libgee:devel/libgee06
- # pkg set -o net-im/folks:net-im/folks04
-
-20130307:
- AFFECTS: users of textproc/elasticsearch
- AUTHOR: tj@FreeBSD.org
-
- textproc/elasticsearch has been updated to 0.20.5. This update also
- changes the required JDK to OpenJDK 7 as there are known issues when
- running on a Java 1.6 JDK.
-
-20130307:
- AFFECTS: users of audio/liblastfm
- AUTHOR: nivit@FreeBSD.org
-
- The audio/liblastfm has been updated to 1.0.6. The shared library version
- has changed from 0 to 1. Please rebuild all ports that depends on it:
-
- If you use portmaster:
- portmaster -r liblastfm
- If you use portupgrade:
- portupgrade -fr audio/liblastfm
- If you use pkgng with binary packages:
- pkg install -fR audio/liblastfm
-
-20130305:
- AFFECTS: users of devel/py-setuptools (i.e you)
- AUTHOR: rm@FreeBSD.org
-
- devel/py-setuptools was replaced with devel/py-distribute. Please do
- the following according to package manager used. py-setuptools port
- will be removed shortly.
-
- # portmaster -o devel/py-distribute devel/py-setuptools
- or
- # portupgrade -fo devel/py-distribute devel/py-setuptools
- or
- # pkg set -o devel/py-setuptools:devel/py-distribute
- # pkg install -f devel/py-distribute
-
-20130226:
- AFFECTS: users of textproc/apache-solr
- AUTHOR: vanilla@FreeBSD.org
-
- textproc/apache-solr has been repocopied to textproc/apache-solr3.
- If you need to continue with the old stable version please run
-
- # portmaster -o textproc/apache-solr3 textproc/apache-solr
- or
- # portupgrade -fo textproc/apache-solr3 textproc/apache-solr
- or
- # pkg set -o textproc/apache-solr:textproc/apache-solr3
-
-20130218:
- AFFECTS: users of net/samba4-devel
- AUTHOR: timur@FreeBSD.org
-
- The port was renamed into net/samba4 and is going to replace older
- development version of Samba4. You can upgrade it with:
-
- # portmaster -o net/samba4 net/samba4-devel
-
- In case you want to upgrade from net/samba36 make sure, that you've
- made backup of /usr/local/etc/smb.conf and the content of /var/db/samba/
- directory.
-
- There is no direct upgrade path from Samba3 to Samba4, but you can
- always try:
-
- # portmaster -o net/samba4 net/samba36
-
- Make sure you've read instructions from the supplied README.FreeBSD
- file and read all the relevant pages on http://wiki.samba.org/
-
- We still miss necessary support for Samba4 from base ntpd and bind9,
- port versions are also are not ready yet, but been worked on.
-
- Please note, that Samba4 is still in it's early days, so there are
- bugs both from my side and it's own, so be careful with placing it
- into production.
-
-20130206:
- AFFECTS: users of sysutils/boxbackup
- AUTHOR: bdrewery@FreeBSD.org
-
- The default location of the configuration files changed from
- /usr/local/etc/box to /usr/local/etc/boxbackup. Move your
- configuration after upgrading:
-
- mv /usr/local/etc/box /usr/local/etc/boxbackup
-
-20130206:
- AFFECTS: users of x11/wbar
- AUTHOR: nivit@FreeBSD.org
-
- wbar has been updated to 2.3.4. The new version uses a different icon
- for the dock background, so you have to replace the old one in your
- config file ~/.wbar
-
- Replace
-
- i: /usr/local/share/pixmaps/wbar/osxbarback.png
-
- with
-
- i: /usr/local/share/pixmaps/wbar/dock.png
-
-20130206:
- AFFECTS: users of security/libtasn1 and any port that depends on it
- AUTHOR: novel@FreeBSD.org
-
- libtasn1 has been updated to 2.14 and all shared libraries versions have
- been bumped. So you need to rebuild all applications that depend on
- libtasn1.
-
- If you use portmaster:
- portmaster -r libtasn1
- If you use portupgrade:
- portupgrade -fr security/libtasn1
- If you use pkgng with binary packages:
- pkg install -fR security/libtasn1
-
-20130206:
- AFFECTS: users of Tcl/Tk
- AUTHOR: gahr@FreeBSD.org
-
- The following ports have been removed, as threads and modules are
- now included in the main ports:
-
- - lang/tcl84-thread
- - lang/tcl85-thread
- - lang/tcl86-thread
- - lang/tcl-modules
- - x11-toolkits/tk84-thread
- - x11-toolkits/tk85-thread
- - x11-toolkits/tk86-thread
-
- Please remove them ...
-
- If you use pkgng:
- pkg delete -f <port>
-
- If you use pkg_* tools
- pkg_delete -f <port>
-
- ... before rebuilding all ports that depend on them:
-
- If you use portmaster:
- portmaster -w -r <port>
-
- If you use portupgrade:
- portupgrade -Ofr <origin/port>
-
- If you use pkgng with binary packages:
- pkg install -fR <origin/port>
-
-20130205:
- AFFECTS: users of lang/ghc and */hs-*
- AUTHOR: haskell@FreeBSD.org
-
- Note that the recent devel/libffi update caused some breakage in the Haskell
- ports with the DYNAMIC option enabled. The problem has been identified and
- fixed since then. All Haskell ports have been updated to their latest stable
- versions or bumped as DYNAMIC is enabled by default.
-
- Hence it is recommended to rebuild or reinstall all ports depending on GHC
- by one of the following commands:
-
- # portmaster -w -r ghc
- or
- # portupgrade -fr lang/ghc
- or
- # pkg install -fR lang/ghc
-
-20130205:
- AFFECTS: users of editors/libreoffice
- AUTHOR: bapt@FreeBSD.org
-
- LibreOffice has been updated to 3.6.5 with a bundle version of libcmis. The
- build will fail if you sill have net/libcmis 0.1 installed. Before upgrading
- LibreOffice you should either first remove libcmis from your system or upgrade
- it to version 0.3.
-
-20130205:
- AFFECTS: users of security/gnutls and any port that depends on it
- AUTHOR: novel@FreeBSD.org
-
- gnutls has been updated to 2.12.23 and all shared libraries versions have
- been bumped. So you need to rebuild all applications that depend on
- gnutls.
-
- If you use portmaster:
- portmaster -r gnutls
- If you use portupgrade:
- portupgrade -fr security/gnutls
- If you use pkgng with binary packages:
- pkg install -fR security/gnutls
-
-20130204:
- AFFECTS: users of sysutils/zfstools
- AUTHOR: bdrewery@FreeBSD.org
-
- The zfstools package has dropped the 'rubygem-' prefix and now installs
- its binary files to PREFIX/sbin instead of PREFIX/bin.
-
-20130204:
- AFFECTS: users of multimedia/qt4-phonon, multimedia/qt4-phonon-gst
- AUTHOR: makc@FreeBSD.org
-
- qt4-phonon has been deprecated in favour of multimedia/phonon. Remove
- WITH_QT_PHONON from your make.conf and replace qt4-phonon with
- multimedia/phonon:
-
- # portmaster -o multimedia/phonon multimedia/qt4-phonon
- # portmaster -o multimedia/phonon-gstreamer multimedia/qt4-phonon-gst
-
-20130204:
- AFFECTS: users of lang/perl5.8 and lang/perl5.10
- AUTHOR: az@FreeBSD.org
-
- lang/perl5.8 and lang/perl5.10 have been removed since they've
- been EOL by upstream. You will have to recompile all perl dependant
- ports after updating your ports tree. Please see entry 20110517 for help.
-
-20130204:
- AFFECTS: users of dns/poweradmin
- AUTHOR: Edmondas Girkantas <eg@fbsd.lt>
-
- Some database changes have been made between version 2.1.5 and 2.1.6,
- upgrading needs to be done manually by running the following SQL:
-
- For MySQL users:
-
- ALTER TABLE users MODIFY username VARCHAR(64) NOT NULL DEFAULT '0';
- ALTER TABLE users MODIFY password VARCHAR(128) NOT NULL DEFAULT '0';
-
- For PostgreSQL users:
-
- ALTER TABLE users ALTER COLUMN username TYPE VARCHAR(64);
- ALTER TABLE users ALTER COLUMN password TYPE VARCHAR(128);
-
-20130203:
- AFFECTS: users of KDE SC 4
- AUTHOR: kde@FreeBSD.org
-
- KDE SC ports have been updated to 4.9.5. kdemultimedia4, kdenetwork4,
- kde-runtime and kde-workspace ports have been split, they must be
- deinstalled before running any port upgrade tool:
-
- # pkg_delete -f kdemultimedia-4\* kdenetwork-4\* \
- kde-workspace-4\* kde-runtime-4\*
-
-20130202:
- AFFECTS: users of net-p2p/deluge
- AUTHOR: rm@FreeBSD.org
-
- deluge port had switched to using libtorrent-rasterbar 0.16 as backend. Since
- both of the versions of libtorrent are conflicting with each other, you need
- to deinstall libtorrent-rasterbar-15 and libtorrent-rasterbar-15-python first
- and then update deluge as usual. Please also keep in mind, that deluge does
- not work via http-proxy when libtorrent-rasterbar 0.16 is used.
-
-20130131:
- AFFECTS: users of devel/boost-libs
- AUTHOR: bapt@FreeBSD.org
-
- boost has been updated to 1.52.0. Please rebuild all ports that depends
- on it:
-
- If you use portmaster:
- portmaster -w -r boost-libs
- If you use portupgrade:
- portupgrade -fr devel/boost-libs
- If you use pkgng with binary packages:
- pkg install -fR devel/boost-libs
-
-20130129:
- AFFECTS: users of textproc/elasticsearch
- AUTHOR: tj@FreeBSD.org
-
- elasticsearch has been updated to 0.20.4. This upgrade requires a
- full cluster restart after installation.
-
- Upgrade steps:
- 1) Shutdown all cluster nodes
- 2) Install elasticsearch update
- 3) Start all cluster nodes
-
-20130128:
- AFFECTS: users of libffi
- AUTHOR: jkim@FreeBSD.org
-
- libffi has been updated to 3.0.11. Please rebuild all ports that
- depends on it:
-
- If you use portmaster:
- portmaster -w -r libffi
- If you use portupgrade:
- portupgrade -fr devel/libffi
- If you use pkgng with binary packages:
- pkg install -fR devel/libffi
-
-20130121:
- AFFECTS: users of mail/opensmtpd
- AUTHOR: ashish@FreeBSD.org
-
- Please flush your mail queue before updating to version 201301191220.
-
-20130116:
- AFFECTS: users of games/py-anki
- AUTHOR: araujo@FreeBSD.org
-
- games/py-anki has been removed upstream and merged with games/anki.
- Users of games/py-anki, from now must use games/anki.
-
-20130114:
- AFFECTS: users of www/hiawatha
- AUTHOR: cs@FreeBSD.org
-
- php-fcgi has been removed upstream from hiawatha and is not supported anymore.
- It is recommended to move to another FastCGI implementation, e.g. PHP-FPM
- (lang/php5).
-
-20130113:
- AFFECTS: users of security/openvpn*
- AUTHOR: mandree@FreeBSD.org
-
- security/openvpn has been upgraded to the IPv6-capable v2.3.0.
- This upgrade moves easy-rsa into a separate package in
- security/easy-rsa that is pre-selected as default run-time dependency,
- and changes installed file layout a bit.
-
- security/openvpn22 retains the prior OpenVPN 2.2.2 version.
- If you want to continue using this version, use one of these commands:
-
- # portmaster -o security/openvpn22 security/openvpn
- or
- # portupgrade -o security/openvpn22 security/openvpn
- or
- # pkg set -o security/openvpn:security/openvpn22
-
- security/openvpn20 has been marked deprecated and to be removed
- in half a year's time. Please migrate to a newer version soonish.
-
-20130110:
- AFFECTS: everyone using csup(1), net/cvsup, or cvs(1) to update the
- ports tree
- AUTHOR: wblock@FreeBSD.org
-
- On February 28, 2013, the CVSup and CVS services will end:
- http://lists.freebsd.org/pipermail/freebsd-ports-announce/2012-September/000026.html
-
- csup(1), net/cvsup, and cvs(1) will no longer be able to update the
- ports tree. Please switch to one of the alternate update methods of
- portsnap(8) or devel/subversion before that time. The Handbook has
- information on using these update methods:
- http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/ports-using.html
-
-20130108:
- AFFECTS: users of devel/libvanessa_socket, mail/perdition
- AUTHOR: jhale@FreeBSD.org
-
- The update of devel/libvanessa_socket to 0.0.12 (used by Perdition)
- adds IPv6 support. If the hostname in bind_address has both IPv4 and
- IPv6 addresses in DNS, then Perdition will ONLY listen on IPv6.
-
- If you prefer to continue to use IPv4, you need to change the
- bind_address in /usr/local/etc/perdition/perdition.conf to use an
- explicit IPv4 address. This can be in addition to, or instead of,
- the current hostname, depending on whether you want to use IPv6 or
- not. If your Perdition server does not have an IPv6 address
- listed in DNS, this change does not affect you.
-
-20130108:
- AFFECTS: users of sysutils/cfengine*
- AUTHOR: gjb@FreeBSD.org
-
- sysutils/cfengine has been created as a master port for the set of
- sysutils/cfengine* ports. Users interested in tracking the latest
- stable branch of cfengine should update their port origins to use
- the new port, for example:
-
- # portmaster -o sysutils/cfengine sysutils/cfengine33
- or
- # portupgrade -fo sysutils/cfengine sysutils/cfengine33
- or
- # pkg set -o sysutils/cfengine33:sysutils/cfengine
-
- Users that switch their port origin and later wish to remain on
- a particular cfengine release can override the default version by
- adding CFENGINE_VERSION to /etc/make.conf, where CFENGINE_VERSION
- is a value from:
-
- # make -V VERSIONS
-
-20130103:
- AFFECTS: users of textproc/docproj*
- AUTHOR: doceng@FreeBSD.org
-
- textproc/docproj no longer requires WITH_JADETEX to be set to 'yes' or
- 'no', and by default, will enable the JADETEX dependencies.
-
- The textproc/docproj-jadetex port has been removed as a result of this
- change.
-
- Users that have installed textproc/docproj and have set
- WITH_JADETEX=no during compile time should update the package origin
- to use textproc/docproj-nojadetex:
-
- # portmaster -o textproc/docproj textproc/docproj-nojadetex
- or
- # portupgrade -fo textproc/docproj textproc/docproj-nojadetex
- or
- # pkg set -o textproc/docproj-nojadetex:textproc/docproj
-
- Users that have installed textproc/docproj-jadetex should update the
- package origin to use the textproc/docproj port:
-
- # portmaster -o textproc/docproj textproc/docproj-jadetex
- or
- # portupgrade -fo textproc/docproj textproc/docproj-jadetex
- or
- # pkg set -o textproc/docproj-jadetex:textproc/docproj
-
- Users that have installed textproc/docproj and have set
- WITH_JADETEX=yes will not need to make any changes.
-
-20130103:
- AFFECTS: users of audio/baresip
- AUTHOR: crees@FreeBSD.org
-
- Baresip is tightly linked to the versions of audio/re and audio/rem, and
- will not build against different versions.
-
- To update without problems, the -R flag for portupgrade is mandatory, or
- build will fail. Portmaster and pkgng will handle this correctly.
-
-20130103:
- AFFECTS: users of emulators/virtualbox-ose
- AUTHOR: decke@FreeBSD.org
-
- VirtualBox has been updated and does now depend on devel/kBuild instead
- of devel/kBuild-devel. Both are in conflict with each other so this has
- to be resolved manually. kBuild is only a build dependency so it is safe
- to remove installed kBuild before updating.
-
- # pkg_delete -f kBuild-\*
-
-20130102:
- AFFECTS: users of mail/opensmtpd
- AUTHOR: ashish@FreeBSD.org
-
- OpenSMTPD port has been updated to the latest portable snapshot. There
- has been several changes to the configuration between the last version
- and this version, which requires configuration file need to be reviewed.
-
-20121230:
- AFFECTS: Nobody
- AUTHOR: wxs@FreeBSD.org
-
- FreeBSD 9.1 released.
-
-20121229:
- AFFECTS: users of devel/libical
- AUTHOR: gnome@FreeBSD.org
-
- The devel/libical has been updated to 0.48. The shared library version has
- been changed from 44 to 0. Please rebuild all ports that depends on it:
-
- If you use portmaster:
- portmaster -r libical
- If you use portupgrade:
- portupgrade -fr devel/libical
- If you use pkgng with binary packages:
- pkg install -fR devel/libical
-
-20121228:
- AFFECTS: users of databases/innotop, multimedia/zoneminder
- net-mgmt/netdot, ports-mgmt/tinderbox, ports-mgmt/tinderbox-devel
- sysutils/watchmen, www/MT
-
- The above mentioned ports were converted to depend on
- databases/p5-DBD-mysql. That will cause messages like
-
- ===> p5-DBD-mysql-4.021 conflicts with installed package(s):
- p5-DBD-mysql55-4.021
-
- To prevent this run one of the following commands to fix the
- dependencies.
-
- # portmaster -o databases/p5-DBD-mysql databases/p5-DBD-mysql55
- or
- # portupgrade -fo databases/p5-DBD-mysql databases/p5-DBD-mysql55
- or
- # pkg set -o databases/p5-DBD-mysql55:databases/p5-DBD-mysql
-
-20121220:
- AFFECTS: users of lang/ghc and */hs-*
- AUTHOR: haskell@FreeBSD.org
-
- Note that the Glorious Glasgow Haskell Compiler has been updated to
- version 7.4.2.
-
- Please rebuild or reinstall all dependent ports by issuing one of the
- following commands, depending on the tool used:
-
- # portmaster -w -r ghc
- or
- # portupgrade -fr lang/ghc
- or
- # pkg install -fR lang/ghc
-
-20121218:
- AFFECTS: users of icu
- AUTHOR: bapt@FreeBSD.org
-
- icu has been updated to 50.1. Please rebuild all ports that depend on it:
-
- If you use portmaster:
- portmaster -w -r icu
- If you use portupgrade:
- portupgrade -fr devel/icu
- If you use pkgng with binary packages:
- pkg install -fR devel/icu
-
-20121212:
- AFFECTS: users of openldap24-client who uses SASL
- AUTHOR: Xin Li <delphij@FreeBSD.org>
-
- There is a change in the openldap24-client port which removes the SASL
- option. If the user previously install openldap24-client, but enabled
- SASL from the config menu, the user would have to replace it with
- openldap24-sasl-client.
-
- Note that this only affects those who manually set SASL from the menu,
- most of the users are not affected.
-
- If you use portmaster:
- portmaster -o net/openldap24-sasl-client openldap24-client
- If you use portupgrade:
- portupgrade -fo net/openldap24-sasl-client openldap24-client
- If you use pkgng with binary packages:
- pkg set -o net/openldap24-client:net/openldap24-sasl-client
-
-20121212:
- AFFECTS: users of horde-* applications
- AUTHOR: Martin Matuska <mm@FreeBSD.org>
-
- Horde3 has reached EOL and to make place for new horde application versions
- all old horde3 applications have been renamed to use the "horde3-" prefix.
-
-20121211:
- AFFECTS: users of graphics/ImageMagick
- AUTHOR: bdrewery@FreeBSD.org
-
- The ImageMagick library has been updated to version 6.8.0-7. Please
- rebuild all ports that depend on it.
-
- If you use portmaster:
- portmaster -w -r ImageMagick
- If you use portupgrade:
- portupgrade -fr graphics/ImageMagick
- If you use pkgng with binary packages:
- pkg install -fR graphics/ImageMagick
-
-20121211:
- AFFECTS: users of devel/pcre
- AUTHOR: bdrewery@FreeBSD.org
-
- The pcre library has been updated to version 8.32. Please
- rebuild all ports that depend on it.
-
- If you use portmaster:
- portmaster -w -r pcre
- If you use portupgrade:
- portupgrade -fr devel/pcre
- If you use pkgng with binary packages:
- pkg install -fR devel/pcre
-
-20121210:
- AFFECTS: users of security/cyrus-sasl2
- AUTHOR: ume@FreeBSD.org
-
- The cyrus-sasl2 library has been updated to version 2.1.26. Please
- rebuild all ports that depend on it.
-
- If you use portmaster:
- portmaster -w -r cyrus-sasl-
- If you use portupgrade:
- portupgrade -fr security/cyrus-sasl2
-
-20121202:
- AFFECTS: users of www/owncloud
- AUTHOR: crees@FreeBSD.org
-
- www/owncloud includes the entire WWWDIR directory structure in pkg-plist.
-
- This means that if you upgrade it, your config files are added to pkg-plist,
- and are then removed on the next deinstall.
-
- This issue has been fixed, but you must back up your install of owncloud and
- reinstall to avoid data loss;
-
- # cd /usr/ports/www/owncloud
- # tar cfC /tmp/owncloud.tar `make -VWWWDIR` .
- # make deinstall
- # tar xfC /tmp/owncloud.tar `make -VWWWDIR`
- # make install clean && rm /tmp/owncloud.tar
-
-20121201:
- AFFECTS: users of www/typo3
- AUTHOR: Helmut Ritter <freebsd-ports@charlieroot.de>
-
- www/typo3 has been repocopied to www/typo347. If you need to continue with
- the old stable version please run
-
- # portmaster -o www/typo347 www/typo3
- or
- # portupgrade -fo www/typo347 www/typo3
- or
- # pkg set -o www/typo3:www/typo347
-
-20121128:
- AFFECTS: users of irc/znc
- AUTHOR: jase@FreeBSD.org
-
- znc has been updated to 1.0. This introduces some major changes to its
- functionality. As a result, if you are upgrading from a previous version
- you need to be aware that znc will automatically modify your
- configuration file to incorporate support for the new functionality.
- Users are recommended to take a backup of their configuration file
- before running this new version.
-
- The SASL option has been renamed to CYRUS following a rename of the
- associated module. Additionally, a number of modules have been removed
- or renamed in this release.
-
- Modules that were classed as Extra modules in previous versions are now
- built as standard. The EXTRA option has been removed accordingly.
-
- Please refer to the following URL for detailed information regarding all
- changes in this release:
-
- http://wiki.znc.in/ChangeLog/1.0
-
-20121128:
- AFFECTS: users of www/opera
- AUTHOR: itetcu@FreeBSD.org
-
- If you are running KDE and you are using KDE's File dialog toolkit, and if
- your Opera crashes on start with a 'libpng error: incorrect data check'
- you can work around it by setting 'Dialog Toolkit=4' in your
- .opera/operaprefs.ini [File Selector] section.
-
-20121112:
- AFFECTS: users of devel/git
- AUTHOR: wxs@FreeBSD.org
-
- The git-daemon(1) process now runs as the git_daemon user. Please make
- sure that this user has appropriate permissions to the repositories.
-
-20121109:
- AFFECTS: FreeBSD < 9.1 users of syslog-ng >= 3.3.6
- AUTHOR: cy@FreeBSD.org
-
- Syslog-ng version 3.3.6 changed the way how /dev/kmsg is read. If you
- don't use the system() source (which configures it automatically),
- please make sure, that in the kmsg related line follow-freq(1) is used
- instead of the previously default follow-freq(0).
-
-20121109:
- AFFECTS: users of devel/py-liblarch_gtk deskutils/gtg
- AUTHOR: rm@FreeBSD.org
-
- Code of py-liblarch_gtk has been merged into py-liblarch 2.1.0. To avoid
- any conflicts, user need to remove py-liblarch_gtk before the update of
- py-liblarch.
-
-20121105:
- AFFECTS: users of mail/postfix-current
- AUTHOR: sahil@FreeBSD.org
-
- With this version of Postfix, the default master.cf now uses "unix"
- instead of "fifo" for the pickup and qmgr services. In addition, a
- new smtpd_relay_restrictions feature has been introduced for mail
- relay control. For sites that do not define this parameter in
- main.cf, the upgrade process will add an entry to main.cf. Please
- read the RELEASE_NOTES to understand this new feature, how it may
- affect your site, and backwards compatibility options.
-
-20121104:
- AFFECTS: users of lang/perl5.16
- AUTHOR: az@FreeBSD.org
-
- lang/perl5.16 has been updated to 5.16.2. You should update everything
- that depends on perl. The easiest way to do that is to use
- "perl-after-upgrade" script supplied with lang/perl5.16.
- Please see its manual page for details.
-
- If you are using binary packages with pkgng, not ports, do this instead of
- "perl-after-upgrade":
-
- # pkg install -fR perl
-
-20121102:
- AFFECTS: users of shells/bash-completion
- AUTHOR: adamw@FreeBSD.org
-
- The bash completion library has been updated to 2.0, and the mechanism
- for activating the library has changed. To use the library, you must:
-
- source /usr/local/share/bash-completion/bash_completion.sh
-
- from your .bashrc file. See the pkg-message or README for a more
- graceful invocation.
-
-20121101:
- AFFECTS: users of graphics/tesseract
- AUTHOR: bf@FreeBSD.org
-
- The trained English and OSD language data that were distributed in
- graphics/tesseract have been moved to graphics/tesseract-data. The
- latter port includes all available trained language data by default;
- as before, users who desire a subset of languages may build smaller
- packages by defining TESSERACT_LANGS during a build.
-
-20121031:
- AFFECTS: users of dns/ldns
- AUTHOR: ak@FreeBSD.org
-
- There is a binary incompatibility in ldns 1.6.14 which is fixed with an
- emergency release of ldns 1.6.15.
-
- Warning!
- If you have compiled ldns using software with ldns-1.6.14, then this new
- version will be binary incompatible with your installed version. You
- will have to recompile the software together with ldns-1.6.15.
-
- Was the software compiled with ldns-1.6.13 or earlier, then you will not
- have this problem and can safely install ldns-1.6.15.
-
-20121030:
- AFFECTS: users of www/squid31
- AUTHOR: flo@FreeBSD.org
-
- The WITH_SQUID_ECAP option was removed from the port. If you use ECAP
- you need to update to www/squid32, you can do so by running one of the
- following commands:
-
- # portmaster -o www/squid32 www/squid31
- or
- # portupgrade -fo www/squid32 www/squid31
-
-20121025:
- AFFECTS: users of net/activemq
- AUTHOR: tj@FreeBSD.org
-
- After reinstalling the port, if you wish to use the datastore used before
- or have any undelivered persistent messages add the following to rc.conf:
-
- activemq_data=/usr/local/activemq
-
-20121022:
- AFFECTS: users of net/samba36
- AUTHOR: timur@FreeBSD.org
-
- Startup rc.d/samba script was modified to address some problems with the
- fine control of supplementary daemons. As a side effect now it's always
- necessary to specify in rc.conf:
-
- samba_enable=YES
-
- to get the script working. You can still control each of the daemons
- individually, by disabling/enabling them with:
-
- nmbd_enable=NO
- smbd_enable=NO
- winbindd_enable=YES
-
-20121015:
- AFFECTS: users of ports-mgmt/portmaster
- AUTHOR: bdrewery@FreeBSD.org
-
- Portmaster now supports pkgng. To use pkgng, enable the patch in the port,
- enable pkgng in your make.conf, and convert your existing /var/db/pkg
- database. Also see UPDATING entry 20121010 if you are on a recent CURRENT
- and do not want to use pkg.
-
- This is optional and not currently required.
-
- # make -C /usr/ports/ports-mgmt/pkg install clean
- # make -C /usr/ports/ports-mgmt/portmaster config build deinstall install clean
- # echo 'WITH_PKGNG=yes' >> /etc/make.conf
- # pkg2ng
-
-20121015:
- AFFECTS: users of ports-mgmt/portupgrade
- AUTHOR: bdrewery@FreeBSD.org
-
- Portupgrade now supports pkgng. To use pkgng, enable it in your make.conf,
- and convert your databases.
-
- This is optional and not currently required.
-
- # make -C /usr/ports/ports-mgmt/pkg install clean
- # echo 'WITH_PKGNG=yes' >> /etc/make.conf
- # pkg2ng
- # pkgdb -fu
-
-20121010:
- AFFECTS: users of mail/enigmail*
- AUTHOR: gecko@FreeBSD.org
-
- Enigmail has been integrated into the Thunderbird / SeaMonkey build and
- is available as option ENIGMAIL (enabled by default)
-
- Before upgrading Thunderbird or SeaMonkey delete all installed enigmail
- ports by running e.g.
-
- # pkg_delete -f seamonkey-enigmail-1.4.3 thunderbird-esr-enigmail-1.4.3 \
- thunderbird-enigmail-1.4.3
-
-20121010:
- AFFECTS: users of CURRENT (OSVERSION >= 1000017)
- AUTHOR: bapt@FreeBSD.org
-
- The ports tree is now using pkgng as the default package manager
- for HEAD. This only affects users of CURRENT -- users of other
- branches need not take any action.
-
- To keep pkg_install as the default package manager, use the new
- WITHOUT_PKGNG knob in make.conf
-
- To make the switch:
-
- 1) Set WITHOUT_PKGNG=yes in make.conf and upgrade all your ports to
- the latest available versions using your favourite tools.
-
- 2) Install ports-mgmt/pkg
-
- 3) Remove WITHOUT_PKGNG from make.conf and run:
-
- # pkg2ng
-
-20121009:
- AFFECTS: users of multimedia/vdpau-video
- AUTHOR: madpilot@FreeBSD.org
-
- vdpau-video has been renamed upstream to libva-vdpau-driver. The
- port has been changed accordingly.
-
- Please update the port origins as follows:
-
- # portmaster -o multimedia/libva-vdpau-driver multimedia/vdpau-video
- or
- # portupgrade -fo multimedia/libva-vdpau-driver multimedia/vdpau-video
- or
- # pkg set -o multimedia/vdpau-video:multimedia/libva-vdpau-driver
-
-20121008:
- AFFECTS: users of mail/squirrelmail
- AUTHOR: adamw@FreeBSD.org
-
- The locale data, including translations and associated help files,
- have been moved to mail/squirrelmail-translations. If you or your
- users are using Squirrelmail in anything other than en_US, you should
- install that port.
-
-20121007:
- AFFECTS: users of lang/mit-scheme
- AUTHOR: olgeni@FreeBSD.org
-
- The lang/mit-scheme port was converted to OptionsNG, and now uses
- the standard PGSQL knob rather than POSTGRESQL. Be sure to check
- your configuration before rebuilding.
-
-20121006:
- AFFECTS: users of devel/geany-plugins
- AUTHOR: makc@FreeBSD.org
-
- devel/geany-plugins has been updated to 1.22 and split into numerous
- devel/geany-plugin-* ports. geany-plugins must be deinstalled before
- running any port upgrade utility.
-
-20121002:
- AFFECTS: users of devel/clanlib
- AUTHOR: jhale@FreeBSD.org
-
- devel/clanlib has been updated to 2.3.6 and the legacy version has been
- moved to devel/clanlib1 and updated to 1.0.0. Although both versions
- may be installed at the same time, you should update your port origins
- first since many ports that depend on clanlib will not work with the
- new version.
-
- Update your port origins as follows:
-
- # portmaster -o devel/clanlib1 devel/clanlib
- or
- # portupgrade -fo devel/clanlib1 devel/clanlib
- or
- # pkg set -o devel/clanlib:devel/clanlib1
-
-20120928:
- AFFECTS: users of mail/maildrop
- AUTHOR: madpilot@FreeBSD.org
-
- With the update to 2.6.0 of mail/maildrop the following executable
- files:
-
- bin/deliverquota -> bin/maildrop-deliverquota
- bin/maidirmake -> bin/maildrop-maildirmake
-
- have been renamed to avoid colliding with files installed from
- other ports. Man pages and HTML files in DOCSDIR relating to these
- files have also been renamed accordingly.
-
-20120925:
- AFFECTS: users of www/linux-f10-flashplugin11
- AUTHOR: eadler@FreeBSD.org
-
- After reinstalling the port make sure to run nspluginwrapper -v -a -u
- for each user that uses the plugin.
-
-20120924:
- AFFECTS: users of textproc/aspell
- AUTHOR: bapt@FreeBSD.org
-
- textproc/aspell no longer installs the English dictionary. If you need it
- please install textproc/en-aspell.
-
-20120919:
- AFFECTS: users of net-mgmt/better-cacti-templates
- AUTHOR: Bryan Drewery <bdrewery@FreeBSD.org>
-
- better-cacti-templates has been renamed as the upstream has merged
- with Percona Monitoring Plugins.
-
- Update your port origins as follows:
-
- # portmaster -o net-mgmt/percona-monitoring-plugins net-mgmt/better-cacti-templates
- or
- # portupgrade -fo net-mgmt/percona-monitoring-plugins net-mgmt/better-cacti-templates
- or
- # pkg set -o net-mgmt/better-cacti-templates:net-mgmt/percona-monitoring-plugins
-
-20120916:
- AFFECTS: users of german/webalizer2, japanese/webalizer, polish/webalizer2, portuguese/webalizer-pt_BR, portuguese/webalizer-pt_PT, ukrainian/webalizer, www/geolizer, www/webalizer
- AUTHOR: dinoex@FreeBSD.org
-
- The default Berkeley DB has changed, so existing DNS caches needs to be
- rebuild or choose the option BDB1 in the port.
-
-20120913:
- AFFECTS: users of sysutils/bacula-server, sysutils/bacula-client
- AUTHOR: rm@FreeBSD.org
-
- If you have both sysutils/bacula-server and sysutils/bacula-client
- installed, you need to pkg_delete them both prior to this update.
-
-20120910:
- AFFECTS: users of www/libxul
- AUTHOR: gecko@FreeBSD.org
-
- The www/libxul has been updated to 10.0 and the older version 1.9.2
- has moved to www/libxul19.
-
- If you want to stay with 1.9.2 please run the following command:
-
- # portmaster -o www/libxul19 www/libxul
- or
- # portupgrade -o www/libxul19 www/libxul
- or
- # pkg set -o www/libxul:www/libxul19
-
-20120909:
- AFFECTS: users of www/testlink
- AUTHOR: tota@FreeBSD.org
-
- Testlink 1.9.4 was released. Before updating, you should read carefully
- the included README file or go to www.teamst.org (Forum: TestLink 1.9.4
- News, changes, etc) because this release requires a manual update of the
- database scheme.
-
-20120908:
- AFFECTS: users of irc/bitlbee, irc/irssi-otr, net-im/climm, net-im/mcabber, net/kdenetwork4, security/kopete-otr, security/py-otr
- AUTHOR: Doug Barton <dougb@FreeBSD.org>
-
- The libotr library has been bumped in version 4.0.0, and the new version is
- not compatible with the old. In order to make it possible for both versions
- to coexist in the short term the old version has been moved to a new port.
-
- If you are currently using pidgin-otr:
- # pkg_delete -f pidgin-otr\*
-
- Then:
- # portmaster -o security/libotr3 security/libotr
- # portmaster -r libotr
- or
- # portupgrade -o security/libotr3 security/libotr
- # portupgrade -r libotr
- or
- # pkg set -o security/libotr:security/libotr3
-
-20120902:
- AFFECTS: users of www/apache22, www/apache22-event-mpm, www/apache22-itk-mpm, www/apache22-peruser-mpm, www/apache22-worker-mpm
- AUTHOR: ohauer@FreeBSD.org
-
- The port use now the options NG framework, this means WITH_xxx
- directives are no longer valid.
-
- Additional:
- - APR only specific options like THREADS, MYSQL, PGSQL, SQLITE,
- BDB and IPV6 where removed.
- - PKGNAME has changed from apache-2... to apache22-2...
- - PROXY is now a MULTI directive which means at last one additional
- PROXY_(AJP|BALANCER|CONNECT|FTP|HTTP|SCGI) module is required.
- - CGI is only a valid option for MPM prefork, peruser and itk.
-
-20120902:
- AFFECTS: users of devel/apr1
- AUTHOR: ohauer@FreeBSD.org
-
- APR was updated to 1.4.6 and APR-util was updated to 1.4.1.
-
- Please rebuild all ports which are using functions from
- APR/APR-util such as apache, subversion ...
-
- # portmaster -r apr
- or
- # portupgrade -r devel/apr1
- or
- # pkg install -fR devel/apr1
-
-20120902:
- AFFECTS: users of math/cantor and math/kalgebra
- AUTHOR: kde@FreeBSD.org
-
- If you have both cantor and kalgebra installed, chances are that
- your cantor installation is corrupted. If the file
- ${KDE4_PREFIX}/lib/kde4/cantor_kalgebrabackend.so is missing on
- your system, rebuild cantor after updating kalgebra to 4.8.4_1 (or
- later).
-
-20120822:
- AFFECTS: users of net/asterisk16, net/asterisk16-addons
- AUTHOR: Florian Smeets <flo@FreeBSD.org>
-
- asterisk16 has been unsupported upstream for a while now and has known
- security vulnerabilities, therefore it was removed from the ports tree.
- People still running net/asterisk16 should upgrade to net/asterisk.
-
- First delete the asterisk addons, as they are part of asterisk now.
-
- # pkg_delete -f asterisk16-addons\*
-
- after that you can run one of the following
-
- # portmaster -o net/asterisk net/asterisk16
- or
- # portupgrade -o net/asterisk net/asterisk16
- or
- # pkg set -o net/asterisk16:net/asterisk
-
- After that you need to update your configuration. Take a look at the following
- URL for the changes between 1.6 and 1.8
-
- http://svnview.digium.com/svn/asterisk/branches/1.8/UPGRADE.txt
-
-20120820:
- AFFECTS: users of ports-mgmt/portupgrade-devel
- AUTHOR: bdrewery@FreeBSD.org
-
- Due to a bug introduced in 20120601, portupgrade is unable to
- upgrade itself on FreeBSD 7.x. This has been fixed in 20120820.
- ports-mgmt/portupgrade is not affected. To upgrade, execute the following:
-
- # make -C /usr/ports/ports-mgmt/portupgrade-devel all deinstall install clean
-
-20120817:
- AFFECTS: users of games/unnethack
- AUTHOR: knu@FreeBSD.org
-
- The place for variable files has changed from
- $PREFIX/share/unnethack to $PREFIX/var/games/unnethack. To keep
- your saved files and game records, please manually move the
- following files and directories to the new directory after
- upgrading.
-
- logfile
- perm
- record
- xlogfile
- bones/
- level/
- saves/
-
-20120816:
- AFFECTS: users of sysutils/cfengine*
- AUTHOR: gjb@FreeBSD.org
-
- The sysutils/cfengine* ports have been renamed as follows:
-
- o sysutils/cfengine -> sysutils/cfengine22
- o sysutils/cfengine3-legacy -> sysutils/cfengine32
- o sysutils/cfengine3 -> sysutils/cfengine33
-
- Users are reminded to update the port origins, for example:
-
- # portmaster -o sysutils/cfengine22 sysutils/cfengine
- or
- # portupgrade -fo sysutils/cfengine22 sysutils/cfengine
- or
- # pkg set -o sysutils/cfengine:sysutils/cfengine22
-
-20120815:
- AFFECTS: users of lang/erlang
- AUTHOR: olgeni@FreeBSD.org
-
- The lang/erlang port was updated to R15B01. Some port options
- were updated, so be sure to run "make config" in the port directory
- and check your configuration before upgrading.
-
- To upgrade Erlang and rebuild all of the dependent ports under
- the new environment:
-
- # portmaster -r erlang
- or
- # portupgrade -r lang/erlang
-
-20120815:
- AFFECTS: users of lang/erlang-lite
- AUTHOR: olgeni@FreeBSD.org
-
- The lang/erlang-lite port uses the same default options as
- lang/erlang, which were changed some time ago.
-
- The couchdb, rabbitmq, freeswitch-core and freeswitch-core-devel
- ports have been updated to use lang/erlang rather than lang/erlang-lite.
-
- Please check that your lang/erlang options are configured as you
- wish (especially X11 support), then follow the instructions below
- to update your dependencies.
-
- # portmaster -o lang/erlang lang/erlang-lite
- or
- # portupgrade -fo lang/erlang erlang-lite
-
-20120810:
- AFFECTS: users of net-p2p/transmission-gtk2
- AUTHOR: crees@FreeBSD.org
-
- Unfortunately Transmission 2.61 moved the requirement for GTK to version
- 3.2.0, which is not yet in our tree.
-
- Those who wish to have a graphical client can either choose transmission-qt4
- in the meantime, or switch to the transmission25 ports.
-
- A script to generate appropriate commands can be found at:
- http://people.FreeBSD.org/~crees/scripts/transmission25.sh
-
-20120808:
- AFFECTS: users of www/libmicrohttpd
- AUTHOR: bdrewery@FreeBSD.org
-
- libmicrohttpd has been updated to version 0.9.21, with a shared library bump.
- This requires dependent ports to be rebuilt.
-
- # portmaster -r libmicrohttpd
- or
- # portupgrade -r www/libmicrohttpd
- or
- # pkg install -fR www/libmicrohttpd
-
-20120804:
- AFFECTS: users of graphics/libglut
- AUTHOR: x11@FreeBSD.org
-
- The libglut library is replaced by the freeglut library.
- Due to shlib version bump all glut users should be rebuild.
- Please follow the instructions below to upgrade.
-
- # portmaster -o graphics/freeglut graphics/libglut
- # portmaster -r freeglut
- or
- # env DISABLE_CONFLICTS=1 portupgrade -fo graphics/freeglut libglut\*
- # portupgrade -frx freeglut freeglut
- or
- # pkg set -o graphics/libglut:graphics/freeglut
- # pkg install -Rf graphics/freeglut
-
-20120801:
- AFFECTS: users of editors/emacs
- AUTHOR: ashish@FreeBSD.org
-
- GNU Emacs port is updated to 24.1. Emacs 23 is moved to editors/emacs23.
-
- If you prefer to stick with Emacs 23, please specify EMACS_PORT_NAME=emacs23
- in /etc/make.conf, and do:
-
- # portmaster -o editors/emacs23 editors/emacs
- or
- # env DISABLE_CONFLICTS=1 portupgrade -fo editors/emacs23 editors/emacs
- or
- # pkg set -o editors/emacs:editors/emacs23
-
-20120726:
- AFFECTS: users of www/firefox, www/seamonkey, mail/thunderbird, www/libxul
- AUTHOR: gecko@FreeBSD.org
-
- Gecko ports were switched to use system libraries. Some of them
- must be built with certain options set (default).
-
- - graphics/png has to be installed with APNG option
-
- - databases/sqlite3 has to be installed with SECURE_DELETE, THREADSAFE,
- FTS3, UNLOCK_NOTIFY options
-
-20120726:
- AFFECTS: users of devel/pkg-config
- AUTHOR: bapt@FreeBSD.org
-
- devel/pkg-config has been replaced by devel/pkgconf
-
- # portmaster -o devel/pkgconf devel/pkg-config
- or
- # portupgrade -fo devel/pkgconf pkg-config-\*
-
- pkgng:
- # pkg set -o devel/pkg-config:devel/pkgconf
- # pkg install -f devel/pkgconf
-
-20120725:
- AFFECTS: users of chinese/fcitx
- AUTHOR: lichray@gmail.com
-
- The textproc/fcitx-keyboard port is merged into chinese/fcitx.
- Before updating, be sure to
-
- # pkg_delete -f fcitx-keyboard-\*
-
- And make sure you have at least one keyboard layout based input method
- enabled in fcitx-configtool, to keep the activation/deactivation of IM
- panel working.
-
- And, since chinese/fcitx-sunpinyin depends on an update to
- chinese/sunpinyin
-
-20120725:
- AFFECTS: users of www/py-beautifulsoup
- AUTHOR: rm@FreeBSD.org
-
- Current www/py-beautifulsoup has been moved to www/py-beautifulsoup32,
- since 4.1.1 is now current stable version.
-
- If you prefer to stick with 3.2.0 do:
-
- # portmaster -o www/py-beautifulsoup32 www/py-beautifulsoup
-
-20120723:
- AFFECTS: users of security/snort
- AUTHOR: zi@FreeBSD.org
-
- The database output modules have been deprecated. If you need this
- functionality please look at the security/barnyard2 port.
-
-20120723:
- AFFECTS: users of graphics/ImageMagick and graphics/ImageMagick-nox11
- AUTHOR: mm@FreeBSD.org
-
- The options for ImageMagick have been changed to match commonly used
- option names. If you are using a customized build, please reconfigure
- your port options with "make config".
-
-20120720:
- AFFECTS: users of net/spread and net/spread4
- AUTHOR: ohauer@FreeBSD.org
-
- The ports net/spread and net/spread4 are using now the
- reserved UID/GID 282 instead (user|group)next.
-
-20120722:
- AFFECTS: users of mail/mutt
- AUTHOR: crees@FreeBSD.org
-
- mail/mutt-devel has been moved to mail/mutt, since 1.5 has been around
- for a while.
-
- Should you wish to stick with version 1.4 at this time;
-
- # portmaster -o mail/mutt14 mutt
-
-20120721:
- AFFECTS: users of audio/libogg
- AUTHOR: naddy@FreeBSD.org
-
- There is a new version of libogg (1.3.0) and the shared library version
- has been bumped (ogg.7 to ogg.8). All ports that have an identifiable
- direct dependency on this library have had their PORTREVISIONs bumped.
- However, some ports that pull in the library indirectly may continue to
- look for the old version. To ensure that all are updated, perform this
- step:
-
- # portmaster -r libogg
- or
- # portupgrade -rf libogg
-
-20120717:
- AFFECTS: users of ftp/proftpd
- AUTHOR: mm@FreeBSD.org
-
- The options of ProFTPD have been made much more user-friendly.
- As the modules are all shared libraries, all possible modules are built
- and installed. The following modules are now in separate slave ports:
-
- databases/proftpd-mod_sql_odbc: mod_sql_odbc
- databases/proftpd-mod_sql_sqlite: mod_sql_sqlite
- databases/proftpd-mod_sql_tds: mod_sql_tds
- net/proftpd-mod_ldap: mod_ldap and mod_quotatab_ldap
-
-20120716:
- AFFECTS: users of www/lighttpd
- AUTHOR: mm@FreeBSD.org
-
- The following port options have been reorganized:
- The OPENLDAP option has been renamed to LDAP.
- The MAGNET and CML options have been withdrawn in favor of new LUA option.
-
-20120716:
- AFFECTS: users of mail/postfix-current
- AUTHOR: sahil@FreeBSD.org
-
- The postscreen-to-smtpd protocol has changed. To avoid "cannot
- receive connection attributes" warnings and dropped connections,
- execute the command "postfix reload".
-
-20120716:
- AFFECTS: Nobody
- AUTHOR: beat@FreeBSD.org
-
- The FreeBSD ports tree switched from CVS to Subversion. A Subversion
- to CVS exporter is in place to continue the support of CVSup.
-
-20120709:
- AFFECTS: users of math/metis
- AUTHOR: bf@FreeBSD.org
-
- The older version of metis has been moved to math/metis4, and
- math/metis has been updated to 5.0.2. Dependent ports still use
- the old API, and the different versions of metis cannot coexist, so
- most users should update with:
-
- # portmaster -o math/metis4 math/metis
- # portmaster -r math/metis4
-
- or the equivalent.
-
-20120702:
- AFFECTS: users of databases/couchdb
- AUTHOR: crees@FreeBSD.org, Adam Strohl <adams-ports@ateamsystems.com>
-
- The couchdb port has an unfortunate side effect; versions before 1.2.0
- will clobber local.ini. The port will refuse to build if that file is
- present and an earlier version is installed, however no such protection
- can be afforded to package installation.
-
- To upgrade from 1.1.0 and earlier, simply move PREFIX/etc/couchdb/local.ini
- out of the way until the upgrade is complete.
-
-20120702:
- AFFECTS: users of net-im/mikutter
- AUTHOR: tota@FreeBSD.org
-
- The net-im/mikutter has been updated to 0.1.1.810 which is required
- Ruby 1.9.2 or later. Before upgrading this port, please see the entry
- 20110822 in this file to upgrade Ruby to 1.9.
-
- If you want to stay with 0.0.3 (requires Ruby 1.8.7, 1.9.2 or later),
- please run the following command:
-
- # portmaster -o net-im/mikutter003 net-im/mikutter
- or
- # portupgrade -o net-im/mikutter003 net-im/mikutter
-
-20120630:
- AFFECTS: users of lang/perl*
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.16 is out. If you want to switch to it from, for example
- lang/perl5.12, that is:
-
- Portupgrade users:
- 0) Fix pkgdb.db (for safety):
- pkgdb -Ff
-
- 1) Reinstall new version of Perl (5.16):
- env DISABLE_CONFLICTS=1 portupgrade -o lang/perl5.16 -f perl-5.12.\*
-
- 2) Reinstall everything that depends on Perl:
- portupgrade -fr perl
-
- Portmaster users:
- portmaster -o lang/perl5.16 lang/perl5.12
-
- Conservative:
- portmaster p5-
-
- Comprehensive (but perhaps overkill):
- portmaster -r perl-
-
- Note: If the "perl-" glob matches more than one port you will need to
- specify the name of the Perl directory in /var/db/pkg explicitly.
-
- The default version for Perl has also been changed from 5.12 to 5.14.
-
-20120623:
- AFFECTS: users of sysutils/xfce4-utils
- AUTHOR: xfce@FreeBSD.org
-
- The port has been discontinued, and installs files that conflict with
- the new versions of misc/xfce4-appfinder and x11-wm/xfce4-session.
-
- # pkg_delete -f xfce4-utils-\*
- # portmaster misc/xfce4-appfinder x11-wm/xfce4-session
-
-20120618:
- AFFECTS: users of databases/db5
- AUTHOR: mandree@FreeBSD.org
-
- The databases/db5 port has been upgraded to BerkeleyDB 5.3. This
- entails a shared library bump.
-
- Before upgrading this port, check if your applications use
- transactional data bases, and if they do, prepare them for a log file
- format upgrade. YOU MUST DO THIS BEFORE YOU UPGRADE THE DB5 PORT! See:
- http://docs.oracle.com/cd/E17076_02/html/upgrading/upgrade_process.html
-
- All packages that depend on db5 need to be rebuilt due to the shared
- library version change. The full changelog is at
- http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
-
- To upgrade the packages that need Berkeley DB 5, please
- issue one of the following commands (depending on your preferred tool):
-
- # portmaster -r db5-5
- or
- # portupgrade -fr databases/db5
-
-20120616:
- AFFECTS: users of www/lighttpd
- AUTHOR: mm@FreeBSD.org
-
- The lighttpd startup script has been changed and is now compatible to the
- apache startup script. The "reload" subcommand now sends a SIGHUP to the
- process and triggers cycling of log files. The new command "graceful"
- performs a graceful restart (similar to former "reload") and "gracefulstop"
- performs a graceful stop. The "check" command has been replaced with
- the "configtest" command.
-
-20120615:
- AFFECTS: users of databases/akonadi
- AUTHOR: kde@FreeBSD.org
-
- The latest Akonadi update includes critical bug fixes. Manual
- intervention is required for people using local MySQL database (the
- default configuration) as backend:
-
- $ akonadictl stop
-
- Wait a bit, and make sure that akonadiserver and akonadi_control are
- not running. Kill them if needed. Then, you have two alternatives:
-
- $ mysql_install_db --force \
- --defaults-file=~/.local/share/akonadi/mysql.conf \
- --datadir=~/.local/share/akonadi/db_data \
- --basedir=$(dirname `dirname $(which mysql_install_db)`)
- $ rm ~/.local/share/akonadi/mysql.conf
-
- ...or...
-
- $ rm -r ~/.local/share/akonadi
-
- In the latter case, Akonadi will have to recache your personal data
- (might take a while). Akonadi is only a cache, no data will be lost.
- Then:
-
- $ akonadictl start
-
-20120613:
- AFFECTS: users of graphics/djvulibre and graphics/djvulibre-nox11
- AUTHOR: bf@FreeBSD.org
-
- DjVuLibre been updated to 3.5.25.3. The Qt 3.x GUI support that was in
- graphics/djvulibre has been removed (users of this GUI should consider
- switching to the new Qt 4.x GUI in graphics/djview4), and
- graphics/djvulibre-nox11 has been merged back into graphics/djvulibre.
- To update DjVuLibre, you can use:
-
- # pkg_delete djvulibre-\?.\*
- # portmaster -o graphics/djvulibre djvulibre-nox11
-
- You should then update any installed ports that link to the djvulibre shared
- library: converters/pdf2djvu, graphics/djview4, graphics/okular, and --
- if optional djvulibre support was enabled -- graphics/ImageMagick,
- graphics/apvlv, and graphics/evince.
-
-20120612:
- AFFECTS: users of databases/postgresql-libpqxx
- AUTHOR: avilla@FreeBSD.org
-
- postgresql-libpqxx has been updated to 4.0. If you want to stick
- with version 3, install postgresql-libpqxx30:
-
- # portmaster -o databases/postgresql-libpqxx30 postgresql-libpqxx
-
-20120612:
- AFFECTS: users of graphics/gdal
- AUTHOR: sunpoet@FreeBSD.org
-
- Language bindings (Perl, PHP, Python, and Ruby) were moved to separate
- ports. Please install them if required. The new ports are:
-
- Perl binding: graphics/p5-Geo-GDAL
- PHP binding: graphics/php-gdal
- Python binding: graphics/py-gdal
- Ruby binding: graphics/ruby-gdal
-
-20120605:
- AFFECTS: users of net/p5-ZConf
- AUTHOR: vvelox@vvelox.net
-
- Please append '.set' to all sets for the FS backend. This was done to prevent
- collisions between config and set names. Previously the config
- "someConfig/default" would collide with the set "default" for "someConfig".
-
-20120603:
- AFFECTS: users of lang/ghc and */hs-*
- AUTHOR: haskell@FreeBSD.org
-
- Note that The Glorious Glasgow Haskell Compiler and the Haskell Platform
- have been updated to versions 7.4.1 and 2012.2.0.0, respectively. At the
- same time, all Haskell ports have been updated to their latest working
- versions.
-
- To follow the changes, please issue one of the following commands
- (depending on the tool used):
-
- # portmaster -r ghc
- or
- # portupgrade -fr lang/ghc
-
-20120531:
- AFFECTS: users of graphics/png
- AUTHOR: dinoex@FreeBSD.org
-
- The PNG library has been updated to version 1.5.10. Please rebuild all
- ports that depend on it.
-
- If you use portmaster:
- portmaster -r png-
- If you use portupgrade:
- portupgrade -fr graphics/png
-
-20120531:
- AFFECTS: users of editors/koffice-kde4
- AUTHOR: kde@FreeBSD.org
-
- KOffice 2 has been replaced by Calligra. You are encouraged to
- deinstall any KOffice port and install equivalent Calligra ones:
-
- # pkg_delete \*koffice\*
- # portmaster editors/calligra <additional l10n ports>
-
-20120530:
- AFFECTS: users of databases/postgresql*-server
- AUTHOR: jgh@FreeBSD.org
-
- Affected users are those who use the crypt(text, text) function with
- DES encryption in the optional pg_crypto module. Passwords affected
- are those that contain characters that cannot be represented with
- 7-bit ASCII. If a password contains a character that has the most
- significant bit set (0x80), and DES encryption is used, that character
- and all characters after it will be ignored.
-
-20120530:
- AFFECTS: users of net/nss-pam-ldapd
- AUTHOR: scheidell@FreeBSD.org
-
- The net/nss-pam-ldapd port no longer provides an option for SASL. This has
- been sourced out to the new net/nss-pam-ldapd-sasl port, to accommodate
- users using packages (see ports/162240). Users with openldap-sasl-client
- installed are encouraged to change the port's origin to:
- net/nss-pam-ldapd-sasl using their favorite ports management tool.
- Example for portmaster:
- portmaster -o net/nss-pam-ldapd-sasl nss-pam-ldapd
-
-20120527:
- AFFECTS: users of x11-toolkits/qt4-gui
- AUTHOR: kde@FreeBSD.org
-
- Qt started using the raster graphics system engine, which relies on
- shared memory. Be sure to check pkg-message.
-
-20120525:
- AFFECTS: users of deskutils/kdepim4, deskutils/kdepim4-runtime
- AUTHOR: kde@FreeBSD.org
-
- kdepim4 has been updated to 4.8.3. For those who prefer old
- kdepim-4.4.11.1 deskutils/kdepim44* ports have been added.
- To stay with kdepim-4.4.11.1 run the following commands:
-
- # portmaster -o deskutils/kdepim44-runtime kdepim-runtime-4\*
- # portmaster -o deskutils/kdepim44 kdepim-4\*
-
-20120525:
- AFFECTS: users of KDE SC 4
- AUTHOR: kde@FreeBSD.org
-
- KDE SC ports have been updated to 4.8.3. Several ports were split,
- thus manual intervention into update procedure is required:
-
- # pkg_delete -f kde-runtime-\* ruby\*-kdebindings-korundum\* \
- kalgebra-4\* kdeaccessibility-4\* kdeutils-4\* kde-baseapps-\* \
- plasma-applet-icontasks\*
- # portmaster -a
-
-20120518:
- AFFECTS: users of dns/poweradmin
- AUTHOR: Edmondas Girkantas <eg@fbsd.lt>
-
- Some database changes have been made between version 2.1.4 and 2.1.5,
- upgrading needs to be done manually by running the following SQL:
-
- For MySQL users:
-
- ALTER TABLE `zones` ADD `zone_templ_id` INT( 11 ) NOT NULL;
- ALTER TABLE zones ENGINE = InnoDB;
- ALTER TABLE zone_templ ENGINE = InnoDB;
- ALTER TABLE zone_templ_records ENGINE = InnoDB;
-
- For PostgreSQL users:
-
- ALTER TABLE zones ADD zone_templ_id INT DEFAULT NULL;
-
- Source: https://www.poweradmin.org/trac/wiki/ReleaseNotes/2.1.5
-
-20120516:
- AFFECTS: users of lang/php5
- AUTHOR: ale@FreeBSD.org
-
- PHP has been updated to 5.4. Suhosin patch has been disabled until the
- new version will be released (soon). Suhosing extension will take more
- time. LINKTHR option is now enabled by default, be sure to flag it if
- you are updating using an old saved configuration. sqlite2 extension
- has been permanently removed.
- If you want to remain at PHP 5.3, a new port (lang/php53) has been
- created for such purpose.
-
-20120513:
- AFFECTS: users of net-mgmt/smokeping
- AUTHOR: lth@FreeBSD.org
-
- Smokeping has been updated to 2.6.7, and the web server configuration
- has changed. FastCGI is now preferred. Please check the documentation
- that your web server configuration is OK.
-
-20120512:
- AFFECTS: users of textproc/p5-XML-SAX
- AUTHOR: crees@FreeBSD.org
-
- p5-XML-SAX (X-S) was split into p5-XML-SAX-Base (X-S-B) and p5-XML-SAX for
- version 0.99. Since X-S-B now installs some files formerly installed by X-S
- the package for X-S must be deinstalled before updating X-S.
-
- # pkg_delete -fx p5-XML-SAX
- # portmaster textproc/p5-XML-SAX
-
- (users of pkgng can substitute pkg_delete with pkg delete)
-
-20120511:
- AFFECTS: users of graphics/xpdf
- AUTHOR: cy@FreeBSD.org
-
- In order to allow graphics/xpdf and graphics/poppler-utils to coexist,
- graphics/xpdf binaries have been moved from ${LOCALBASE}/bin to
- ${LOCALBASE}/lib/xpdf. The symlink ${LOCALBASE}/bin/xpdf points to
- ${LOCALBASE}/lib/xpdf/xpdf. However the other utilities installed by
- the xpdf port conflict with poppler-utils, no symlinks are maintained.
- Applicaions and scripts which use the pdf* utilities provided by
- graphics/xpdf must reference them using their new location, specify
- ${LOCALBASE}/lib/xpdf in $PATH, or use the same utilities provided by
- graphics/poppler-utils.
-
-20120510:
- AFFECTS: users of devel/gitolite
- AUTHOR: milki@rescomp.berkeley.edu
-
- gitolite has been split into two ports: devel/gitolite for 3.x and
- devel/gitolite2 for 2.x
-
- gitolite 3.x is NOT "API" compatible with gitolite 2.x and requires
- additional manual migration steps which can be found in the online
- documentation.
-
- http://sitaramc.github.com/gitolite/install.html#migr
-
- Current users wishing to continue using gitolite 2.x should run:
-
- # portmaster -o devel/gitolite2 gitolite
- or
- # portupgrade -o devel/gitolite2 gitolite
-
-20120508:
- AFFECTS: users of www/node and www/node-devel
- AUTHOR: sunpoet@FreeBSD.org
-
- npm is a package manager for node. Starting with node 0.6.17 (www/node) and
- node 0.7.8 (www/node-devel), we do not install bundled npm but provide a
- separate port (www/npm). Please install www/npm if you need it.
-
-20120430:
- AFFECTS: users of www/py-google-api-python-client
- AUTHOR: nivit@FreeBSD.org
-
- The port has been updated to 1.0.b8. This new version has important
- changes which might break your code:
-
- * apiclient.anyjson has moved to oauth2client.anyjson.
- * Some calls, for example, taskqueue().lease() used to require
- a parameter named body. In this new release only methods that
- really need to send a body require a body parameter, and so
- you may get errors about an unknown 'body' parameter in your call.
- The solution is to remove the unneeded body={} parameter
-
- See http://code.google.com/p/google-api-python-client/wiki/PyDoc for
- more information.
-
-20120426:
- AFFECTS: users of editors/libreoffice
- AUTHOR: bapt@FreeBSD.org
-
- LOCALIZED_LANG option has gone, localized packages are now available
- separately, you can also use editors/libreoffice-i18n to pick the
- localization you want.
-
-20120425:
- AFFECTS: users of mail/postfix, mail/postfix2[6-8]
- AUTHOR: sahil@FreeBSD.org
-
- The latest update to these ports adds support to turn off
- the TLSv1.1 and TLSv1.2 protocols introduced in OpenSSL 1.0.1.
- These protocols are known to cause inter-operability issues
- with certain services, e.g. hotmail. If using TLS with Postfix,
- please consult the RELEASE_NOTES for information about possible
- workarounds.
-
-20120423:
- AFFECTS: users of astro/boinc-astropulse
- AUTHOR: rene@FreeBSD.org
-
- Astropulse has been updated to 6.01, which is a different application
- than version 5.06. You need to have Astropulse v6 enabled in your
- account under SETI@home preferences. It is also advisable to finish
- and report existing Astropulse units before updating.
-
-20120421:
- AFFECTS: users of x11/xorg
- AUTHOR: x11@FreeBSD.org
-
- The default mesa has been updated to 7.6.1 and the default xorg-server
- to 1.7.7.
- A switch is available for people that want to use mesa 7.11.x and
- xorg-server 1.10.6. This requires an nvidia card or Intel+KMS support.
- If you have an intel card and can try these experimental KMS support
- patches:
- 10/head with a patch: http://people.freebsd.org/~kib/drm/
- FreeBSD stable/9 and releng/9.0:
- http://lists.freebsd.org/pipermail/freebsd-x11/2012-April/011640.html
-
-20120419:
- AFFECTS: users of security/openssl
- AUTHOR: dinoex@FreeBSD.org
-
- The OpenSSL port has been updated to 1.0.1a. Please rebuild all
- ports that depend on it.
-
- If you use portmaster:
- portmaster -r openssl
- Or, if you would prefer a more gradual approach:
- portmaster -w openssl (check the man page for more information)
-
- If you use portupgrade:
- portupgrade -fr security/openssl
-
-20120418:
- AFFECTS: Nobody
- AUTHOR: wxs@FreeBSD.org
-
- FreeBSD 8.3 released.
-
-20120418:
- AFFECTS: users of www/firefox and mail/thunderbird
- AUTHOR: gecko@FreeBSD.org
-
- Firefox and Thunderbird have been updated to 11.0. If you want to
- stay with the Extended Support Release please use the new -esr
- ports.
-
- Firefox:
- # portupgrade -o www/firefox-esr www/firefox
- # portupgrade -o www/firefox-esr-i18n www/firefox-i18n (if installed)
- or
- # portmaster -o www/firefox-esr www/firefox
- # portmaster -o www/firefox-esr-i18n www/firefox-i18n (if installed)
-
- Thunderbird:
- # portupgrade -o mail/thunderbird-esr mail/thunderbird
- # portupgrade -o mail/thunderbird-esr-i18n \
- mail/thunderbird-i18n (if installed)
- or
- # portmaster -o mail/thunderbird-esr mail/thunderbird
- # portmaster -o mail/thunderbird-esr-i18n \
- mail/thunderbird-i18n (if installed)
-
-20120418:
- AFFECTS: users of www/chpasswd
- AUTHOR: madpilot@FreeBSD.org
-
- Previous version of the chpasswd port put the configuration file
- in the pkg-plist, causing it to be removed on deinstall.
-
- Users are advised to make a backup copy of the configuration file
- before upgrading. This has been fixed and will not happen anymore
- in future updates.
-
-20120415:
- AFFECTS: users of irc/ircd-ratbox
- AUTHOR: scheidell@FreeBSD.org
-
- Ircd-ratbox has been updated to follow the current stable release
- branch (3.0.x). All previous branches are no longer supported by the
- ratbox team.
-
- Users of ircd-ratbox are advised to create new ircd configuration
- files based on the examples provided.
-
-20120404:
- AFFECTS: users of net-mgmt/net-snmp
- AUTHOR: zi@FreeBSD.org
-
- The net-snmp startup script now specifies a new pid_file to avoid a
- conflict that existed with bsnmpd. As a result, the startup script
- cannot find currently running versions of snmpd.
-
- You will need to either stop the daemon before upgrading or locate the
- PID of snmpd and manually kill it after upgrade. Then, start the daemon
- as you normally would.
-
-20120326:
- AFFECTS: users of www/tomcat7
- AUTHOR: ale@FreeBSD.org
-
- Tomcat 7 startup script now uses 'jsvc' to monitor the daemon's process.
- A few rc.conf variables has been changed, be sure to adapt your
- configuration, if needed.
-
-20120318:
- AFFECTS: users of mail/dbmail
- AUTHOR: rm@FreeBSD.org
-
- dbmail 3.0 is now available.
-
- There are a number of significant changes including Dependencies,
- Config, Schema and Server changes.
-
- Without required modifications, dbmail will not run and you will
- no longer have access to your emails. See UPGRADING for details.
- Don't forget to backup and fully test before upgrading.
-
- To stick with version 2.2.x run:
- # portupgrade -o mail/dbmail22 mail/dbmail
- or
- # portmaster -o mail/dbmail22 mail/dbmail
-
-20120313:
- AFFECTS: users of x11-toolkits/qt4-gui
- AUTHOR: kde@FreeBSD.org
-
- MIT-SHM problem (blank windows in Marble and KDE-Games) has been
- fixed, kern.ipc.shm_allow_removed=1 is not needed anymore to
- workaround it.
-
-20120311:
- AFFECTS: users of lang/perl5.8 and lang/perl5.10
- AUTHOR: linimon@FreeBSD.org
-
- lang/perl5.8 and lang/perl5.10 have been restored from the Attic
- in order to give a FreeBSD-style deprecation cycle. However, users
- are advised to upgrade to perl5.12 as soon as feasible.
-
-20120308:
- AFFECTS: users of lang/perl5.8 and lang/perl5.10
- AUTHOR: pgollucci@FreeBSD.org
-
- lang/perl5.8 and lang/perl5.10 have been removed since they've
- been EOL upstream for 3yrs and 2yrs respectively. The default
- of lang/perl5.12 has not changed (yet). Conditional checks for
- perl < 5.12 have been removed. UNLESS you have PERL_VERSION=5.8.x
- or PERL_VERSION=5.10.x in /etc/make.conf you need take no action.
- If you do, you will have to recompile all perl dependant ports after
- updating your ports tree. Please see entry 20110517 for help.
-
-20120225:
- AFFECTS: users of archivers/libarchive
- AUTHOR: glewis@FreeBSD.org
-
- libarchive has been updated to version 3.0.3, with a shared library bump.
- This requires dependent ports to be rebuilt.
-
- # portmaster -r libarchive
- or
- # portupgrade -r archivers/libarchive
-
-20120221:
- AFFECTS: users of emulators/virtualbox-ose
- AUTHOR: decke@FreeBSD.org
-
- virtualbox-ose has been updated to 4.1.8 and requires the latest
- devel/kBuild-devel now. It is only a build dependency so it is safe
- to remove it before updating.
-
- # pkg_delete -f kBuild-\*
-
-20120220:
- AFFECTS: users of graphics/libungif
- AUTHOR: dinoex@FreeBSD.org
-
- libungif is obsolete, please deinstall it and rebuild all ports using
- it with graphics/giflib.
-
- # portmaster -o graphics/giflib graphics/libungif
- # portmaster -r giflib
- or
- # portupgrade -o graphics/giflib graphics/libungif
- # portupgrade -rf giflib
-
-20120216:
- AFFECTS: users of multimedia/libvpx
- AUTHOR: ashish@FreeBSD.org
-
- libvpx has been updated to version 1.0.0, with a shared library bump.
- This requires dependencies to be rebuilt.
-
- # portmaster -r libvpx
- or
- # portupgrade -r multimedia/libvpx
-
-20120214:
- AFFECTS: users of net/libexosip2
- AUTHOR: jgh@FreeBSD.org
-
- libexosip2 has been updated with a shared library bump.
- This requires dependencies to be rebuilt.
-
- # portmaster -r libexosip2
- or
- # portupgrade -rf libexosip2-3.\*
-
-20120214:
- AFFECTS: users of devel/pcre
- AUTHOR: dougb@FreeBSD.org
-
- Until all dependent ports have been updated you should update pcre in
- a manner that will preserve its old shared library. For example:
-
- # portmaster -w devel/pcre
- or
- # portupgrade devel/pcre
-
-20120213:
- AFFECTS: users of lang/ghc and */hs-*
- AUTHOR: pgj@FreeBSD.org
-
- GHC has been updated to version 7.0.4, and Haskell Platform to version
- 2011.4.0.0, and other Haskell ports are also updated to their Haskell
- Platform versions or latest versions.
-
- To update all affected ports:
-
- # portmaster -r lang/ghc
- or
- # portupgrade -r lang/ghc
-
-20120210:
- AFFECTS: users of mail/postfix
- AUTHOR: Sahil Tandon <sahil@FreeBSD.org>
-
- Postfix 2.9.0 contains several major changes, some of which could
- result in incompatible or unexpected behavior. Regardless of the
- version from which you are upgrading, please carefully review the
- RELEASE_NOTES before proceeding.
-
-20120126:
- AFFECTS: users of ftp/proftpd and ftp/proftpd-mysql
- AUTHOR: Martin Matuska <mm@FreeBSD.org>
-
- The proftpd port has been updated to 1.3.4 and changed to use
- dynamically loadable modules. Please add corresponding LoadModule
- directives to your configuration file, like in the following example:
-
- LoadModule mod_tls.c
-
- The modules mod_sql_mysql and mod_sql_postgres are now outside of the
- main proftpd port:
- databases/proftpd-mod_sql_mysql
- databases/proftpd-mod_sql_postgres
-
- The proftpd-mysql port has been removed, use the alternative port:
- databases/proftpd-mod_sql_mysql
-
-20120121:
- AFFECTS: users of multimedia/vdr
- AUTHOR: Juergen Lock <nox@FreeBSD.org>
-
- The vdr ports have been updated to 1.7.22 which involves at least
- two changes:
-
- - svdrpsend.pl is now called svdrpsend.
-
- - The ttxtsubs channels.conf format has changed so if you use that
- plugin you need to edit /usr/local/etc/vdr/channels.conf for the
- channels you want to receive teletext subtitles on - see:
-
- /usr/local/share/doc/vdr-plugin-ttxtsubs/HISTORY
-
-20120116:
- AFFECTS: users of mail/postfix-current
- AUTHOR: Sahil Tandon <sahil@FreeBSD.org>
-
- From the upstream RELEASE_NOTES:
-
- Instead of terminating immediately with a "fatal" message when a
- database file can't be opened, a Postfix daemon program now logs
- an "error" message, and continues execution with reduced
- functionality.
-
- Specify "daemon_table_open_error_is_fatal = yes" to get the
- historical behavior (immediate termination with "fatal" message).
-
- Logfile-based alerting systems may need to be updated to look for
- "error" messages in addition to "fatal" messages.
-
- By default the Postfix SMTP server no longer reports transcripts
- of sessions where a client command is rejected because a table is
- unavailable. To receive such reports, add the new "data" class to
- the notify_classes parameter value. The reports will be sent to the
- error_notice_recipient address as before. This class is also used
- by the Postfix SMTP client to report about sessions that fail
- because a table is unavailable.
-
-20120116:
- AFFECTS: users of x11/xcb-util
- AUTHOR: garga@FreeBSD.org
-
- x11/xcb-util was updated to 0.3.8 and was split in new modules.
- Dependencies were adjusted but main port symbols were moved to a single
- library, xcb-util.so. For this reason, all dependent ports must be
- recompiled.If you use portmaster, run:
-
- # portmaster -R -r xcb-util-0
-
- Or for portupgrade:
-
- # portupgrade -r xcb-util-0\*
-
-20120112:
- AFFECTS: Nobody
- AUTHOR: wxs@FreeBSD.org
-
- FreeBSD 9.0 released.
-
-20120109:
- AFFECTS: users of www/p5-WWW-GitHub-Gist
- AUTHOR: lbr@FreeBSD.org
-
- gist command was moved into new www/p5-App-gist port.
-
-20120109:
- AFFECTS: ports using Apache Software License 2.0
- AUTHOR: tabthorpe@FreeBSD.org
-
- The correct acronym for Apache Software License 2.0 is really AL2.
-
-20120109:
- AFFECTS: users of graphics/inkscape:
- AUTHOR: bsam@FreeBSD.org
-
- Before updating graphics/inkscape to version 0.48.2 one should deinstall
- the port graphics/libwpg01.
-
-20120108:
- AFFECTS: users of devel/p5-CPAN-Meta and devel/p5-Version-Requirements
- AUTHOR: sunpoet@FreeBSD.org
-
- Author of Version::Requirements (devel/p5-Version-Requirements) merged
- its function to CPAN::Meta::Requirements (part of devel/p5-CPAN-Meta).
- As a result, devel/p5-Version-Requirements is marked DEPRECATED.
- Please run the following commands to update p5-CPAN-Meta and remove
- p5-Version-Requirements:
-
- # portmaster -o devel/p5-CPAN-Meta devel/p5-Version-Requirements
- # pkg_delete p5-Version-Requirements-\*
-
-20120104:
- AFFECTS: users of devel/thrift, py-thrift, php5-thrift, p5-thrift
- AUTHOR: scheidell@FreeBSD.org
-
- Users upgrading thrift from 0.6.1, please take note: library structure
- and versions have changed, and are not compatible with 0.7.0+
-
-20111231:
- AFFECTS: users of lang/newlisp
- AUTHOR: olgeni@FreeBSD.org
-
- In lang/newlisp, the MYSQL5 and MYSQL51 options have been unified into
- MYSQL, which will pick the correct MySQL version using the standard
- MySQL selection logic. MySQL users will have to run "make config" and
- select the MYSQL option.
-
- Tinderbox users will have to update their options files with the new
- MYSQL option, and possibly change their Tinderbox environment to select
- a specific MySQL version.
-
-20111229:
- AFFECTS: users of ftp/proftpd{-devel,-mysql}
- AUTHORS: delphij@FreeBSD.org, mm@FreeBSD.org
-
- Due to the nature of the way FreeBSD-SA-11:07.chroot is implemented,
- users have to update to latest -STABLE, -CURRENT, or supported
- security branch to use the chroot functionality in these ports.
-
- Please see the security advisory for more details.
-
-20111219:
- AFFECTS: users of lang/perl5.14
- AUTHOR: skv@FreeBSD.org
-
- lang/perl5.14 has been updated to 5.14.2. You should update everything
- that depends on perl. The easiest way to do that is to use
- "perl-after-upgrade" script supplied with lang/perl5.14.
- Please see its manual page for details.
-
- If you want to switch to lang/perl5.14 from lang/perl5.{8,10,12} please
- follow instructions in the entry 20110517 in this file.