aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-28 01:29:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-28 01:29:36 +0000
commit2ce62c36eb03c90b5418de1d548a1add4c25ec00 (patch)
tree04eabdf1624bfe37495320ecc15e46acfd1ce632
parent12da909032613bda1502baaa0fd567bcc541009c (diff)
downloadports-2ce62c36eb03c90b5418de1d548a1add4c25ec00.tar.gz
ports-2ce62c36eb03c90b5418de1d548a1add4c25ec00.zip
misc/py-openai: New port: Python client library for the OpenAI API
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-openai/Makefile23
-rw-r--r--misc/py-openai/distinfo3
-rw-r--r--misc/py-openai/pkg-descr2
4 files changed, 29 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index e1e00528cb12..d3bbfe709910 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -422,6 +422,7 @@
SUBDIR += py-numcodecs
SUBDIR += py-onnx
SUBDIR += py-onnx-tf
+ SUBDIR += py-openai
SUBDIR += py-openpaperwork-core
SUBDIR += py-openpaperwork-gtk
SUBDIR += py-openvdb
diff --git a/misc/py-openai/Makefile b/misc/py-openai/Makefile
new file mode 100644
index 000000000000..712b849f5932
--- /dev/null
+++ b/misc/py-openai/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= openai
+DISTVERSION= 0.26.5
+CATEGORIES= misc # mechine-learning
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python client library for the OpenAI API
+WWW= https://github.com/openai/openai-python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wandb>0:misc/py-wandb@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-openai/distinfo b/misc/py-openai/distinfo
new file mode 100644
index 000000000000..6777e46e7e7a
--- /dev/null
+++ b/misc/py-openai/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677544433
+SHA256 (openai-0.26.5.tar.gz) = 2882a59c67ae33c2716a04389a6e6680d061f073424953732f917fde219addfd
+SIZE (openai-0.26.5.tar.gz) = 55501
diff --git a/misc/py-openai/pkg-descr b/misc/py-openai/pkg-descr
new file mode 100644
index 000000000000..735bb97bc2ac
--- /dev/null
+++ b/misc/py-openai/pkg-descr
@@ -0,0 +1,2 @@
+The OpenAI Python library provides convenient access to the OpenAI API from
+applications written in the Python language.