aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-15 02:42:03 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-15 02:45:23 +0000
commit2d00178fd4d952c698d3413800c3bd1b6cfc98a9 (patch)
treeb0881172ea8e79250cf341d237d9f9cc6248e3f6
parent6ef6944084c27cbe91fb6c6dc5f051200247ba06 (diff)
downloadports-2d00178fd4d952c698d3413800c3bd1b6cfc98a9.tar.gz
ports-2d00178fd4d952c698d3413800c3bd1b6cfc98a9.zip
*/*: Fix some ports conversion from USE_RUBY to USES=ruby
In my previous commit 18c6e18 I missed some ports where RUBY was optional. This commit fixes those missing ports and fixes INDEX build. Approved by: portmgr Fixes: 18c6e18 Mk/**ruby.mk: Switch from USE_RUBY=yes to USES=ruby
-rw-r--r--databases/redis-devel/Makefile2
-rw-r--r--databases/rrdtool/Makefile2
-rw-r--r--editors/vim/Makefile2
-rw-r--r--graphics/graphviz/Makefile2
-rw-r--r--irc/iroffer-dinoex/Makefile2
-rw-r--r--japanese/tomoe/Makefile4
-rw-r--r--java/openjfx14/Makefile1
-rw-r--r--multimedia/arcan/Makefile2
-rw-r--r--textproc/redland-bindings/Makefile2
9 files changed, 9 insertions, 10 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index b13a3f95f859..d6f64bd97bb9 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -48,7 +48,7 @@ TLS_USES= ssl
TLS_MAKE_ENV= BUILD_TLS=yes
TRIB_CATEGORIES= ruby
TRIB_RUN_DEPENDS= rubygem-redis>=2.2:databases/rubygem-redis
-TRIB_USE= RUBY=yes
+TRIB_USES= ruby
.include <bsd.port.pre.mk>
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index 82ca0bfe76b8..50a72f9e4b2b 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -67,7 +67,7 @@ PYTHON_USES= python
PYTHON_USE= PYTHON=flavors,optsuffix
PYTHON_CONFIGURE_ENABLE= python
PYTHON_PORTEXAMPLES= stripes.py
-RUBY_USE= RUBY=yes
+RUBY_USES= ruby
RUBY_CONFIGURE_ENABLE= ruby
post-extract:
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 785fa58cbfbe..9694788ec3f1 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -139,7 +139,7 @@ PYTHON_CONFIGURE_ENABLE= python3interp
PYTHON_CONFIGURE_WITH= python3-command=${PYTHON_CMD}
RUBY_CONFIGURE_ENABLE= rubyinterp
-RUBY_USE= RUBY=yes
+RUBY_USES= ruby
SCHEME_DESC= MzScheme (Racket) bindings
SCHEME_CONFIGURE_ENABLE=mzschemeinterp
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 64888ef10304..8482acaa59a1 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -96,7 +96,7 @@ PERL_USES= perl5
PHP_USES= php:build gnome
PHP_USE= GNOME=libxml2
PYTHON_USES= python:build
-RUBY_USE= RUBY=yes
+RUBY_USES= ruby
LUA_USES= lua
TK_USES= tk:build
GO_USES= go:no_targets
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index e90b7a79b973..24013ccc758c 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -46,7 +46,7 @@ OPTIONS_DEFAULT=CURL RUBY UPNP GEOIP
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_ON= -curl
-RUBY_USE= RUBY=yes
+RUBY_USES= ruby
RUBY_LIB_DEPENDS= libruby${RUBY_SHLIBVER}.so:${RUBY_PORT}
RUBY_CONFIGURE_ON= -ruby
UPNP_LIB_DEPENDS= libminiupnpc.so:net/miniupnpc
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index 9d4008788649..aca0d1c212fd 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -33,7 +33,7 @@ MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
RUBY_DESC= Enable Ruby module
RUBY_BROKEN= Does not build
-RUBY_USE= RUBY=yes
+RUBY_USES= ruby
RUBY_CONFIGURE_OFF= --with-ruby=no
RUBY_BUILD_DEPENDS= rubygem-glib2>0:devel/rubygem-glib2
RUBY_RUN_DEPENDS= rubygem-glib2>0:devel/rubygem-glib2
@@ -47,7 +47,7 @@ UNIHAN_EXTRACT_DEPENDS= ${UNZIP_CMD}:archivers/unzip
UNIHAN_BUILD_DEPENDS= \
${RUBY_SITEARCHLIBDIR}/uconv.so:japanese/ruby-uconv \
${RUBY_SITELIBDIR}/suikyo/suikyo.rb:japanese/suikyo
-UNIHAN_USE= RUBY=yes
+UNIHAN_USES= ruby
UNIHAN_CONFIGURE_ENABLE=unihan
post-extract-UNIHAN-on:
diff --git a/java/openjfx14/Makefile b/java/openjfx14/Makefile
index 924d00c769b7..b5a9ff49a289 100644
--- a/java/openjfx14/Makefile
+++ b/java/openjfx14/Makefile
@@ -76,7 +76,6 @@ WEBKIT_LIB_DEPENDS= libicui18n.so:devel/icu
WEBKIT_USES= bison gmake gperf perl5 python:3.5+,build ruby:build
WEBKIT_USE= GNOME=libxslt,libxml2 \
PERL5=build \
- RUBY=yes \
XORG=xcomposite,xdamage,xfixes,xrender,xt
WEBKIT_VARS= COMPILE_WEBKIT=true
diff --git a/multimedia/arcan/Makefile b/multimedia/arcan/Makefile
index fb9de6eccd36..1579c2240068 100644
--- a/multimedia/arcan/Makefile
+++ b/multimedia/arcan/Makefile
@@ -40,7 +40,7 @@ OPTIONS_SUB= yes
ESPEAK_LIB_DEPENDS= libespeak-ng.so:audio/espeak-ng
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-MANPAGES_USE= RUBY=yes
+MANPAGES_USES= ruby
MANPAGES_VARS= RUBY_NO_RUN_DEPENDS=yes
LUAJIT_DESC= Use LuaJIT instead of standard Lua
diff --git a/textproc/redland-bindings/Makefile b/textproc/redland-bindings/Makefile
index 87df73b49449..79dfdbd169e4 100644
--- a/textproc/redland-bindings/Makefile
+++ b/textproc/redland-bindings/Makefile
@@ -29,6 +29,6 @@ PHP_USES= php:build
PYTHON_CONFIGURE_WITH= python python-libext=${PYTHON_EXT_SUFFIX}.so
PYTHON_USES= python
RUBY_CONFIGURE_WITH= ruby
-RUBY_USE= RUBY=yes
+RUBY_USES= ruby
.include <bsd.port.mk>