aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-20 16:14:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-20 16:14:56 +0000
commit2d3698b772949fbd4c3434d2ac2020ca033df9b2 (patch)
treed003aa9590cafbe174cf323687d62e01a4f85427
parent2cdaceb379244e0f304927e09d40061c67dc573d (diff)
downloadports-2d3698b772949fbd4c3434d2ac2020ca033df9b2.tar.gz
ports-2d3698b772949fbd4c3434d2ac2020ca033df9b2.zip
math/ceres-solver: Fix PLIST with glog 0.5.0
- Add BUILD_DEPENDS to ensure glog 0.5.0+ - Bump PORTREVISION for package change In aac990618e17966d1b5865526efd9c89332701fe, glog changed to cmake and provided its own cmake module, therefore ceres-solver does not install its glog-detection cmake module [1]. from CMakeLists.txt [1]: 762 if (GLOG_FOUND AND NOT FOUND_INSTALLED_GLOG_CMAKE_CONFIGURATION) 763 # Version of glog detected was not built with CMake, install our glog module 764 # file to enable detection in CeresConfig. 765 install(FILES "${Ceres_SOURCE_DIR}/cmake/FindGlog.cmake" 766 DESTINATION ${RELATIVE_CMAKECONFIG_INSTALL_DIR}) 767 endif() Reported by: thierry
-rw-r--r--math/ceres-solver/Makefile3
-rw-r--r--math/ceres-solver/pkg-plist1
2 files changed, 2 insertions, 2 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index aa7b62bffd83..076d4f79d46f 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ceres-solver
DISTVERSION= 2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= ports@FreeBSD.org
@@ -9,6 +9,7 @@ COMMENT= Nonlinear least squares minimizer
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= glog>=0.5.0:devel/glog
LIB_DEPENDS= libglog.so:devel/glog
RUN_DEPENDS:= ${BUILD_DEPENDS:Meigen*}
diff --git a/math/ceres-solver/pkg-plist b/math/ceres-solver/pkg-plist
index 512210ade0b8..12f9fd524053 100644
--- a/math/ceres-solver/pkg-plist
+++ b/math/ceres-solver/pkg-plist
@@ -55,7 +55,6 @@ lib/cmake/Ceres/CeresConfig.cmake
lib/cmake/Ceres/CeresConfigVersion.cmake
lib/cmake/Ceres/CeresTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Ceres/CeresTargets.cmake
-lib/cmake/Ceres/FindGlog.cmake
lib/libceres.so
lib/libceres.so.2
lib/libceres.so.%%VERSION%%