aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-30 05:19:10 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-31 00:06:29 +0000
commit2d9e79b015e2bdf487610286dd3ce94fbc17db88 (patch)
treee697c57554805f2895d5c06e74a76183cfab410b
parente73ac8df149aa69dddb27678c2bbaaf87bec7186 (diff)
downloadports-2d9e79b015e2bdf487610286dd3ce94fbc17db88.tar.gz
ports-2d9e79b015e2bdf487610286dd3ce94fbc17db88.zip
math/wfmath: Remove expired port
2023-12-31 math/wfmath: There has been no release for most of the Worldforge libraries in the past 10 years.
-rw-r--r--MOVED1
-rw-r--r--math/Makefile1
-rw-r--r--math/wfmath/Makefile20
-rw-r--r--math/wfmath/distinfo2
-rw-r--r--math/wfmath/files/patch-wfmath-intersect.cpp244
-rw-r--r--math/wfmath/pkg-descr4
-rw-r--r--math/wfmath/pkg-plist41
7 files changed, 1 insertions, 312 deletions
diff --git a/MOVED b/MOVED
index 26935f4a2005..90712d498799 100644
--- a/MOVED
+++ b/MOVED
@@ -8253,3 +8253,4 @@ devel/libwfut||2023-12-31|Has expired: There has been no release for most of the
devel/fuel||2023-12-31|Has expired: Depends on deprecated www/qt5-webkit
devel/rubygem-aws-sdk-macie||2023-12-31|Has expired: Deprecated by upstream
sysutils/devcpu-data|sysutils/cpu-microcode|2023-12-31|Has expired: Use sysutils/cpu-microcode
+math/wfmath||2023-12-31|Has expired: There has been no release for most of the Worldforge libraries in the past 10 years.
diff --git a/math/Makefile b/math/Makefile
index 51bf24e648f2..0bb79b67370b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -1229,7 +1229,6 @@
SUBDIR += vtk9
SUBDIR += wavelib
SUBDIR += wcalc
- SUBDIR += wfmath
SUBDIR += wxmaxima
SUBDIR += xblas
SUBDIR += xfce4-calculator-plugin
diff --git a/math/wfmath/Makefile b/math/wfmath/Makefile
deleted file mode 100644
index eb3b90230f65..000000000000
--- a/math/wfmath/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-PORTNAME= wfmath
-PORTVERSION= 1.0.2
-PORTREVISION= 10
-CATEGORIES= math
-MASTER_SITES= SF/worldforge/${PORTNAME}%20%28math%20lib%29/${PORTVERSION}
-
-MAINTAINER= oliver@FreeBSD.org
-COMMENT= Worldforge math library
-WWW= https://www.worldforge.org/
-
-DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
-EXPIRATION_DATE=2023-12-31
-
-USES= libtool pathfix pkgconfig compiler:c++11-lib
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-
-CXXFLAGS+= -Dregister=
-
-.include <bsd.port.mk>
diff --git a/math/wfmath/distinfo b/math/wfmath/distinfo
deleted file mode 100644
index 1cb27532dfd7..000000000000
--- a/math/wfmath/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (wfmath-1.0.2.tar.gz) = 203fa14cac60b55860d8a3140f2a8a400f52ab4b2ede6b5a67bd7112d51f36ad
-SIZE (wfmath-1.0.2.tar.gz) = 494246
diff --git a/math/wfmath/files/patch-wfmath-intersect.cpp b/math/wfmath/files/patch-wfmath-intersect.cpp
deleted file mode 100644
index eb82b671e7d5..000000000000
--- a/math/wfmath/files/patch-wfmath-intersect.cpp
+++ /dev/null
@@ -1,244 +0,0 @@
---- wfmath/intersect.cpp.orig 2014-03-10 19:17:04.000000000 +0100
-+++ wfmath/intersect.cpp 2014-03-10 19:18:00.000000000 +0100
-@@ -31,121 +31,6 @@
-
- namespace WFMath {
-
--// force a bunch of instantiations
--
--template bool Intersect<2>(const Point<2>&, const Point<2>&, bool);
--template bool Intersect<3>(const Point<3>&, const Point<3>&, bool);
--template bool Contains<2>(const Point<2>&, const Point<2>&, bool);
--template bool Contains<3>(const Point<3>&, const Point<3>&, bool);
--
--template bool Intersect<Point<2>,AxisBox<2> >(const Point<2>&, const AxisBox<2>&, bool);
--template bool Intersect<Point<3>,AxisBox<3> >(const Point<3>&, const AxisBox<3>&, bool);
--template bool Contains<2>(const Point<2>&, const AxisBox<2>&, bool);
--template bool Contains<3>(const Point<3>&, const AxisBox<3>&, bool);
--template bool Intersect<2>(const AxisBox<2>&, const Point<2>&, bool);
--template bool Intersect<3>(const AxisBox<3>&, const Point<3>&, bool);
--template bool Contains<2>(const AxisBox<2>&, const Point<2>&, bool);
--template bool Contains<3>(const AxisBox<3>&, const Point<3>&, bool);
--
--template bool Intersect<2>(const AxisBox<2>&, const AxisBox<2>&, bool);
--template bool Intersect<3>(const AxisBox<3>&, const AxisBox<3>&, bool);
--template bool Contains<2>(const AxisBox<2>&, const AxisBox<2>&, bool);
--template bool Contains<3>(const AxisBox<3>&, const AxisBox<3>&, bool);
--
--template bool Intersect<Point<2>,Ball<2> >(const Point<2>&, const Ball<2>&, bool);
--template bool Intersect<Point<3>,Ball<3> >(const Point<3>&, const Ball<3>&, bool);
--template bool Contains<2>(const Point<2>&, const Ball<2>&, bool);
--template bool Contains<3>(const Point<3>&, const Ball<3>&, bool);
--template bool Intersect<2>(const Ball<2>&, const Point<2>&, bool);
--template bool Intersect<3>(const Ball<3>&, const Point<3>&, bool);
--template bool Contains<2>(const Ball<2>&, const Point<2>&, bool);
--template bool Contains<3>(const Ball<3>&, const Point<3>&, bool);
--
--template bool Intersect<AxisBox<2>,Ball<2> >(const AxisBox<2>&, const Ball<2>&, bool);
--template bool Intersect<AxisBox<3>,Ball<3> >(const AxisBox<3>&, const Ball<3>&, bool);
--template bool Contains<2>(const AxisBox<2>&, const Ball<2>&, bool);
--template bool Contains<3>(const AxisBox<3>&, const Ball<3>&, bool);
--template bool Intersect<2>(const Ball<2>&, const AxisBox<2>&, bool);
--template bool Intersect<3>(const Ball<3>&, const AxisBox<3>&, bool);
--template bool Contains<2>(const Ball<2>&, const AxisBox<2>&, bool);
--template bool Contains<3>(const Ball<3>&, const AxisBox<3>&, bool);
--
--template bool Intersect<2>(const Ball<2>&, const Ball<2>&, bool);
--template bool Intersect<3>(const Ball<3>&, const Ball<3>&, bool);
--template bool Contains<2>(const Ball<2>&, const Ball<2>&, bool);
--template bool Contains<3>(const Ball<3>&, const Ball<3>&, bool);
--
--template bool Intersect<Point<2>,Segment<2> >(const Point<2>&, const Segment<2>&, bool);
--template bool Intersect<Point<3>,Segment<3> >(const Point<3>&, const Segment<3>&, bool);
--template bool Contains<2>(const Point<2>&, const Segment<2>&, bool);
--template bool Contains<3>(const Point<3>&, const Segment<3>&, bool);
--template bool Intersect<2>(const Segment<2>&, const Point<2>&, bool);
--template bool Intersect<3>(const Segment<3>&, const Point<3>&, bool);
--template bool Contains<2>(const Segment<2>&, const Point<2>&, bool);
--template bool Contains<3>(const Segment<3>&, const Point<3>&, bool);
--
--template bool Intersect<AxisBox<2>,Segment<2> >(const AxisBox<2>&, const Segment<2>&, bool);
--template bool Intersect<AxisBox<3>,Segment<3> >(const AxisBox<3>&, const Segment<3>&, bool);
--template bool Contains<2>(const AxisBox<2>&, const Segment<2>&, bool);
--template bool Contains<3>(const AxisBox<3>&, const Segment<3>&, bool);
--template bool Intersect<2>(const Segment<2>&, const AxisBox<2>&, bool);
--template bool Intersect<3>(const Segment<3>&, const AxisBox<3>&, bool);
--template bool Contains<2>(const Segment<2>&, const AxisBox<2>&, bool);
--template bool Contains<3>(const Segment<3>&, const AxisBox<3>&, bool);
--
--template bool Intersect<Ball<2>,Segment<2> >(const Ball<2>&, const Segment<2>&, bool);
--template bool Intersect<Ball<3>,Segment<3> >(const Ball<3>&, const Segment<3>&, bool);
--template bool Contains<2>(const Ball<2>&, const Segment<2>&, bool);
--template bool Contains<3>(const Ball<3>&, const Segment<3>&, bool);
--template bool Intersect<2>(const Segment<2>&, const Ball<2>&, bool);
--template bool Intersect<3>(const Segment<3>&, const Ball<3>&, bool);
--template bool Contains<2>(const Segment<2>&, const Ball<2>&, bool);
--template bool Contains<3>(const Segment<3>&, const Ball<3>&, bool);
--
--template bool Intersect<2>(const Segment<2>&, const Segment<2>&, bool);
--template bool Intersect<3>(const Segment<3>&, const Segment<3>&, bool);
--template bool Contains<2>(const Segment<2>&, const Segment<2>&, bool);
--template bool Contains<3>(const Segment<3>&, const Segment<3>&, bool);
--
--template bool Intersect<Point<2>,RotBox<2> >(const Point<2>&, const RotBox<2>&, bool);
--template bool Intersect<Point<3>,RotBox<3> >(const Point<3>&, const RotBox<3>&, bool);
--template bool Contains<2>(const Point<2>&, const RotBox<2>&, bool);
--template bool Contains<3>(const Point<3>&, const RotBox<3>&, bool);
--template bool Intersect<2>(const RotBox<2>&, const Point<2>&, bool);
--template bool Intersect<3>(const RotBox<3>&, const Point<3>&, bool);
--template bool Contains<2>(const RotBox<2>&, const Point<2>&, bool);
--template bool Contains<3>(const RotBox<3>&, const Point<3>&, bool);
--
--template bool Intersect<AxisBox<2>,RotBox<2> >(const AxisBox<2>&, const RotBox<2>&, bool);
--template bool Intersect<AxisBox<3>,RotBox<3> >(const AxisBox<3>&, const RotBox<3>&, bool);
--template bool Contains<2>(const AxisBox<2>&, const RotBox<2>&, bool);
--template bool Contains<3>(const AxisBox<3>&, const RotBox<3>&, bool);
--template bool Contains<2>(const RotBox<2>&, const AxisBox<2>&, bool);
--template bool Contains<3>(const RotBox<3>&, const AxisBox<3>&, bool);
--
--template bool Intersect<Ball<2>,RotBox<2> >(const Ball<2>&, const RotBox<2>&, bool);
--template bool Intersect<Ball<3>,RotBox<3> >(const Ball<3>&, const RotBox<3>&, bool);
--template bool Contains<2>(const Ball<2>&, const RotBox<2>&, bool);
--template bool Contains<3>(const Ball<3>&, const RotBox<3>&, bool);
--template bool Intersect<2>(const RotBox<2>&, const Ball<2>&, bool);
--template bool Intersect<3>(const RotBox<3>&, const Ball<3>&, bool);
--template bool Contains<2>(const RotBox<2>&, const Ball<2>&, bool);
--template bool Contains<3>(const RotBox<3>&, const Ball<3>&, bool);
--
--template bool Intersect<Segment<2>,RotBox<2> >(const Segment<2>&, const RotBox<2>&, bool);
--template bool Intersect<Segment<3>,RotBox<3> >(const Segment<3>&, const RotBox<3>&, bool);
--template bool Contains<2>(const Segment<2>&, const RotBox<2>&, bool);
--template bool Contains<3>(const Segment<3>&, const RotBox<3>&, bool);
--template bool Intersect<2>(const RotBox<2>&, const Segment<2>&, bool);
--template bool Intersect<3>(const RotBox<3>&, const Segment<3>&, bool);
--template bool Contains<2>(const RotBox<2>&, const Segment<2>&, bool);
--template bool Contains<3>(const RotBox<3>&, const Segment<3>&, bool);
--
--template bool Intersect<2>(const RotBox<2>&, const RotBox<2>&, bool);
--template bool Intersect<3>(const RotBox<3>&, const RotBox<3>&, bool);
--template bool Contains<2>(const RotBox<2>&, const RotBox<2>&, bool);
--template bool Contains<3>(const RotBox<3>&, const RotBox<3>&, bool);
--
- // The 2d implementation was inspired as a simplification of the 3d.
- // It used the fact that two not-similarly-oriented rectangles a and b
- // intersect each other if and only if a's bounding box in b's coordinate
-@@ -359,4 +244,119 @@
- return true;
- }
-
-+// force a bunch of instantiations
-+
-+template bool Intersect<2>(const Point<2>&, const Point<2>&, bool);
-+template bool Intersect<3>(const Point<3>&, const Point<3>&, bool);
-+template bool Contains<2>(const Point<2>&, const Point<2>&, bool);
-+template bool Contains<3>(const Point<3>&, const Point<3>&, bool);
-+
-+template bool Intersect<Point<2>,AxisBox<2> >(const Point<2>&, const AxisBox<2>&, bool);
-+template bool Intersect<Point<3>,AxisBox<3> >(const Point<3>&, const AxisBox<3>&, bool);
-+template bool Contains<2>(const Point<2>&, const AxisBox<2>&, bool);
-+template bool Contains<3>(const Point<3>&, const AxisBox<3>&, bool);
-+template bool Intersect<2>(const AxisBox<2>&, const Point<2>&, bool);
-+template bool Intersect<3>(const AxisBox<3>&, const Point<3>&, bool);
-+template bool Contains<2>(const AxisBox<2>&, const Point<2>&, bool);
-+template bool Contains<3>(const AxisBox<3>&, const Point<3>&, bool);
-+
-+template bool Intersect<2>(const AxisBox<2>&, const AxisBox<2>&, bool);
-+template bool Intersect<3>(const AxisBox<3>&, const AxisBox<3>&, bool);
-+template bool Contains<2>(const AxisBox<2>&, const AxisBox<2>&, bool);
-+template bool Contains<3>(const AxisBox<3>&, const AxisBox<3>&, bool);
-+
-+template bool Intersect<Point<2>,Ball<2> >(const Point<2>&, const Ball<2>&, bool);
-+template bool Intersect<Point<3>,Ball<3> >(const Point<3>&, const Ball<3>&, bool);
-+template bool Contains<2>(const Point<2>&, const Ball<2>&, bool);
-+template bool Contains<3>(const Point<3>&, const Ball<3>&, bool);
-+template bool Intersect<2>(const Ball<2>&, const Point<2>&, bool);
-+template bool Intersect<3>(const Ball<3>&, const Point<3>&, bool);
-+template bool Contains<2>(const Ball<2>&, const Point<2>&, bool);
-+template bool Contains<3>(const Ball<3>&, const Point<3>&, bool);
-+
-+template bool Intersect<AxisBox<2>,Ball<2> >(const AxisBox<2>&, const Ball<2>&, bool);
-+template bool Intersect<AxisBox<3>,Ball<3> >(const AxisBox<3>&, const Ball<3>&, bool);
-+template bool Contains<2>(const AxisBox<2>&, const Ball<2>&, bool);
-+template bool Contains<3>(const AxisBox<3>&, const Ball<3>&, bool);
-+template bool Intersect<2>(const Ball<2>&, const AxisBox<2>&, bool);
-+template bool Intersect<3>(const Ball<3>&, const AxisBox<3>&, bool);
-+template bool Contains<2>(const Ball<2>&, const AxisBox<2>&, bool);
-+template bool Contains<3>(const Ball<3>&, const AxisBox<3>&, bool);
-+
-+template bool Intersect<2>(const Ball<2>&, const Ball<2>&, bool);
-+template bool Intersect<3>(const Ball<3>&, const Ball<3>&, bool);
-+template bool Contains<2>(const Ball<2>&, const Ball<2>&, bool);
-+template bool Contains<3>(const Ball<3>&, const Ball<3>&, bool);
-+
-+template bool Intersect<Point<2>,Segment<2> >(const Point<2>&, const Segment<2>&, bool);
-+template bool Intersect<Point<3>,Segment<3> >(const Point<3>&, const Segment<3>&, bool);
-+template bool Contains<2>(const Point<2>&, const Segment<2>&, bool);
-+template bool Contains<3>(const Point<3>&, const Segment<3>&, bool);
-+template bool Intersect<2>(const Segment<2>&, const Point<2>&, bool);
-+template bool Intersect<3>(const Segment<3>&, const Point<3>&, bool);
-+template bool Contains<2>(const Segment<2>&, const Point<2>&, bool);
-+template bool Contains<3>(const Segment<3>&, const Point<3>&, bool);
-+
-+template bool Intersect<AxisBox<2>,Segment<2> >(const AxisBox<2>&, const Segment<2>&, bool);
-+template bool Intersect<AxisBox<3>,Segment<3> >(const AxisBox<3>&, const Segment<3>&, bool);
-+template bool Contains<2>(const AxisBox<2>&, const Segment<2>&, bool);
-+template bool Contains<3>(const AxisBox<3>&, const Segment<3>&, bool);
-+template bool Intersect<2>(const Segment<2>&, const AxisBox<2>&, bool);
-+template bool Intersect<3>(const Segment<3>&, const AxisBox<3>&, bool);
-+template bool Contains<2>(const Segment<2>&, const AxisBox<2>&, bool);
-+template bool Contains<3>(const Segment<3>&, const AxisBox<3>&, bool);
-+
-+template bool Intersect<Ball<2>,Segment<2> >(const Ball<2>&, const Segment<2>&, bool);
-+template bool Intersect<Ball<3>,Segment<3> >(const Ball<3>&, const Segment<3>&, bool);
-+template bool Contains<2>(const Ball<2>&, const Segment<2>&, bool);
-+template bool Contains<3>(const Ball<3>&, const Segment<3>&, bool);
-+template bool Intersect<2>(const Segment<2>&, const Ball<2>&, bool);
-+template bool Intersect<3>(const Segment<3>&, const Ball<3>&, bool);
-+template bool Contains<2>(const Segment<2>&, const Ball<2>&, bool);
-+template bool Contains<3>(const Segment<3>&, const Ball<3>&, bool);
-+
-+template bool Intersect<2>(const Segment<2>&, const Segment<2>&, bool);
-+template bool Intersect<3>(const Segment<3>&, const Segment<3>&, bool);
-+template bool Contains<2>(const Segment<2>&, const Segment<2>&, bool);
-+template bool Contains<3>(const Segment<3>&, const Segment<3>&, bool);
-+
-+template bool Intersect<Point<2>,RotBox<2> >(const Point<2>&, const RotBox<2>&, bool);
-+template bool Intersect<Point<3>,RotBox<3> >(const Point<3>&, const RotBox<3>&, bool);
-+template bool Contains<2>(const Point<2>&, const RotBox<2>&, bool);
-+template bool Contains<3>(const Point<3>&, const RotBox<3>&, bool);
-+template bool Intersect<2>(const RotBox<2>&, const Point<2>&, bool);
-+template bool Intersect<3>(const RotBox<3>&, const Point<3>&, bool);
-+template bool Contains<2>(const RotBox<2>&, const Point<2>&, bool);
-+template bool Contains<3>(const RotBox<3>&, const Point<3>&, bool);
-+
-+template bool Intersect<AxisBox<2>,RotBox<2> >(const AxisBox<2>&, const RotBox<2>&, bool);
-+template bool Intersect<AxisBox<3>,RotBox<3> >(const AxisBox<3>&, const RotBox<3>&, bool);
-+template bool Contains<2>(const AxisBox<2>&, const RotBox<2>&, bool);
-+template bool Contains<3>(const AxisBox<3>&, const RotBox<3>&, bool);
-+template bool Contains<2>(const RotBox<2>&, const AxisBox<2>&, bool);
-+template bool Contains<3>(const RotBox<3>&, const AxisBox<3>&, bool);
-+
-+template bool Intersect<Ball<2>,RotBox<2> >(const Ball<2>&, const RotBox<2>&, bool);
-+template bool Intersect<Ball<3>,RotBox<3> >(const Ball<3>&, const RotBox<3>&, bool);
-+template bool Contains<2>(const Ball<2>&, const RotBox<2>&, bool);
-+template bool Contains<3>(const Ball<3>&, const RotBox<3>&, bool);
-+template bool Intersect<2>(const RotBox<2>&, const Ball<2>&, bool);
-+template bool Intersect<3>(const RotBox<3>&, const Ball<3>&, bool);
-+template bool Contains<2>(const RotBox<2>&, const Ball<2>&, bool);
-+template bool Contains<3>(const RotBox<3>&, const Ball<3>&, bool);
-+
-+template bool Intersect<Segment<2>,RotBox<2> >(const Segment<2>&, const RotBox<2>&, bool);
-+template bool Intersect<Segment<3>,RotBox<3> >(const Segment<3>&, const RotBox<3>&, bool);
-+template bool Contains<2>(const Segment<2>&, const RotBox<2>&, bool);
-+template bool Contains<3>(const Segment<3>&, const RotBox<3>&, bool);
-+template bool Intersect<2>(const RotBox<2>&, const Segment<2>&, bool);
-+template bool Intersect<3>(const RotBox<3>&, const Segment<3>&, bool);
-+template bool Contains<2>(const RotBox<2>&, const Segment<2>&, bool);
-+template bool Contains<3>(const RotBox<3>&, const Segment<3>&, bool);
-+
-+template bool Intersect<2>(const RotBox<2>&, const RotBox<2>&, bool);
-+template bool Intersect<3>(const RotBox<3>&, const RotBox<3>&, bool);
-+template bool Contains<2>(const RotBox<2>&, const RotBox<2>&, bool);
-+template bool Contains<3>(const RotBox<3>&, const RotBox<3>&, bool);
-+
- }
diff --git a/math/wfmath/pkg-descr b/math/wfmath/pkg-descr
deleted file mode 100644
index 57ac981ce5cd..000000000000
--- a/math/wfmath/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-This is the Worldforge math library. The primary focus of WFMath is geometric
-objects. Thus, it includes several shapes (boxes, balls, lines), in addition
-to the basic math objects that are used to build these shapes (points,
-vectors, matricies).
diff --git a/math/wfmath/pkg-plist b/math/wfmath/pkg-plist
deleted file mode 100644
index 1870a9f48906..000000000000
--- a/math/wfmath/pkg-plist
+++ /dev/null
@@ -1,41 +0,0 @@
-include/wfmath-1.0/wfmath/MersenneTwister.h
-include/wfmath-1.0/wfmath/atlasconv.h
-include/wfmath-1.0/wfmath/axisbox.h
-include/wfmath-1.0/wfmath/axisbox_funcs.h
-include/wfmath-1.0/wfmath/ball.h
-include/wfmath-1.0/wfmath/ball_funcs.h
-include/wfmath-1.0/wfmath/const.h
-include/wfmath-1.0/wfmath/error.h
-include/wfmath-1.0/wfmath/int_to_string.h
-include/wfmath-1.0/wfmath/intersect.h
-include/wfmath-1.0/wfmath/intersect_decls.h
-include/wfmath-1.0/wfmath/line.h
-include/wfmath-1.0/wfmath/line_funcs.h
-include/wfmath-1.0/wfmath/miniball.h
-include/wfmath-1.0/wfmath/miniball_funcs.h
-include/wfmath-1.0/wfmath/point.h
-include/wfmath-1.0/wfmath/point_funcs.h
-include/wfmath-1.0/wfmath/polygon.h
-include/wfmath-1.0/wfmath/polygon_funcs.h
-include/wfmath-1.0/wfmath/polygon_intersect.h
-include/wfmath-1.0/wfmath/probability.h
-include/wfmath-1.0/wfmath/quaternion.h
-include/wfmath-1.0/wfmath/randgen.h
-include/wfmath-1.0/wfmath/rotbox.h
-include/wfmath-1.0/wfmath/rotbox_funcs.h
-include/wfmath-1.0/wfmath/rotmatrix.h
-include/wfmath-1.0/wfmath/rotmatrix_funcs.h
-include/wfmath-1.0/wfmath/segment.h
-include/wfmath-1.0/wfmath/segment_funcs.h
-include/wfmath-1.0/wfmath/shuffle.h
-include/wfmath-1.0/wfmath/stream.h
-include/wfmath-1.0/wfmath/timestamp.h
-include/wfmath-1.0/wfmath/vector.h
-include/wfmath-1.0/wfmath/vector_funcs.h
-include/wfmath-1.0/wfmath/wfmath.h
-include/wfmath-1.0/wfmath/wrapped_array.h
-include/wfmath-1.0/wfmath/zero.h
-lib/libwfmath-1.0.so
-lib/libwfmath-1.0.so.1
-lib/libwfmath-1.0.so.1.0.0
-libdata/pkgconfig/wfmath-1.0.pc