aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-04-02 12:18:49 +0000
committerDiane Bruce <db@FreeBSD.org>2020-04-02 12:18:49 +0000
commit2dad88284b1b8362e978abb7018b6e2ad73ac09a (patch)
tree6a4c7f316909961b14048e9bcc4d222a4ee96952
parent42035cb31cd18933cbc74e87f01c37a43ac80aa0 (diff)
downloadports-2dad88284b1b8362e978abb7018b6e2ad73ac09a.tar.gz
ports-2dad88284b1b8362e978abb7018b6e2ad73ac09a.zip
VOLK is a sub-project of GNU Radio. Please see http://libvolk.org for bug
tracking, documentation, source code, and contact information about VOLK. VOLK is the Vector-Optimized Library of Kernels. It is a library that contains kernels of hand-written SIMD code for different mathematical operations. Since each SIMD architecture can be very different and no compiler has yet come along to handle vectorization properly or highly efficiently, VOLK approaches the problem differently. For each architecture or platform that a developer wishes to vectorize for, a new proto-kernel is added to VOLK. At runtime, VOLK will select the correct proto-kernel. In this way, the users of VOLK call a kernel for performing the operation that is platform/architecture agnostic. This allows us to write portable SIMD code. Bleeding edge code can be found in our git repository at https://www.gnuradio.org/git/volk.git/.
Notes
Notes: svn path=/head/; revision=530361
-rw-r--r--devel/Makefile1
-rw-r--r--devel/volk/Makefile25
-rw-r--r--devel/volk/distinfo3
-rw-r--r--devel/volk/pkg-descr19
-rw-r--r--devel/volk/pkg-plist169
5 files changed, 217 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5c4c577ca13c..040e8e29345e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6685,6 +6685,7 @@
SUBDIR += violet
SUBDIR += visualparadigm
SUBDIR += vitables
+ SUBDIR += volk
SUBDIR += vstr
SUBDIR += vulkan-headers
SUBDIR += vulkan-tools
diff --git a/devel/volk/Makefile b/devel/volk/Makefile
new file mode 100644
index 000000000000..4087291cb41b
--- /dev/null
+++ b/devel/volk/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= volk
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.2.0
+CATEGORIES= devel comms hamradio
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= VOLK is the Vector-Optimized Library of Kernels
+
+LICENSE= GPLv3
+
+LIB_DEPENDS+= liborc-0.4.so:devel/orc
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/mako/__init__.py:textproc/py-mako@${PY_FLAVOR}
+
+USES= cmake python:3.5+
+
+USE_GITHUB= yes
+GH_ACCOUNT= gnuradio
+GH_PROJECT= volk
+GH_TAGNAME= v2.2.0
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/volk/distinfo b/devel/volk/distinfo
new file mode 100644
index 000000000000..0e926c53e49b
--- /dev/null
+++ b/devel/volk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585701872
+SHA256 (gnuradio-volk-v2.2.0_GH0.tar.gz) = 9745d60c16e7af61b58d3ae0e53e8d4464fd932bb56ae8fd143f6db2e3aa0217
+SIZE (gnuradio-volk-v2.2.0_GH0.tar.gz) = 330436
diff --git a/devel/volk/pkg-descr b/devel/volk/pkg-descr
new file mode 100644
index 000000000000..2a558ce81288
--- /dev/null
+++ b/devel/volk/pkg-descr
@@ -0,0 +1,19 @@
+VOLK is a sub-project of GNU Radio. Please see http://libvolk.org for bug
+tracking, documentation, source code, and contact information about VOLK.
+
+VOLK is the Vector-Optimized Library of Kernels. It is a library that
+contains kernels of hand-written SIMD code for different mathematical
+operations. Since each SIMD architecture can be very different and no
+compiler has yet come along to handle vectorization properly or highly
+efficiently, VOLK approaches the problem differently.
+
+For each architecture or platform that a developer wishes to vectorize for,
+a new proto-kernel is added to VOLK. At runtime, VOLK will select the correct
+proto-kernel. In this way, the users of VOLK call a kernel for performing
+the operation that is platform/architecture agnostic. This allows us to
+write portable SIMD code.
+
+Bleeding edge code can be found in our git repository at
+https://www.gnuradio.org/git/volk.git/.
+
+WWW: https://github.com/gnuradio/volk
diff --git a/devel/volk/pkg-plist b/devel/volk/pkg-plist
new file mode 100644
index 000000000000..b476f8ee0f8a
--- /dev/null
+++ b/devel/volk/pkg-plist
@@ -0,0 +1,169 @@
+bin/volk-config-info
+bin/volk_modtool
+bin/volk_profile
+include/volk/constants.h
+include/volk/saturation_arithmetic.h
+include/volk/volk.h
+include/volk/volk_16i_32fc_dot_prod_32fc.h
+include/volk/volk_16i_branch_4_state_8.h
+include/volk/volk_16i_convert_8i.h
+include/volk/volk_16i_max_star_16i.h
+include/volk/volk_16i_max_star_horizontal_16i.h
+include/volk/volk_16i_permute_and_scalar_add.h
+include/volk/volk_16i_s32f_convert_32f.h
+include/volk/volk_16i_x4_quad_max_star_16i.h
+include/volk/volk_16i_x5_add_quad_16i_x4.h
+include/volk/volk_16ic_convert_32fc.h
+include/volk/volk_16ic_deinterleave_16i_x2.h
+include/volk/volk_16ic_deinterleave_real_16i.h
+include/volk/volk_16ic_deinterleave_real_8i.h
+include/volk/volk_16ic_magnitude_16i.h
+include/volk/volk_16ic_s32f_deinterleave_32f_x2.h
+include/volk/volk_16ic_s32f_deinterleave_real_32f.h
+include/volk/volk_16ic_s32f_magnitude_32f.h
+include/volk/volk_16ic_x2_dot_prod_16ic.h
+include/volk/volk_16ic_x2_multiply_16ic.h
+include/volk/volk_16u_byteswap.h
+include/volk/volk_16u_byteswappuppet_16u.h
+include/volk/volk_32f_64f_add_64f.h
+include/volk/volk_32f_64f_multiply_64f.h
+include/volk/volk_32f_8u_polarbutterfly_32f.h
+include/volk/volk_32f_8u_polarbutterflypuppet_32f.h
+include/volk/volk_32f_accumulator_s32f.h
+include/volk/volk_32f_acos_32f.h
+include/volk/volk_32f_asin_32f.h
+include/volk/volk_32f_atan_32f.h
+include/volk/volk_32f_binary_slicer_32i.h
+include/volk/volk_32f_binary_slicer_8i.h
+include/volk/volk_32f_convert_64f.h
+include/volk/volk_32f_cos_32f.h
+include/volk/volk_32f_expfast_32f.h
+include/volk/volk_32f_index_max_16u.h
+include/volk/volk_32f_index_max_32u.h
+include/volk/volk_32f_invsqrt_32f.h
+include/volk/volk_32f_log2_32f.h
+include/volk/volk_32f_null_32f.h
+include/volk/volk_32f_s32f_32f_fm_detect_32f.h
+include/volk/volk_32f_s32f_calc_spectral_noise_floor_32f.h
+include/volk/volk_32f_s32f_convert_16i.h
+include/volk/volk_32f_s32f_convert_32i.h
+include/volk/volk_32f_s32f_convert_8i.h
+include/volk/volk_32f_s32f_mod_rangepuppet_32f.h
+include/volk/volk_32f_s32f_multiply_32f.h
+include/volk/volk_32f_s32f_normalize.h
+include/volk/volk_32f_s32f_power_32f.h
+include/volk/volk_32f_s32f_s32f_mod_range_32f.h
+include/volk/volk_32f_s32f_stddev_32f.h
+include/volk/volk_32f_sin_32f.h
+include/volk/volk_32f_sqrt_32f.h
+include/volk/volk_32f_stddev_and_mean_32f_x2.h
+include/volk/volk_32f_tan_32f.h
+include/volk/volk_32f_tanh_32f.h
+include/volk/volk_32f_x2_add_32f.h
+include/volk/volk_32f_x2_divide_32f.h
+include/volk/volk_32f_x2_dot_prod_16i.h
+include/volk/volk_32f_x2_dot_prod_32f.h
+include/volk/volk_32f_x2_fm_detectpuppet_32f.h
+include/volk/volk_32f_x2_interleave_32fc.h
+include/volk/volk_32f_x2_max_32f.h
+include/volk/volk_32f_x2_min_32f.h
+include/volk/volk_32f_x2_multiply_32f.h
+include/volk/volk_32f_x2_pow_32f.h
+include/volk/volk_32f_x2_s32f_interleave_16ic.h
+include/volk/volk_32f_x2_subtract_32f.h
+include/volk/volk_32f_x3_sum_of_poly_32f.h
+include/volk/volk_32fc_32f_add_32fc.h
+include/volk/volk_32fc_32f_dot_prod_32fc.h
+include/volk/volk_32fc_32f_multiply_32fc.h
+include/volk/volk_32fc_conjugate_32fc.h
+include/volk/volk_32fc_convert_16ic.h
+include/volk/volk_32fc_deinterleave_32f_x2.h
+include/volk/volk_32fc_deinterleave_64f_x2.h
+include/volk/volk_32fc_deinterleave_imag_32f.h
+include/volk/volk_32fc_deinterleave_real_32f.h
+include/volk/volk_32fc_deinterleave_real_64f.h
+include/volk/volk_32fc_index_max_16u.h
+include/volk/volk_32fc_index_max_32u.h
+include/volk/volk_32fc_magnitude_32f.h
+include/volk/volk_32fc_magnitude_squared_32f.h
+include/volk/volk_32fc_s32f_atan2_32f.h
+include/volk/volk_32fc_s32f_deinterleave_real_16i.h
+include/volk/volk_32fc_s32f_magnitude_16i.h
+include/volk/volk_32fc_s32f_power_32fc.h
+include/volk/volk_32fc_s32f_power_spectrum_32f.h
+include/volk/volk_32fc_s32f_x2_power_spectral_density_32f.h
+include/volk/volk_32fc_s32fc_multiply_32fc.h
+include/volk/volk_32fc_s32fc_rotatorpuppet_32fc.h
+include/volk/volk_32fc_s32fc_x2_rotator_32fc.h
+include/volk/volk_32fc_x2_add_32fc.h
+include/volk/volk_32fc_x2_conjugate_dot_prod_32fc.h
+include/volk/volk_32fc_x2_divide_32fc.h
+include/volk/volk_32fc_x2_dot_prod_32fc.h
+include/volk/volk_32fc_x2_multiply_32fc.h
+include/volk/volk_32fc_x2_multiply_conjugate_32fc.h
+include/volk/volk_32fc_x2_s32f_square_dist_scalar_mult_32f.h
+include/volk/volk_32fc_x2_s32fc_multiply_conjugate_add_32fc.h
+include/volk/volk_32fc_x2_square_dist_32f.h
+include/volk/volk_32i_s32f_convert_32f.h
+include/volk/volk_32i_x2_and_32i.h
+include/volk/volk_32i_x2_or_32i.h
+include/volk/volk_32u_byteswap.h
+include/volk/volk_32u_byteswappuppet_32u.h
+include/volk/volk_32u_popcnt.h
+include/volk/volk_32u_popcntpuppet_32u.h
+include/volk/volk_32u_reverse_32u.h
+include/volk/volk_64f_convert_32f.h
+include/volk/volk_64f_x2_add_64f.h
+include/volk/volk_64f_x2_max_64f.h
+include/volk/volk_64f_x2_min_64f.h
+include/volk/volk_64f_x2_multiply_64f.h
+include/volk/volk_64u_byteswap.h
+include/volk/volk_64u_byteswappuppet_64u.h
+include/volk/volk_64u_popcnt.h
+include/volk/volk_64u_popcntpuppet_64u.h
+include/volk/volk_8i_convert_16i.h
+include/volk/volk_8i_s32f_convert_32f.h
+include/volk/volk_8ic_deinterleave_16i_x2.h
+include/volk/volk_8ic_deinterleave_real_16i.h
+include/volk/volk_8ic_deinterleave_real_8i.h
+include/volk/volk_8ic_s32f_deinterleave_32f_x2.h
+include/volk/volk_8ic_s32f_deinterleave_real_32f.h
+include/volk/volk_8ic_x2_multiply_conjugate_16ic.h
+include/volk/volk_8ic_x2_s32f_multiply_conjugate_32fc.h
+include/volk/volk_8u_conv_k7_r2puppet_8u.h
+include/volk/volk_8u_x2_encodeframepolar_8u.h
+include/volk/volk_8u_x3_encodepolar_8u_x2.h
+include/volk/volk_8u_x3_encodepolarpuppet_8u.h
+include/volk/volk_8u_x4_conv_k7_r2_8u.h
+include/volk/volk_alloc.hh
+include/volk/volk_avx2_intrinsics.h
+include/volk/volk_avx_intrinsics.h
+include/volk/volk_common.h
+include/volk/volk_complex.h
+include/volk/volk_config_fixed.h
+include/volk/volk_cpu.h
+include/volk/volk_malloc.h
+include/volk/volk_neon_intrinsics.h
+include/volk/volk_prefs.h
+include/volk/volk_sse3_intrinsics.h
+include/volk/volk_sse_intrinsics.h
+include/volk/volk_typedefs.h
+include/volk/volk_version.h
+lib/cmake/volk/VolkConfig.cmake
+lib/cmake/volk/VolkConfigVersion.cmake
+lib/cmake/volk/VolkTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/volk/VolkTargets.cmake
+lib/libvolk.so
+lib/libvolk.so.2.2
+%%PYTHON_SITELIBDIR%%/volk_modtool/__init__.py
+%%PYTHON_SITELIBDIR%%/volk_modtool/__init__.pyc
+%%PYTHON_SITELIBDIR%%/volk_modtool/__init__.pyo
+%%PYTHON_SITELIBDIR%%/volk_modtool/cfg.py
+%%PYTHON_SITELIBDIR%%/volk_modtool/cfg.pyc
+%%PYTHON_SITELIBDIR%%/volk_modtool/cfg.pyo
+%%PYTHON_SITELIBDIR%%/volk_modtool/volk_modtool_generate.py
+%%PYTHON_SITELIBDIR%%/volk_modtool/volk_modtool_generate.pyc
+%%PYTHON_SITELIBDIR%%/volk_modtool/volk_modtool_generate.pyo
+libdata/pkgconfig/volk.pc
+@dir include/volk/asm/neon
+@dir include/volk/asm/orc