aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-24 23:41:06 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-24 23:41:06 +0000
commit2e1fdc173831debc50f2c25b86e202c0a4967334 (patch)
treed36fea69025e64f586e5ae9423269a84f29cd862
parent322c0325932a5a2f6ed89821f82f27a3edddef8f (diff)
downloadports-2e1fdc173831debc50f2c25b86e202c0a4967334.tar.gz
ports-2e1fdc173831debc50f2c25b86e202c0a4967334.zip
Change PHP default version to 8.0
- databases/xapian-bindings is a mata port which do not have php:flavors and is unable to be MARKED to IGNORE as one of it's dependent databases/php-xapian do not support php8.0. Hence this creates a circular dependency and it fails to start bulk building. So for now remove PHP from OPTIONS_DEFAULT. PR: 260595 Approved by: ale portmgr(exp-run) Sponsored by: Bounce Experts
-rw-r--r--Mk/Uses/php.mk4
-rw-r--r--Mk/bsd.default-versions.mk2
-rw-r--r--UPDATING16
-rw-r--r--databases/xapian-bindings/Makefile4
4 files changed, 22 insertions, 4 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index ab8d54ec0e00..8f1dd7cc6375 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -190,8 +190,8 @@ PHP_EXT_DIR= 20180731
PHP_EXT_INC= pcre spl
. else
# (rene) default to DEFAULT_VERSIONS
-PHP_EXT_DIR= 20190902
-PHP_EXT_INC= hash pcre spl
+PHP_EXT_DIR= 20200930
+PHP_EXT_INC= hash json pcre spl
. endif
# Try to figure out what the PHP_EXT_DIR should be WRT the
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index c09e3c31eb21..327b477fe180 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -108,7 +108,7 @@ PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
# Possible values: 9.6, 10, 11, 12, 13, 14
PGSQL_DEFAULT?= 13
# Possible values: 7.3, 7.4, 8.0, 8.1
-PHP_DEFAULT?= 7.4
+PHP_DEFAULT?= 8.0
# Possible values: 2.7, 3.7, 3.8, 3.9, 3.10, 3.11
PYTHON_DEFAULT?= 3.8
# Possible values: 2.7
diff --git a/UPDATING b/UPDATING
index 9bd25062a8ea..2ea507392648 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,22 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20220125:
+ AFFECTS: users of lang/php74
+ AUTHOR: tz@FreeBSD.org
+
+ The default version of PHP has been switched from 7.4 to 8.0.
+
+ If you use binary packages you should make a list of php packages
+ before running 'pkg upgrade':
+
+ # pkg info php7\* > ~/installed-php-ports-list
+
+ After the upgrade, check with such list if all your php extensions
+ are still installed, and reinstall them if needed.
+
+ If you use mod_php74 you need to deinstall it and install mod_php80.
+
20220120:
AFFECTS: users of x11-wm/dwm
AUTHOR: 0mp@FreeBSD.org
diff --git a/databases/xapian-bindings/Makefile b/databases/xapian-bindings/Makefile
index 1552e4aba479..825e82444f39 100644
--- a/databases/xapian-bindings/Makefile
+++ b/databases/xapian-bindings/Makefile
@@ -14,7 +14,9 @@ USES= metaport
PORTSCOUT= limitw:1,even
OPTIONS_DEFINE= LUA PERL PHP PYTHON RUBY
-OPTIONS_DEFAULT=LUA PERL PHP PYTHON RUBY
+# While switching php DEFAULT OPTION PHP is creating circular
+# dependency. For now remove default OPTION PHP
+OPTIONS_DEFAULT=LUA PERL PYTHON RUBY
LUA_RUN_DEPENDS= ${LUA_PKGNAMEPREFIX}xapian>=${PORTVERSION}:databases/lua-xapian@${LUA_FLAVOR}
LUA_USES= lua:run