aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2018-04-10 18:41:22 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2018-04-10 18:41:22 +0000
commit2e3fb33924e2162bc435d7b7c29b513d8afc4e34 (patch)
treeccb30061c82db4218241533938096ed825fc4b4f
parente4dea36dcb0ca5be2ad792b4ac11aace6d379e97 (diff)
downloadports-2e3fb33924e2162bc435d7b7c29b513d8afc4e34.tar.gz
ports-2e3fb33924e2162bc435d7b7c29b513d8afc4e34.zip
Document the latest Flash Player vulnerability.
Notes
Notes: svn path=/head/; revision=467003
-rw-r--r--security/vuxml/vuln.xml42
1 files changed, 42 insertions, 0 deletions
diff --git a/security/vuxml/vuln.xml b/security/vuxml/vuln.xml
index c63891997226..c5b9edc6a070 100644
--- a/security/vuxml/vuln.xml
+++ b/security/vuxml/vuln.xml
@@ -58,6 +58,48 @@ Notes:
* Do not forget port variants (linux-f10-libxml2, libxml2, etc.)
-->
<vuxml xmlns="http://www.vuxml.org/apps/vuxml-1">
+ <vuln vid="5c6f7482-3ced-11e8-b157-6451062f0f7a">
+ <topic>Flash Player -- multiple vulnerabilities</topic>
+ <affects>
+ <package>
+ <name>linux-flashplayer</name>
+ <range><lt>29.0.0.140</lt></range>
+ </package>
+ </affects>
+ <description>
+ <body xmlns="http://www.w3.org/1999/xhtml">
+ <p>Adobe reports:</p>
+ <blockquote cite="https://helpx.adobe.com/security/products/flash-player/apsb18-08.html">
+ <ul>
+ <li>This update resolves a use-after-free vulnerability that
+ could lead to remote code execution (CVE-2018-4932).</li>
+ <li>This update resolves out-of-boubds read vulnerabilities that
+ could lead to information disclosure (CVE-2018-4933,
+ CVE-2018-4934).</li>
+ <li>This update resolves out-of-boubds write vulnerabilities that
+ could lead to remote code execution (CVE-2018-4935,
+ CVE-2018-4937).</li>
+ <li>This update resolves a heap overflow vulnerability that
+ could lead to information disclosure (CVE-2018-4936).</li>
+ </ul>
+ </blockquote>
+ </body>
+ </description>
+ <references>
+ <cvename>CVE-2018-4932</cvename>
+ <cvename>CVE-2018-4933</cvename>
+ <cvename>CVE-2018-4934</cvename>
+ <cvename>CVE-2018-4935</cvename>
+ <cvename>CVE-2018-4936</cvename>
+ <cvename>CVE-2018-4937</cvename>
+ <url>https://helpx.adobe.com/security/products/flash-player/apsb18-08.html</url>
+ </references>
+ <dates>
+ <discovery>2018-04-10</discovery>
+ <entry>2018-04-10</entry>
+ </dates>
+ </vuln>
+
<vuln vid="085a087b-3897-11e8-ac53-d8cb8abf62dd">
<topic>Gitlab -- multiple vulnerabilities</topic>
<affects>