aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2025-03-12 12:59:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2025-03-12 13:01:47 +0000
commit2f18602d69c813081dcd0338f5cadb1e65bb7b87 (patch)
tree6b5e498274e0fa35fe143ac516f668d43abacae0
parent619db45fc7c57ca9e155326b9cdd86afc55ad344 (diff)
textproc/asciidoc: explicit the dependencies on libxml2 and libxslt
With newer pkg we plan to dissociate the semantic of LIB_DEPENDS and RUN_DEPENDS, asciidoc does not actually depend on the library part of both libxml2 and libxslt but on the binaries xmllint and xsltproc. USE_GNOME= libxml2 libxslt will result with the runtime dependencies expressed a LIB_DEPENDS which make the packages broken with some upcoming changes in the ports tree and newer pkg.
-rw-r--r--textproc/asciidoc/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/textproc/asciidoc/Makefile b/textproc/asciidoc/Makefile
index 317ac2a92e1b..58db95f86496 100644
--- a/textproc/asciidoc/Makefile
+++ b/textproc/asciidoc/Makefile
@@ -12,11 +12,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= docbook-xsl>=0:textproc/docbook-xsl \
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-RUN_DEPENDS= docbook-xsl>=0:textproc/docbook-xsl
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR} \
+ xmllint:textproc/libxml2
+RUN_DEPENDS= docbook-xsl>=0:textproc/docbook-xsl \
+ xmllint:textproc/libxml2 \
+ xsltproc:textproc/libxslt
-USES= gnome python shebangfix
-USE_GNOME= libxml2 libxslt
+USES= python shebangfix
USE_PYTHON= autoplist noflavors pep517
NO_ARCH= yes