aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-07-11 20:28:21 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-07-11 20:28:21 +0000
commit2f3cbb880dc06413014f6661caea4e046bf36c5f (patch)
tree44b2dea95b57cadc8ef972e5d7ec597c244d3852
parent2c2ec62c72ca36f480a349a7f69ad755a4d226dd (diff)
downloadports-2f3cbb880dc06413014f6661caea4e046bf36c5f.tar.gz
ports-2f3cbb880dc06413014f6661caea4e046bf36c5f.zip
graphics/libemf: Unbreak build with clang16
PR: 272425
-rw-r--r--graphics/libemf/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/graphics/libemf/Makefile b/graphics/libemf/Makefile
index acc1b9079707..00207ef8b4f2 100644
--- a/graphics/libemf/Makefile
+++ b/graphics/libemf/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libEMF
-PORTVERSION= 1.0.13
+DISTVERSION= 1.0.13
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= libemf-${DISTVERSION}
@@ -10,14 +11,21 @@ WWW= http://libemf.sourceforge.net/
LICENSE= LGPL21
-OPTIONS_DEFINE= DOCS
-
-USES= cpe libtool
+USES= compiler:c++14-lang cpe libtool
CPE_VENDOR= ${PORTNAME:tl}_project
+# libEMF 1.10.13 does not work with C++17 which is the default since
+# clang 16. This can be removed once that port starts working with C++17 and
+# has its own USE_CXXSTD removed.
+# See also: https://sourceforge.net/p/libemf/bugs/5/
+USE_CXXSTD= c++14
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
TEST_TARGET= check
+OPTIONS_DEFINE= DOCS
+
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}