aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-03-24 04:56:52 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2024-02-22 08:14:00 +0000
commit2f66c587e24445ca95684f48870f57661b4d5254 (patch)
tree20096797b1652050b4632f9c5c44a319ad00051b
parent9de5bbcb455870623ce0fd791f1fef2afb760adb (diff)
downloadports-2f66c587e24445ca95684f48870f57661b4d5254.tar.gz
ports-2f66c587e24445ca95684f48870f57661b4d5254.zip
comms/gnuradio: Prepare to Qwt 6.2.0
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_DisplayPlot.h14
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_TimeRasterDisplayPlot.h13
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_WaterfallDisplayPlot.h13
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__raster.h15
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__waterfall.h15
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_qtgui__types.h10
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_timeRasterGlobalData.h35
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_waterfallGlobalData.h35
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_lib_ConstellationDisplayPlot.cc10
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_lib_plot__raster.cc29
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_lib_plot__waterfall.cc28
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_lib_timeRasterGlobalData.cc16
-rw-r--r--comms/gnuradio/files/patch-gr-qtgui_lib_waterfallGlobalData.cc16
14 files changed, 250 insertions, 1 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 57a461700628..4205e04581e9 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gnuradio
DISTVERSIONPREFIX= v
DISTVERSION= 3.8.4.0
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= comms astro hamradio
MAINTAINER= hamradio@FreeBSD.org
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_DisplayPlot.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_DisplayPlot.h
new file mode 100644
index 000000000000..26a2b59937c9
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_DisplayPlot.h
@@ -0,0 +1,14 @@
+--- gr-qtgui/include/gnuradio/qtgui/DisplayPlot.h.orig 2024-02-19 05:15:00 UTC
++++ gr-qtgui/include/gnuradio/qtgui/DisplayPlot.h
+@@ -41,7 +41,10 @@
+ #include <vector>
+
+ #if QWT_VERSION >= 0x060000
+-#include <qwt_compat.h>
++typedef QPointF QwtDoublePoint;
++typedef QRectF QwtDoubleRect;
++
++typedef QwtInterval QwtDoubleInterval;
+ #endif
+
+ typedef QList<QColor> QColorList;
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_TimeRasterDisplayPlot.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_TimeRasterDisplayPlot.h
new file mode 100644
index 000000000000..9f0ccb6c159f
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_TimeRasterDisplayPlot.h
@@ -0,0 +1,13 @@
+--- gr-qtgui/include/gnuradio/qtgui/TimeRasterDisplayPlot.h.orig 2024-02-19 05:15:29 UTC
++++ gr-qtgui/include/gnuradio/qtgui/TimeRasterDisplayPlot.h
+@@ -35,7 +35,9 @@
+ #if QWT_VERSION < 0x060000
+ #include <gnuradio/qtgui/plot_waterfall.h>
+ #else
+-#include <qwt_compat.h>
++#include <qwt_interval.h>
++
++typedef QwtInterval QwtDoubleInterval;
+ #endif
+
+ /*!
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_WaterfallDisplayPlot.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_WaterfallDisplayPlot.h
new file mode 100644
index 000000000000..5c77cea2715f
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_WaterfallDisplayPlot.h
@@ -0,0 +1,13 @@
+--- gr-qtgui/include/gnuradio/qtgui/WaterfallDisplayPlot.h.orig 2024-02-19 05:15:53 UTC
++++ gr-qtgui/include/gnuradio/qtgui/WaterfallDisplayPlot.h
+@@ -34,7 +34,9 @@
+ #if QWT_VERSION < 0x060000
+ #include <gnuradio/qtgui/plot_waterfall.h>
+ #else
+-#include <qwt_compat.h>
++#include <qwt_interval.h>
++
++typedef QwtInterval QwtDoubleInterval;
+ #endif
+
+ /*!
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__raster.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__raster.h
new file mode 100644
index 000000000000..a2588451e7cc
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__raster.h
@@ -0,0 +1,15 @@
+--- gr-qtgui/include/gnuradio/qtgui/plot_raster.h.orig 2024-02-19 05:17:07 UTC
++++ gr-qtgui/include/gnuradio/qtgui/plot_raster.h
+@@ -28,8 +28,10 @@
+ #include <qwt_plot_rasteritem.h>
+
+ #if QWT_VERSION >= 0x060000
+-#include <qwt_compat.h>
+-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
++#include <qsize.h>
++#include <qwt_interval.h>
++
++typedef QwtInterval QwtDoubleInterval;
+ #endif
+
+ class QwtColorMap;
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__waterfall.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__waterfall.h
new file mode 100644
index 000000000000..13c1952528df
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_plot__waterfall.h
@@ -0,0 +1,15 @@
+--- gr-qtgui/include/gnuradio/qtgui/plot_waterfall.h.orig 2024-02-19 05:17:32 UTC
++++ gr-qtgui/include/gnuradio/qtgui/plot_waterfall.h
+@@ -28,8 +28,10 @@
+ #include <qwt_plot_rasteritem.h>
+
+ #if QWT_VERSION >= 0x060000
+-#include <qwt_compat.h>
+-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
++#include <qsize.h>
++#include <qwt_interval.h>
++
++typedef QwtInterval QwtDoubleInterval;
+ #endif
+
+ class QwtColorMap;
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_qtgui__types.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_qtgui__types.h
new file mode 100644
index 000000000000..d7ec0bf86b5f
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_qtgui__types.h
@@ -0,0 +1,10 @@
+--- gr-qtgui/include/gnuradio/qtgui/qtgui_types.h.orig 2024-02-19 05:18:00 UTC
++++ gr-qtgui/include/gnuradio/qtgui/qtgui_types.h
+@@ -26,6 +26,7 @@
+ #include <gnuradio/high_res_timer.h>
+ #include <qwt_color_map.h>
+ #include <qwt_scale_draw.h>
++#include <qwt_text.h>
+
+ namespace gr {
+ namespace qtgui {
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_timeRasterGlobalData.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_timeRasterGlobalData.h
new file mode 100644
index 000000000000..b8b260a4e8dc
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_timeRasterGlobalData.h
@@ -0,0 +1,35 @@
+--- gr-qtgui/include/gnuradio/qtgui/timeRasterGlobalData.h.orig 2024-02-19 05:18:25 UTC
++++ gr-qtgui/include/gnuradio/qtgui/timeRasterGlobalData.h
+@@ -27,8 +27,9 @@
+ #include <qwt_raster_data.h>
+
+ #if QWT_VERSION >= 0x060000
+-#include <qwt_compat.h>
+-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
++#include <qwt_interval.h>
++
++typedef QwtInterval QwtDoubleInterval;
+ #endif
+
+ class TimeRasterData : public QwtRasterData
+@@ -47,6 +48,9 @@ class TimeRasterData : public QwtRasterData (public)
+ #if QWT_VERSION < 0x060000
+ virtual QwtDoubleInterval range() const;
+ virtual void setRange(const QwtDoubleInterval&);
++#elif QWT_VERSION >= 0x060200
++ virtual QwtInterval interval(Qt::Axis) const;
++ void setInterval(Qt::Axis, const QwtInterval&);
+ #endif
+
+ virtual double value(double x, double y) const;
+@@ -68,6 +72,10 @@ class TimeRasterData : public QwtRasterData (public)
+ QwtDoubleInterval d_intensityRange;
+ #else
+ QwtInterval d_intensityRange;
++#endif
++
++#if QWT_VERSION >= 0x060200
++ QwtInterval d_intervals[3];
+ #endif
+
+ private:
diff --git a/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_waterfallGlobalData.h b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_waterfallGlobalData.h
new file mode 100644
index 000000000000..7def4080f8a2
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_include_gnuradio_qtgui_waterfallGlobalData.h
@@ -0,0 +1,35 @@
+--- gr-qtgui/include/gnuradio/qtgui/waterfallGlobalData.h.orig 2024-02-19 05:19:43 UTC
++++ gr-qtgui/include/gnuradio/qtgui/waterfallGlobalData.h
+@@ -27,8 +27,9 @@
+ #include <qwt_raster_data.h>
+
+ #if QWT_VERSION >= 0x060000
+-#include <qwt_compat.h>
+-#include <qwt_point_3d.h> // doesn't seem necessary, but is...
++#include <qwt_interval.h>
++
++typedef QwtInterval QwtDoubleInterval;
+ #endif
+
+ class WaterfallData : public QwtRasterData
+@@ -48,6 +49,9 @@ class WaterfallData : public QwtRasterData (public)
+ #if QWT_VERSION < 0x060000
+ virtual QwtDoubleInterval range() const;
+ virtual void setRange(const QwtDoubleInterval&);
++#elif QWT_VERSION >= 0x060200
++ virtual QwtInterval interval(Qt::Axis) const;
++ void setInterval(Qt::Axis, const QwtInterval&);
+ #endif
+
+ virtual double value(double x, double y) const;
+@@ -72,6 +76,10 @@ class WaterfallData : public QwtRasterData (public)
+ QwtDoubleInterval _intensityRange;
+ #else
+ QwtInterval _intensityRange;
++#endif
++
++#if QWT_VERSION >= 0x060200
++ QwtInterval d_intervals[3];
+ #endif
+
+ private:
diff --git a/comms/gnuradio/files/patch-gr-qtgui_lib_ConstellationDisplayPlot.cc b/comms/gnuradio/files/patch-gr-qtgui_lib_ConstellationDisplayPlot.cc
new file mode 100644
index 000000000000..c2052f012146
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_lib_ConstellationDisplayPlot.cc
@@ -0,0 +1,10 @@
+--- gr-qtgui/lib/ConstellationDisplayPlot.cc.orig 2024-02-19 05:20:52 UTC
++++ gr-qtgui/lib/ConstellationDisplayPlot.cc
+@@ -29,6 +29,7 @@
+ #include <qwt_scale_draw.h>
+ #include <QColor>
+ #include <iostream>
++#include <cmath>
+
+ class ConstellationDisplayZoomer : public QwtPlotZoomer
+ {
diff --git a/comms/gnuradio/files/patch-gr-qtgui_lib_plot__raster.cc b/comms/gnuradio/files/patch-gr-qtgui_lib_plot__raster.cc
new file mode 100644
index 000000000000..78548b201aa9
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_lib_plot__raster.cc
@@ -0,0 +1,29 @@
+--- gr-qtgui/lib/plot_raster.cc.orig 2024-02-19 05:21:10 UTC
++++ gr-qtgui/lib/plot_raster.cc
+@@ -257,7 +257,11 @@ QImage PlotTimeRaster::renderImage(const QwtScaleMap&
+ }
+ d_data->data->incrementResidual();
+ } else if (d_data->colorMap->format() == QwtColorMap::Indexed) {
++#if QWT_VERSION >= 0x060200
++ image.setColorTable(d_data->colorMap->colorTable(256));
++#else
+ image.setColorTable(d_data->colorMap->colorTable(intensityRange));
++#endif
+
+ for (int y = rect.top(); y <= rect.bottom(); y++) {
+ const double ty = yyMap.invTransform(y);
+@@ -265,9 +269,13 @@ QImage PlotTimeRaster::renderImage(const QwtScaleMap&
+ unsigned char* line = image.scanLine(y - rect.top());
+ for (int x = rect.left(); x <= rect.right(); x++) {
+ const double tx = xxMap.invTransform(x);
+-
++#if QWT_VERSION >= 0x060200
++ *line++ = d_data->colorMap->colorIndex(
++ 256, intensityRange, d_data->data->value(tx, ty));
++#else
+ *line++ = d_data->colorMap->colorIndex(intensityRange,
+ d_data->data->value(tx, ty));
++#endif
+ }
+ }
+ }
diff --git a/comms/gnuradio/files/patch-gr-qtgui_lib_plot__waterfall.cc b/comms/gnuradio/files/patch-gr-qtgui_lib_plot__waterfall.cc
new file mode 100644
index 000000000000..f20ba3b32598
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_lib_plot__waterfall.cc
@@ -0,0 +1,28 @@
+--- gr-qtgui/lib/plot_waterfall.cc.orig 2024-02-19 05:22:53 UTC
++++ gr-qtgui/lib/plot_waterfall.cc
+@@ -252,7 +252,11 @@ QImage PlotWaterfall::renderImage(const QwtScaleMap& x
+ }
+ }
+ } else if (d_data->colorMap->format() == QwtColorMap::Indexed) {
++#if QWT_VERSION >= 0x060200
++ image.setColorTable(d_data->colorMap->colorTable(256));
++#else
+ image.setColorTable(d_data->colorMap->colorTable(intensityRange));
++#endif
+
+ for (int y = rect.top(); y <= rect.bottom(); y++) {
+ const double ty = yyMap.invTransform(y);
+@@ -261,8 +265,13 @@ QImage PlotWaterfall::renderImage(const QwtScaleMap& x
+ for (int x = rect.left(); x <= rect.right(); x++) {
+ const double tx = xxMap.invTransform(x);
+
++#if QWT_VERSION >= 0x060200
++ *line++ = d_data->colorMap->colorIndex(
++ 256, intensityRange, d_data->data->value(tx, ty));
++#else
+ *line++ = d_data->colorMap->colorIndex(intensityRange,
+ d_data->data->value(tx, ty));
++#endif
+ }
+ }
+ }
diff --git a/comms/gnuradio/files/patch-gr-qtgui_lib_timeRasterGlobalData.cc b/comms/gnuradio/files/patch-gr-qtgui_lib_timeRasterGlobalData.cc
new file mode 100644
index 000000000000..909184d0cbe4
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_lib_timeRasterGlobalData.cc
@@ -0,0 +1,16 @@
+--- gr-qtgui/lib/timeRasterGlobalData.cc.orig 2024-02-19 05:24:01 UTC
++++ gr-qtgui/lib/timeRasterGlobalData.cc
+@@ -155,7 +155,13 @@ void TimeRasterData::setRange(const QwtDoubleInterval&
+ {
+ d_intensityRange = newRange;
+ }
++#elif QWT_VERSION >= 0x060200
++void TimeRasterData::setInterval(Qt::Axis axis, const QwtInterval& interval)
++{
++ d_intervals[axis] = interval;
++}
+
++QwtInterval TimeRasterData::interval(Qt::Axis a) const { return d_intervals[a]; }
+ #endif
+
+
diff --git a/comms/gnuradio/files/patch-gr-qtgui_lib_waterfallGlobalData.cc b/comms/gnuradio/files/patch-gr-qtgui_lib_waterfallGlobalData.cc
new file mode 100644
index 000000000000..b1e8143339d6
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-qtgui_lib_waterfallGlobalData.cc
@@ -0,0 +1,16 @@
+--- gr-qtgui/lib/waterfallGlobalData.cc.orig 2024-02-19 05:24:33 UTC
++++ gr-qtgui/lib/waterfallGlobalData.cc
+@@ -158,7 +158,13 @@ void WaterfallData::setRange(const QwtDoubleInterval&
+ {
+ _intensityRange = newRange;
+ }
++#elif QWT_VERSION >= 0x060200
++void WaterfallData::setInterval(Qt::Axis axis, const QwtInterval& interval)
++{
++ d_intervals[axis] = interval;
++}
+
++QwtInterval WaterfallData::interval(Qt::Axis a) const { return d_intervals[a]; }
+ #endif
+
+