aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2023-05-16 19:16:49 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2023-05-16 19:21:40 +0000
commit304524388125bd1c0f9b788d8e3633c8261b070e (patch)
treea868152770415ff8a146a73771ca2f2c417df2b3
parent0d669e0f36685ff8813ef97a883573fbb8ad4e4f (diff)
downloadports-304524388125bd1c0f9b788d8e3633c8261b070e.tar.gz
ports-304524388125bd1c0f9b788d8e3633c8261b070e.zip
textproc/py-python-lsp-server: Update to 1.7.3
- Adds support for Yapf 0.33 - Fix an empty current working directory value for Pylint Changelog: https://github.com/python-lsp/python-lsp-server/blob/develop/CHANGELOG.md#version-173-20230515 Reported by: portscout, Repology MFH: 2023Q2
-rw-r--r--textproc/py-python-lsp-server/Makefile9
-rw-r--r--textproc/py-python-lsp-server/distinfo6
-rw-r--r--textproc/py-python-lsp-server/files/patch-pyproject.toml25
3 files changed, 22 insertions, 18 deletions
diff --git a/textproc/py-python-lsp-server/Makefile b/textproc/py-python-lsp-server/Makefile
index 0936d0c62c2c..2936022266e3 100644
--- a/textproc/py-python-lsp-server/Makefile
+++ b/textproc/py-python-lsp-server/Makefile
@@ -1,6 +1,5 @@
PORTNAME= python-lsp-server
-PORTVERSION= 1.7.2
-PORTREVISION= 1
+PORTVERSION= 1.7.3
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -44,10 +43,10 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}yapf>0:textproc/py-yapf@${PY_FLAVOR} \
${PYNUMPY}
-# make test: 3 failed, 168 passed, 8 skipped, 21 warnings
+# make test: 3 failed, 168 passed, 8 skipped, 11 warnings
# test/plugins/test_flake8_lint.py:90,219,241: AssertionError
-USES= python:3.7+ pytest
-USE_PYTHON= autoplist concurrent pep517
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
diff --git a/textproc/py-python-lsp-server/distinfo b/textproc/py-python-lsp-server/distinfo
index 0f3ea261c36b..bb9ecb4a3f9a 100644
--- a/textproc/py-python-lsp-server/distinfo
+++ b/textproc/py-python-lsp-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680625275
-SHA256 (python-lsp-server-1.7.2.tar.gz) = b2433467d0fcb8fd45828463ff1cc805837c08731fcea5d7d953d9be776881e1
-SIZE (python-lsp-server-1.7.2.tar.gz) = 97050
+TIMESTAMP = 1684261746
+SHA256 (python-lsp-server-1.7.3.tar.gz) = a31b0525be6ec831c7d2b476b744e5aa5074633e1d1b77ee97f332cde15983ea
+SIZE (python-lsp-server-1.7.3.tar.gz) = 97336
diff --git a/textproc/py-python-lsp-server/files/patch-pyproject.toml b/textproc/py-python-lsp-server/files/patch-pyproject.toml
index daa45ceb646a..12616c1b0d1a 100644
--- a/textproc/py-python-lsp-server/files/patch-pyproject.toml
+++ b/textproc/py-python-lsp-server/files/patch-pyproject.toml
@@ -1,6 +1,6 @@
---- pyproject.toml.orig 2023-03-18 18:10:05 UTC
+--- pyproject.toml.orig 2023-05-15 11:24:53 UTC
+++ pyproject.toml
-@@ -27,27 +27,27 @@ all = [
+@@ -27,29 +27,29 @@ all = [
[project.optional-dependencies]
all = [
@@ -9,17 +9,17 @@
- "mccabe>=0.7.0,<0.8.0",
- "pycodestyle>=2.9.0,<2.11.0",
- "pydocstyle>=6.3.0,<6.4.0",
+- "pyflakes>=2.5.0,<3.1.0",
+- "pylint>=2.5.0,<3",
+ "autopep8>=1.6.0",
+ "flake8>=5.0.0",
+ "mccabe>=0.7.0",
+ "pycodestyle>=2.9.0",
+ "pydocstyle>=6.3.0",
- "pyflakes>=2.5.0,<3.1.0",
-- "pylint>=2.5.0,<3",
++ "pyflakes>=2.5.0",
+ "pylint>=2.5.0",
"rope>1.2.0",
- "yapf<=0.32.0",
- "toml",
+ "yapf>=0.33.0",
"whatthepatch>=1.0.2,<2.0.0"
]
-autopep8 = ["autopep8>=1.6.0,<2.1.0"]
@@ -28,16 +28,21 @@
-pycodestyle = ["pycodestyle>=2.9.0,<2.11.0"]
-pydocstyle = ["pydocstyle>=6.3.0,<6.4.0"]
-pyflakes = ["pyflakes>=2.5.0,<3.1.0"]
+-pylint = ["pylint>=2.5.0,<3"]
+autopep8 = ["autopep8>=1.6.0"]
+flake8 = ["flake8>=5.0.0"]
+mccabe = ["mccabe>=0.7.0"]
+pycodestyle = ["pycodestyle>=2.9.0"]
+pydocstyle = ["pydocstyle>=6.3.0"]
+pyflakes = ["pyflakes>=2.5.0"]
- pylint = ["pylint>=2.5.0,<3"]
++pylint = ["pylint>=2.5.0"]
rope = ["rope>1.2.0"]
--yapf = ["yapf<=0.32.0", "whatthepatch>=1.0.2,<2.0.0", "toml"]
-+yapf = ["yapf<=0.32.0", "whatthepatch>=1.0.2", "toml"]
+-yapf = ["yapf>=0.33.0", "whatthepatch>=1.0.2,<2.0.0"]
++yapf = ["yapf>=0.33.0", "whatthepatch>=1.0.2"]
websockets = ["websockets>=10.3"]
test = [
- "pylint>=2.5.0,<3",
+- "pylint>=2.5.0,<3",
++ "pylint>=2.5.0",
+ "pytest",
+ "pytest-cov",
+ "coverage",