aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2023-07-05 11:43:28 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2023-07-05 12:35:13 +0000
commit30887e6d789c208e55029535416e80ef52b4a595 (patch)
tree2d2bfb3fb56b8121774ea3703a4b03796c5728c2
parentd4a5ef109a15a99ccfdc4a42ee6db8ea299c0f32 (diff)
games/eboard: Unbreak for llvm16
The port does not work with C++17 which is the default since clang 16. This can be removed once that port starts working with C++17. Reported by: pkg-fallout MFH: 2023Q3
-rw-r--r--games/eboard/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index befd1bca26ab..3f78f9e91874 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -21,6 +21,9 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png
USES= compiler:c++11-lang gnome gstreamer perl5 pkgconfig shebangfix tar:bzip2
+# eboard 1.1.13 is not compatible with C++17, which is the default since
+# clang 16. This means ports depending on it also need to use at most C++14.
+USE_CXXSTD= c++11
USE_GITHUB= yes
GH_ACCOUNT= fbergo
USE_GNOME= cairo gdkpixbuf2 gtk20