aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 08:51:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 09:00:41 +0000
commit30a2153ebcebb1a8500e6007ac90713776d3071a (patch)
treedff26d7dd25b25aaad252f41ab7ab53322558131
parent7c317e365c2195d1f283a982e7bfc2db459ba154 (diff)
downloadports-30a2153ebcebb1a8500e6007ac90713776d3071a.tar.gz
ports-30a2153ebcebb1a8500e6007ac90713776d3071a.zip
science/py-h5py: Update to 3.7.0
-rw-r--r--science/py-h5py/Makefile14
-rw-r--r--science/py-h5py/distinfo6
-rw-r--r--science/py-h5py/files/patch-pytest.ini7
-rw-r--r--science/py-h5py/pkg-plist2
4 files changed, 16 insertions, 13 deletions
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index 4885d08ec30a..2e8838f5ced3 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -1,7 +1,7 @@
# Created by: TAOKA Fumiyoshi
PORTNAME= h5py
-PORTVERSION= 3.6.0
+PORTVERSION= 3.7.0
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,19 +17,13 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.15:lang/cython@${PY_FLAVOR} \
${RUN_DEPENDS}
LIB_DEPENDS= libhdf5.so:science/hdf5
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.14.5,1:math/py-numpy@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR}
USES= localbase pkgconfig python:3.7+
USE_PYTHON= autoplist concurrent cython distutils
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30800
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cached-property>=0:devel/py-cached-property@${PY_FLAVOR}
-.endif
-
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
@@ -43,6 +37,6 @@ post-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/examples/*.py ${STAGEDIR}${EXAMPLESDIR}
do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ cd ${WRKSRC} && ${PYTHON_CMD} setup.py test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/py-h5py/distinfo b/science/py-h5py/distinfo
index 8bd498327110..18f1ece22172 100644
--- a/science/py-h5py/distinfo
+++ b/science/py-h5py/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637519900
-SHA256 (h5py-3.6.0.tar.gz) = 8752d2814a92aba4e2b2a5922d2782d0029102d99caaf3c201a566bc0b40db29
-SIZE (h5py-3.6.0.tar.gz) = 384160
+TIMESTAMP = 1653926012
+SHA256 (h5py-3.7.0.tar.gz) = 3fcf37884383c5da64846ab510190720027dca0768def34dd8dcb659dbe5cbf3
+SIZE (h5py-3.7.0.tar.gz) = 392355
diff --git a/science/py-h5py/files/patch-pytest.ini b/science/py-h5py/files/patch-pytest.ini
new file mode 100644
index 000000000000..9f6fe314e9f0
--- /dev/null
+++ b/science/py-h5py/files/patch-pytest.ini
@@ -0,0 +1,7 @@
+--- pytest.ini.orig 2021-05-09 11:55:36 UTC
++++ pytest.ini
+@@ -1,4 +1,3 @@
+ [pytest]
+ filterwarnings =
+ error::h5py.h5py_warnings.H5pyDeprecationWarning
+-required_plugins = pytest-mpi
diff --git a/science/py-h5py/pkg-plist b/science/py-h5py/pkg-plist
index 14c74301a120..73735de9049b 100644
--- a/science/py-h5py/pkg-plist
+++ b/science/py-h5py/pkg-plist
@@ -17,6 +17,7 @@
%%PORTDOCS%%%%DOCSDIR%%/quick.rst
%%PORTDOCS%%%%DOCSDIR%%/refs.rst
%%PORTDOCS%%%%DOCSDIR%%/release_guide.rst
+%%PORTDOCS%%%%DOCSDIR%%/requirements-rtd.txt
%%PORTDOCS%%%%DOCSDIR%%/special.rst
%%PORTDOCS%%%%DOCSDIR%%/strings.rst
%%PORTDOCS%%%%DOCSDIR%%/swmr.rst
@@ -40,6 +41,7 @@
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.4.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.5.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.6.rst
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.7.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/index.rst
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bytesio.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/collective_io.py