aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2022-10-07 01:02:52 +0000
committerJason Helfman <jgh@FreeBSD.org>2022-10-07 01:02:52 +0000
commit30efb2816c2beeddb22060b84aa009e07c91a342 (patch)
treec337838ba322a02a940a8172e3919b0ca8b68566
parentd575da67486ccba512c494d715a999aa7ea77473 (diff)
downloadports-30efb2816c2beeddb22060b84aa009e07c91a342.tar.gz
ports-30efb2816c2beeddb22060b84aa009e07c91a342.zip
x11/fonts/atkinson-hyperlegible: new port had been added (+)
Atkinson Hyperlegible font is named after Braille Institute founder, J. Robert Atkinson. What makes it different from traditional typography design is that it focuses on letterform distinction to increase character recognition, ultimately improving readability.
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/atkinson-hyperlegible/Makefile58
-rw-r--r--x11-fonts/atkinson-hyperlegible/distinfo5
-rw-r--r--x11-fonts/atkinson-hyperlegible/files/pkg-message.in17
-rw-r--r--x11-fonts/atkinson-hyperlegible/pkg-descr4
-rw-r--r--x11-fonts/atkinson-hyperlegible/pkg-plist24
6 files changed, 109 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 2145235afb76..f0c72001fa54 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -17,6 +17,7 @@
SUBDIR += artwiz-aleczapka-de
SUBDIR += artwiz-aleczapka-se
SUBDIR += artwiz-fonts
+ SUBDIR += atkinson-hyperlegible
SUBDIR += averiagwf
SUBDIR += b612
SUBDIR += bdf2sfd
diff --git a/x11-fonts/atkinson-hyperlegible/Makefile b/x11-fonts/atkinson-hyperlegible/Makefile
new file mode 100644
index 000000000000..d7dd8b7a249f
--- /dev/null
+++ b/x11-fonts/atkinson-hyperlegible/Makefile
@@ -0,0 +1,58 @@
+PORTNAME= atkinson-hyperlegible
+PORTVERSION= 2020.0514
+CATEGORIES= x11-fonts accessibility
+MASTER_SITES= https://brailleinstitute.org/wp-content/uploads/${PORTNAME}-font/:source1 \
+ http://brailleinstitute.org/wp-content/uploads/2020/11/:source2
+DISTFILES= ${AHF}-Print-and-Web-${PORTVERSION:S/./-/}.zip:source1 \
+ ${AHF}-License-2020-1104.pdf:source2
+EXTRACT_ONLY= ${AHF}-Print-and-Web-${PORTVERSION:S/./-/}.zip
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Braille Institute font for low vision readers
+WWW= https://brailleinstitute.org/freefont
+
+LICENSE= ATKINSON-HYPERLEGIBLE
+LICENSE_NAME= ATKINSON HYPERLEGIBLE FONT LICENSE
+LICENSE_FILE= ${DISTDIR}/${AHF}-License-2020-1104.pdf
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+USES= fonts zip
+
+OPTIONS_DEFINE= OTF TTF WEB
+OPTIONS_DEFAULT= OTF TTF
+OTF_DESC= Install OTF fonts set
+TTF_DESC= Install TTF fonts set
+WEB_DESC= Install WEB fonts set
+
+AHF= Atkinson-Hyperlegible-Font
+
+OPTIONS_SUB= yes
+SUB_FILES= pkg-message
+NO_ARCH= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${AHF}-Print-and-Web-${PORTVERSION:S/./-/}
+
+.include <bsd.port.options.mk>
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/allfonts
+ @${FIND} ${WRKSRC} -type f -exec ${MV} {} ${WRKSRC}/allfonts \;
+
+do-install:
+ @${DO_NADA}
+
+do-install-TTF-on:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/allfonts/*.ttf ${STAGEDIR}${FONTSDIR}
+
+do-install-OTF-on:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/allfonts/*.otf ${STAGEDIR}${DATADIR}
+
+post-install-WEB-on:
+.for ext in svg eot woff woff2
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/allfonts/*.${ext} ${STAGEDIR}${DATADIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/atkinson-hyperlegible/distinfo b/x11-fonts/atkinson-hyperlegible/distinfo
new file mode 100644
index 000000000000..0ccfb81318dc
--- /dev/null
+++ b/x11-fonts/atkinson-hyperlegible/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1664985764
+SHA256 (Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514.zip) = 9e1a65d53ddadc8253791e958a07bf5aba210ef6155ea9c91b2b4c46bbce53e3
+SIZE (Atkinson-Hyperlegible-Font-Print-and-Web-2020-0514.zip) = 574460
+SHA256 (Atkinson-Hyperlegible-Font-License-2020-1104.pdf) = 066982a89de7ce65f13a1cfabe91f93b5dbb09b6ca23f0525bc53eadb1d03423
+SIZE (Atkinson-Hyperlegible-Font-License-2020-1104.pdf) = 56016
diff --git a/x11-fonts/atkinson-hyperlegible/files/pkg-message.in b/x11-fonts/atkinson-hyperlegible/files/pkg-message.in
new file mode 100644
index 000000000000..0b3cc2d3ff66
--- /dev/null
+++ b/x11-fonts/atkinson-hyperlegible/files/pkg-message.in
@@ -0,0 +1,17 @@
+[
+{ type: install
+ message: <<EOM
+To use these fonts, add the following line to the "Files" section of
+xorg.conf:
+
+ FontPath "%%FONTSDIR%%/"
+
+Users of older versions of X may additionally have to make sure that
+the freetype module is loaded. Check /var/log/Xorg.0.log for error
+messages. If freetype is required, add the following line to the
+"Modules" section of xorg.conf:
+
+ Load "freetype"
+EOM
+}
+]
diff --git a/x11-fonts/atkinson-hyperlegible/pkg-descr b/x11-fonts/atkinson-hyperlegible/pkg-descr
new file mode 100644
index 000000000000..d4b1b49bfc18
--- /dev/null
+++ b/x11-fonts/atkinson-hyperlegible/pkg-descr
@@ -0,0 +1,4 @@
+Atkinson Hyperlegible font is named after Braille Institute founder, J. Robert
+Atkinson. What makes it different from traditional typography design is that
+it focuses on letterform distinction to increase character recognition,
+ultimately improving readability.
diff --git a/x11-fonts/atkinson-hyperlegible/pkg-plist b/x11-fonts/atkinson-hyperlegible/pkg-plist
new file mode 100644
index 000000000000..6a467d1a4d58
--- /dev/null
+++ b/x11-fonts/atkinson-hyperlegible/pkg-plist
@@ -0,0 +1,24 @@
+%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.otf
+%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.otf
+%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.otf
+%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.otf
+%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Bold-102.ttf
+%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-BoldItalic-102.ttf
+%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Italic-102.ttf
+%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Regular-102.ttf
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.eot
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.svg
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.woff
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102a.woff2
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.eot
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.svg
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.woff
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102a.woff2
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.eot
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.svg
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.woff
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102a.woff2
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.eot
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.svg
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.woff
+%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102a.woff2