aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGoran Mekić <meka@tilda.center>2024-10-14 00:30:17 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-10-14 00:30:17 +0000
commit3113582c824ce813db0f1919c074bb01a1723cfc (patch)
tree6b0ece1cb0ea2b5f0b8ba8909da7da2d51115be9
parent65c5d19460382d4822927eb1f5f7c08e88274d87 (diff)
databases/py-ormar: Use USE_PYTHON=cryptography instead of direct dependency
PR: 282065
-rw-r--r--databases/py-ormar/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/py-ormar/Makefile b/databases/py-ormar/Makefile
index 801d003ee5a9..26aec7ecdc37 100644
--- a/databases/py-ormar/Makefile
+++ b/databases/py-ormar/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ormar
DISTVERSION= 0.20.1
+PORTREVISION= 1
CATEGORIES= databases python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +12,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}databases>=0.3.2,<0.9.0:databases/py-databases@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}databases>=0.3.2,<0.9.0:databases/py-databases@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic-extra-types>=0:devel/py-pydantic-extra-types@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic2>=0:devel/py-pydantic2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy14>=1.4.0:databases/py-sqlalchemy14@${PY_FLAVOR} \
@@ -31,7 +31,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asgi-lifespan>=0:devel/py-asgi-lifespan@${P
USES= python
USE_GITHUB= YES
-USE_PYTHON= autoplist concurrent pep517 pytest
+USE_PYTHON= autoplist concurrent cryptography pep517 pytest
GH_ACCOUNT= collerek
TEST_ENV= PYTHONPATH=${WRKSRC}