aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-24 01:27:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-24 01:27:50 +0000
commit315634f10b8459756a55035ca56d74108ae1d3ef (patch)
tree11577754cd159258d21482362c2a0528a70a66a0
parent8832ed34986619f044270884b9dfabfcd9f4e856 (diff)
downloadports-315634f10b8459756a55035ca56d74108ae1d3ef.tar.gz
ports-315634f10b8459756a55035ca56d74108ae1d3ef.zip
devel/py-numba: Broken on systems where OpenMP isn't enabled
Reported by: fallout Approved by: portmgr (blanket)
-rw-r--r--devel/py-numba/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/py-numba/Makefile b/devel/py-numba/Makefile
index 19c292538551..4824f2ae245a 100644
--- a/devel/py-numba/Makefile
+++ b/devel/py-numba/Makefile
@@ -10,6 +10,10 @@ COMMENT= Optimizing compiler for Python using LLVM
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+.if !exists(/usr/include/omp.h)
+BROKEN= requires OpenMP support that is missing on this architecture
+.endif
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>1.11,1:math/py-numpy@${PY_FLAVOR}
LIB_DEPENDS= libtbb.so:devel/tbb
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}llvmlite>=0.31.0:devel/py-llvmlite@${PY_FLAVOR}