aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 16:04:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:42:38 +0000
commit31d49d9d4200a3d9cb5695bb1daee68e28ae7299 (patch)
treef12b91f366d4334e70a9a3439ccf250c6dfa1b0a
parent6b16cc2fe8442ee8d0b93ce8ac87ffc547c581c6 (diff)
downloadports-31d49d9d4200a3d9cb5695bb1daee68e28ae7299.tar.gz
ports-31d49d9d4200a3d9cb5695bb1daee68e28ae7299.zip
science/openbabel: Fix build with llvm16
This was a bit ambiguous as it uses USE_CXXSTD for GCC while gnu++98 for clang. However this patch was tested on 12.4-RELEASE i386/amd64, 13.1-RELEASE amd64 and MAIN amd64. Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--science/openbabel/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index 4f423feebcaf..1cde3a122d32 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libmaeparser.so:science/maeparser \
CONFLICTS_INSTALL= babel
USES= cmake:testing compiler:c++11-lang eigen:3 gnome pkgconfig tar:bz2
-USE_CXXSTD= gnu++98
+USE_CXXSTD= c++11
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_GITHUB= yes # temporary