aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-09-01 19:26:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-09-01 19:28:15 +0000
commit3249865ef32052075c97bfec80dd683c1e7e2c83 (patch)
treea2e78ceb5f56bb7f3a826dc83123d27f7632604c
parente92b15d1f517333f4baddf50be2940a246e4a4a7 (diff)
downloadports-3249865ef32052075c97bfec80dd683c1e7e2c83.tar.gz
ports-3249865ef32052075c97bfec80dd683c1e7e2c83.zip
www/py-requests-gssapi: Add new port
Requests is an HTTP library, written in Python, for human beings. This library adds optional GSSAPI authentication support and supports mutual authentication. It provides a fully backward-compatible shim for the old python-requests-kerberos library. A more powerful interface is provided by the HTTPSPNEGOAuth component, but this is of course not guaranteed to be compatible. Documentation below is written toward the new interface. WWW: https://pypi.org/project/requests-gssapi/
-rw-r--r--www/Makefile1
-rw-r--r--www/py-requests-gssapi/Makefile19
-rw-r--r--www/py-requests-gssapi/distinfo3
-rw-r--r--www/py-requests-gssapi/pkg-descr12
4 files changed, 35 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6f0b1996dc28..4bf872081349 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1721,6 +1721,7 @@
SUBDIR += py-requests-cache93
SUBDIR += py-requests-file
SUBDIR += py-requests-futures
+ SUBDIR += py-requests-gssapi
SUBDIR += py-requests-mock
SUBDIR += py-requests-oauthlib
SUBDIR += py-requests-toolbelt
diff --git a/www/py-requests-gssapi/Makefile b/www/py-requests-gssapi/Makefile
new file mode 100644
index 000000000000..c65be69f2022
--- /dev/null
+++ b/www/py-requests-gssapi/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= requests-gssapi
+PORTVERSION= 1.2.3
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= GSSAPI authentication handler for python-requests
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gssapi>=1.4.1:security/py-gssapi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=1.1.0:www/py-requests@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/py-requests-gssapi/distinfo b/www/py-requests-gssapi/distinfo
new file mode 100644
index 000000000000..9b56f41bb781
--- /dev/null
+++ b/www/py-requests-gssapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1662059140
+SHA256 (requests-gssapi-1.2.3.tar.gz) = 20784508981401f7153c933eed095338933a40818da65a259dbf2d80dccb150e
+SIZE (requests-gssapi-1.2.3.tar.gz) = 19007
diff --git a/www/py-requests-gssapi/pkg-descr b/www/py-requests-gssapi/pkg-descr
new file mode 100644
index 000000000000..94b42833bb9f
--- /dev/null
+++ b/www/py-requests-gssapi/pkg-descr
@@ -0,0 +1,12 @@
+Requests is an HTTP library, written in Python, for human beings. This
+library adds optional GSSAPI authentication support and supports mutual
+authentication.
+
+It provides a fully backward-compatible shim for the old
+python-requests-kerberos library.
+
+A more powerful interface is provided by the HTTPSPNEGOAuth component,
+but this is of course not guaranteed to be compatible. Documentation
+below is written toward the new interface.
+
+WWW: https://pypi.org/project/requests-gssapi/