aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 15:51:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 16:09:47 +0000
commit32b9ed2628d518b290a0f62b412d00da294f4637 (patch)
treeb83b077564b155f81f1db9ab01b644d56dfa0ac2
parentde2945c07bfd9c24ec9bfbc48de92a0613bae8f2 (diff)
downloadports-32b9ed2628d518b290a0f62b412d00da294f4637.tar.gz
ports-32b9ed2628d518b290a0f62b412d00da294f4637.zip
databases/pear-DB: Add NO_ARCH
- Update pkg-descr
-rw-r--r--databases/pear-DB/Makefile2
-rw-r--r--databases/pear-DB/pkg-descr37
2 files changed, 18 insertions, 21 deletions
diff --git a/databases/pear-DB/Makefile b/databases/pear-DB/Makefile
index ff58ea700a27..cf99998b7f2e 100644
--- a/databases/pear-DB/Makefile
+++ b/databases/pear-DB/Makefile
@@ -12,4 +12,6 @@ LICENSE= PHP301
USES= pear
+NO_ARCH= yes
+
.include <bsd.port.mk>
diff --git a/databases/pear-DB/pkg-descr b/databases/pear-DB/pkg-descr
index b14108ebff9a..ba60c40dd90a 100644
--- a/databases/pear-DB/pkg-descr
+++ b/databases/pear-DB/pkg-descr
@@ -1,24 +1,19 @@
-PEAR::DB is a database abstraction layer providing:
+DB is a database abstraction layer providing:
+- an OO-style query API
+- portability features that make programs written for one DBMS work with other
+ DBMS's
+- a DSN (data source name) format for specifying database servers
+- prepare/execute (bind) emulation for databases that don't support it natively
+- a result object for each query response
+- portable error codes
+- sequence emulation
+- sequential and non-sequential row fetching as well as bulk fetching
+- formats fetched rows as associative arrays, ordered arrays or objects
+- row limit support
+- transactions support
+- table information interface
+- DocBook and phpDocumentor API documentation
-* an OO-style query API
-* portability features that make programs written for one DBMS work
-with other DBMS's
-* a DSN (data source name) format for specifying database servers
-* prepare/execute (bind) emulation for databases that don't support
-it natively
-* a result object for each query response
-* portable error codes
-* sequence emulation
-* sequential and non-sequential row fetching as well as bulk fetching
-* formats fetched rows as associative arrays, ordered arrays or objects
-* row limit support
-* transactions support
-* table information interface
-* DocBook and phpDocumentor API documentation
-
-Drivers for the following extensions pass the complete test suite and
-provide interchangeability when all of DB's portability options are
-enabled: fbsql, ibase, informix, msql, mssql, mysql, mysqli, oci8,
-odbc, pgsql, sqlite and sybase.
+DB layers itself on top of PHP's existing database extensions.
WWW: https://pear.php.net/package/DB