aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2018-06-20 04:12:17 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2018-06-20 04:12:17 +0000
commit338fc6d6cca7bf17c48671c9640827f41cc9f00c (patch)
treed869510edfaf0316592d77b6a7af7c6a1a42aa08
parent876c6a10278c32d0a8cd3b1be6d2f36981998042 (diff)
downloadports-338fc6d6cca7bf17c48671c9640827f41cc9f00c.tar.gz
ports-338fc6d6cca7bf17c48671c9640827f41cc9f00c.zip
unbreak sysutils/packer on i386
no revision bump because no package change
Notes
Notes: svn path=/head/; revision=472844
-rw-r--r--sysutils/packer/Makefile12
-rw-r--r--sysutils/packer/files/extra-patch-i38611
2 files changed, 20 insertions, 3 deletions
diff --git a/sysutils/packer/Makefile b/sysutils/packer/Makefile
index 8cf17454622a..878535b4e8a0 100644
--- a/sysutils/packer/Makefile
+++ b/sysutils/packer/Makefile
@@ -13,11 +13,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PLIST_FILES= bin/${PORTNAME}
+USES= go
+
USE_GITHUB= yes
GH_ACCOUNT= hashicorp
-USES= go
-
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-i386
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/packer/files/extra-patch-i386 b/sysutils/packer/files/extra-patch-i386
new file mode 100644
index 000000000000..259d5d21f308
--- /dev/null
+++ b/sysutils/packer/files/extra-patch-i386
@@ -0,0 +1,11 @@
+--- vendor/github.com/Azure/azure-sdk-for-go/services/network/mgmt/2018-01-01/network/expressroutecircuitpeerings.go.orig 2018-06-20 03:54:26 UTC
++++ vendor/github.com/Azure/azure-sdk-for-go/services/network/mgmt/2018-01-01/network/expressroutecircuitpeerings.go
+@@ -50,7 +50,7 @@ func (client ExpressRouteCircuitPeerings
+ {TargetValue: peeringParameters,
+ Constraints: []validation.Constraint{{Target: "peeringParameters.ExpressRouteCircuitPeeringPropertiesFormat", Name: validation.Null, Rule: false,
+ Chain: []validation.Constraint{{Target: "peeringParameters.ExpressRouteCircuitPeeringPropertiesFormat.PeerASN", Name: validation.Null, Rule: false,
+- Chain: []validation.Constraint{{Target: "peeringParameters.ExpressRouteCircuitPeeringPropertiesFormat.PeerASN", Name: validation.InclusiveMaximum, Rule: 4294967295, Chain: nil},
++ Chain: []validation.Constraint{{Target: "peeringParameters.ExpressRouteCircuitPeeringPropertiesFormat.PeerASN", Name: validation.InclusiveMaximum, Rule: 2147483647, Chain: nil},
+ {Target: "peeringParameters.ExpressRouteCircuitPeeringPropertiesFormat.PeerASN", Name: validation.InclusiveMinimum, Rule: 1, Chain: nil},
+ }},
+ }}}}}); err != nil {