aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:11:20 +0000
commit339c6a9b46fc1553ec86ec5b0cac6f9cd861c083 (patch)
tree60941bfb15271ae97e84980d804cac93dd3fb9a4
parent5b93136e223e85fe6e10b691af5860fa2e978e5b (diff)
downloadports-339c6a9b46fc1553ec86ec5b0cac6f9cd861c083.tar.gz
ports-339c6a9b46fc1553ec86ec5b0cac6f9cd861c083.zip
databases/cdb: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--databases/cdb/Makefile1
-rw-r--r--databases/cdb/files/patch-error.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/databases/cdb/Makefile b/databases/cdb/Makefile
index 5b32880e0899..8611cabdd0bb 100644
--- a/databases/cdb/Makefile
+++ b/databases/cdb/Makefile
@@ -1,5 +1,6 @@
PORTNAME= cdb
PORTVERSION= 0.75
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://cr.yp.to/cdb/
diff --git a/databases/cdb/files/patch-error.h b/databases/cdb/files/patch-error.h
new file mode 100644
index 000000000000..e35ddb04802a
--- /dev/null
+++ b/databases/cdb/files/patch-error.h
@@ -0,0 +1,11 @@
+--- error.h.orig
++++ error.h
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;