aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-31 01:59:46 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-31 02:00:41 +0000
commit33eaf26bbb386a81f0d71a99782300c0842e5d53 (patch)
tree777a9489fc6cc029fe6fad7cbade4f0a33dd144e
parent32eb9c0167a0f079b0abdd1ad8fb6ebc40e12275 (diff)
downloadports-33eaf26bbb386a81f0d71a99782300c0842e5d53.tar.gz
ports-33eaf26bbb386a81f0d71a99782300c0842e5d53.zip
net/opennx: Cleanup EXPIRED ports
Approved by: portmgr
-rw-r--r--MOVED1
-rw-r--r--net/Makefile1
-rw-r--r--net/opennx/Makefile57
-rw-r--r--net/opennx/distinfo2
-rw-r--r--net/opennx/files/patch-opennxApp.cpp22
-rw-r--r--net/opennx/pkg-descr21
-rw-r--r--net/opennx/pkg-plist44
7 files changed, 1 insertions, 147 deletions
diff --git a/MOVED b/MOVED
index a8874dd0172f..f87319445135 100644
--- a/MOVED
+++ b/MOVED
@@ -17733,3 +17733,4 @@ comms/ebook2cwgui||2022-12-31|Has expired: Abandoned project, last update 2013-0
databases/firebird25-client||2022-12-31|Has expired: Upstream Support ends on 2019-06-24
databases/firebird25-server||2022-12-31|Has expired: Upstream Support ends on 2019-06-24
multimedia/libkate||2022-12-31|Has expired: Obsolete format that never got any traction and no development in over 10 years
+net/opennx||2022-12-31|Has expired: Abandoned project and use deprecated wxgtk28
diff --git a/net/Makefile b/net/Makefile
index 4f23c835befd..c4385f4363ee 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -568,7 +568,6 @@
SUBDIR += openmpi
SUBDIR += openmpi3
SUBDIR += openntpd
- SUBDIR += opennx
SUBDIR += openpgm
SUBDIR += openradius
SUBDIR += openrsync
diff --git a/net/opennx/Makefile b/net/opennx/Makefile
deleted file mode 100644
index 46cde7d32b59..000000000000
--- a/net/opennx/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-PORTNAME= opennx
-PORTVERSION= 0.16.0.729
-PORTREVISION= 11
-CATEGORIES= net
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/CI-source
-
-MAINTAINER= beyert@cs.ucr.edu
-COMMENT= Open source drop in replacement for NoMachine's NX client
-WWW= http://opennx.net/
-
-DEPRECATED= Abandoned project and use deprecated wxgtk28
-EXPIRATION_DATE= 2022-12-31
-
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BUILD_DEPENDS= ${LOCALBASE}/bin/zip:archivers/zip
-LIB_DEPENDS= libcups.so:print/cups \
- libcurl.so:ftp/curl
-
-USES= gmake gnome samba:lib xorg
-USE_XORG= ice sm x11 xau xmu
-USE_WX= 2.8+
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-0.16
-
-GNU_CONFIGURE= yes
-
-LDFLAGS+= -L${LOCALBASE}/lib -L${SAMBALIBS}
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
-CPPFLAGS+= -I${LOCALBASE}/include -I${SAMBAINCLUDES}
-
-NO_PACKAGE= must generate a fresh private key at install time
-LEGAL_PACKAGE= yes
-
-SSH_KEYGEN?= ssh-keygen
-
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
-
-# do not use default private key included with tarball
-post-patch:
- @${RM} ${WRKSRC}/share/keys/server.id_dsa.key
- @${SSH_KEYGEN} -N '' -b 2048 -q -f ${WRKSRC}/share/keys/server.id_dsa.key
- @${REINPLACE_CMD} 's|/usr/NX/bin/||' \
- ${WRKSRC}/extres/xdg/innovidata-opennx.desktop \
- ${WRKSRC}/extres/xdg/innovidata-opennx-admin.desktop \
- ${WRKSRC}/extres/xdg/innovidata-opennx-wizard.desktop
- @${RM} ${WRKSRC}/extres/xdg/*.bak
-
-post-install:
- @${CHMOD} 440 ${STAGEDIR}${PREFIX}/share/keys/server.id_dsa.key
-
-.include <bsd.port.mk>
diff --git a/net/opennx/distinfo b/net/opennx/distinfo
deleted file mode 100644
index 4e8a302d73cd..000000000000
--- a/net/opennx/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (opennx-0.16.0.729.tar.gz) = 1dd6613a78d5d31b4e496c9185b06cfa47ec6c24b33c6e1f8b43dd176d7d5572
-SIZE (opennx-0.16.0.729.tar.gz) = 5345822
diff --git a/net/opennx/files/patch-opennxApp.cpp b/net/opennx/files/patch-opennxApp.cpp
deleted file mode 100644
index a4a805af02e6..000000000000
--- a/net/opennx/files/patch-opennxApp.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- opennxApp.cpp.orig 2022-11-07 09:51:49 UTC
-+++ opennxApp.cpp
-@@ -759,7 +759,7 @@ void opennxApp::checkNxSmartCardSupport()
- #endif
- if (!fn.FileExists())
- return;
-- time_t last_mtime;
-+ long last_mtime;
- long last_size;
- time_t mtime = fn.GetModificationTime().GetTicks();
- long size = fn.GetSize().ToULong();
-@@ -767,8 +767,8 @@ void opennxApp::checkNxSmartCardSupport()
- wxConfigBase::Get()->Read(wxT("Config/NxSshSize"), &last_size, 0);
- wxConfigBase::Get()->Read(wxT("Config/NxSshSmartCardSupport"), &m_bNxSmartCardSupport, false);
-
-- if ((mtime != last_mtime) || (size != last_size)) {
-- wxConfigBase::Get()->Write(wxT("Config/NxSshStamp"), mtime);
-+ if ((mtime != (time_t)last_mtime) || (size != last_size)) {
-+ wxConfigBase::Get()->Write(wxT("Config/NxSshStamp"), (long)mtime);
- wxConfigBase::Get()->Write(wxT("Config/NxSshSize"), size);
- wxString nxsshcmd = fn.GetShortPath();
- nxsshcmd << wxT(" -I 0 -V");
diff --git a/net/opennx/pkg-descr b/net/opennx/pkg-descr
deleted file mode 100644
index 75350115defe..000000000000
--- a/net/opennx/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-OpenNX is an open source drop in replacement for NoMachine's NX client. It is
-compatible to the original client in that it uses the same syntax for the
-session configuration files (.nxs files). OpenNX is distributed under the GNU
-Lesser Public License v2.1. OpenNX is written in C++ and uses the excellent
-wxWidgets toolkit. Compared to the original client, it also adds some
-additional features which improve usability:
-
- - Ability to use the OpenSC framework to enable SmartCard based
- authentication for the initial SSH connection.
-
- - Ability to use a variety of different proxy types.
-
- - Ability to fetch session configuration files via http (read only)
-
- - Ability to disable configuration controls by providing a read only
- configuration file.
-
- - Dynamic use of libsmbclient, libcups, libopensc and pulseaudio (no static
- dependencies).
-
- - Uses libjpeg-turbo for speed improvement (if available).
diff --git a/net/opennx/pkg-plist b/net/opennx/pkg-plist
deleted file mode 100644
index 8cc3147363e2..000000000000
--- a/net/opennx/pkg-plist
+++ /dev/null
@@ -1,44 +0,0 @@
-bin/opennx
-bin/pconnect
-bin/watchreader
-share/applnk/xdg/innovidata-opennx-admin.desktop
-share/applnk/xdg/innovidata-opennx-wizard.desktop
-share/applnk/xdg/innovidata-opennx.desktop
-share/applnk/xdg/innovidata-opennx.directory
-share/cups/mime.convs
-share/cups/mime.types
-share/icons/128x128/apps/nx.png
-share/icons/128x128/apps/opennx-admin.png
-share/icons/128x128/apps/opennx-wizard.png
-share/icons/128x128/mimetypes/nx-desktop.png
-share/icons/16x16/apps/nx.png
-share/icons/16x16/apps/opennx-admin.png
-share/icons/16x16/apps/opennx-wizard.png
-share/icons/16x16/mimetypes/nx-desktop.png
-share/icons/256x256/apps/nx.png
-share/icons/256x256/apps/opennx-admin.png
-share/icons/256x256/apps/opennx-wizard.png
-share/icons/256x256/mimetypes/nx-desktop.png
-share/icons/32x32/apps/nx.png
-share/icons/32x32/apps/opennx-admin.png
-share/icons/32x32/apps/opennx-wizard.png
-share/icons/32x32/mimetypes/nx-desktop.png
-share/icons/48x48/apps/nx.png
-share/icons/48x48/apps/opennx-admin.png
-share/icons/48x48/apps/opennx-wizard.png
-share/icons/48x48/mimetypes/nx-desktop.png
-share/icons/512x512/apps/nx.png
-share/icons/512x512/apps/opennx-admin.png
-share/icons/512x512/apps/opennx-wizard.png
-share/icons/512x512/mimetypes/nx-desktop.png
-share/icons/scalable/apps/nx.svg
-share/icons/scalable/apps/opennx-admin.svg
-share/icons/scalable/apps/opennx-wizard.svg
-share/icons/scalable/mimetypes/nx-desktop.svg
-share/keyboards
-share/keys/server.id_dsa.key
-share/keys/server.id_dsa.key.pub
-%%NLS%%share/locale/de/LC_MESSAGES/opennx.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/opennx.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/opennx.mo
-share/pconnect.html