aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-02-28 15:29:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-02-28 16:36:03 +0000
commit342ded777ddd526b56b5699c276574a49337451d (patch)
tree09484eaf2ed06df09d4ea327dc21bcc4b0c9872d
parent97ba3e4405acdeec656457be9a2d187550dfb512 (diff)
downloadports-342ded777ddd526b56b5699c276574a49337451d.tar.gz
ports-342ded777ddd526b56b5699c276574a49337451d.zip
sysutils/pam_xdg: temporarily hide on -CURRENT due to POLA violation
https://cgit.freebsd.org/src/commit/?id=6e69612d5df1 https://cgit.freebsd.org/src/commit/?id=6b9e6f12e5bb From a brief look: - by default base uses /var/run/xdg/<user> while the port uses /var/run/user/<uid> - session tracking is unconditional in base but opt-in in the port - base is limited to XDG_RUNTIME_DIR while the port supports other dirs per XDG Base Directory Specification Migrating from the port requires user intervention: - adjust/remount /etc/fstab if /var/run/user was under tmpfs(5) - adjust /etc/pam.d/* to remove unused/unsupported options - re-login to inherit the new XDG_RUNTIME_DIR value - restart *user* services that survived re-login
-rw-r--r--sysutils/pam_xdg/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/sysutils/pam_xdg/Makefile b/sysutils/pam_xdg/Makefile
index d8b7c2ac4f4a..b849c2f4110a 100644
--- a/sysutils/pam_xdg/Makefile
+++ b/sysutils/pam_xdg/Makefile
@@ -13,6 +13,10 @@ USES= uidfix
PLIST_FILES= lib/${PORTNAME}.so \
share/man/man8/${PORTNAME}.8.gz
+.if exists(/usr/lib/pam_xdg.so)
+IGNORE= module name conflict with a different implementation in base system
+.endif
+
# makefile is too crufty, so roll our own
MAKEFILE= bsd.lib.mk
MAKE_ARGS+= SHLIB_NAME="${PORTNAME}.so" MAN="${PORTNAME}.8" \