aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-03-27 15:02:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-03-27 18:25:49 +0000
commit359167a298721dff5bc99fc9bcae00d7819b50f6 (patch)
tree27ec36d7253b9ede4ec45af99cff4b0a9cf5b722
parentb6acc0141788a4544b3aa6f2dfe2e3165b4be95c (diff)
downloadports-359167a298721dff5bc99fc9bcae00d7819b50f6.tar.gz
ports-359167a298721dff5bc99fc9bcae00d7819b50f6.zip
math/cvc5: Fix tests
-rw-r--r--math/cvc5/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/cvc5/Makefile b/math/cvc5/Makefile
index f9fc98a3b875..81b70e6a00e5 100644
--- a/math/cvc5/Makefile
+++ b/math/cvc5/Makefile
@@ -35,7 +35,9 @@ CMAKE_ARGS+= -DANTLR_BINARY=${WRKDIR}/antlr3 \
-DPython_EXECUTABLE:STRING=${PYTHON_CMD}
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_BINDINGS_PYTHON USE_PYTHON3 # Python binding should be a separate port
-CMAKE_TESTING_ON= ENABLE_UNIT_TESTING # 2 tests fail, see https://github.com/cvc5/cvc5/issues/9569
+CMAKE_TESTING_ON= ENABLE_UNIT_TESTING
+CMAKE_TESTING_TARGET= check # check target runs only quick tests (based on https://github.com/cvc5/cvc5/issues/9569#issuecomment-1484943348)
+#CMAKE_TESTING_TARGET= test # test target also runs longer tests, 2 of which fail, see https://github.com/cvc5/cvc5/issues/9569
OPTIONS_DEFINE= COCOALIB EDITLINE JAVA
OPTIONS_GROUP= SOLVERS