aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:03:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:03:30 +0000
commit35b17c292f14e55830723615f78ead2e8169d1c6 (patch)
tree77f1048a5ae6d0d85054e157ef49f6909eb99fc0
parent7a7191f15db8676179b4bbaa549c0f8a24ea4fcb (diff)
downloadports-35b17c292f14e55830723615f78ead2e8169d1c6.tar.gz
ports-35b17c292f14e55830723615f78ead2e8169d1c6.zip
devel/py-epsilon: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-epsilon/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/devel/py-epsilon/Makefile b/devel/py-epsilon/Makefile
index 3311cb06819c..bc8cf3e7fead 100644
--- a/devel/py-epsilon/Makefile
+++ b/devel/py-epsilon/Makefile
@@ -1,5 +1,6 @@
PORTNAME= epsilon
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,20 +12,19 @@ WWW= https://github.com/twisted/epsilon
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=42:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.12.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=13.2.0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:devel/py-zope.interface@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
# bin/benchmark
CONFLICTS_INSTALL= brlcad
-post-patch:
- @${ECHO_CMD} 'setuptools.setup()' > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>