aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2024-02-12 18:16:18 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2024-02-18 15:23:01 +0000
commit35bca82a1fa2b1f46877b804e59554c84d048750 (patch)
tree30ad716413d9830b27ffe9ad2b70c63fbae88bc2
parent6b738c0de9858bcae0664e03c076a42895fd6dc3 (diff)
www/py-dj42-django-celery-results: New port
Celery result backends for django
-rw-r--r--www/Makefile1
-rw-r--r--www/py-dj42-django-celery-results/Makefile21
-rw-r--r--www/py-dj42-django-celery-results/distinfo3
-rw-r--r--www/py-dj42-django-celery-results/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 68fbc8b03828..4e3ab2b78769 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1494,6 +1494,7 @@
SUBDIR += py-dj42-django-allauth
SUBDIR += py-dj42-django-auditlog
SUBDIR += py-dj42-django-auth-ldap
+ SUBDIR += py-dj42-django-celery-results
SUBDIR += py-dj42-django-compression-middleware
SUBDIR += py-dj42-django-cors-headers
SUBDIR += py-dj42-django-debug-toolbar
diff --git a/www/py-dj42-django-celery-results/Makefile b/www/py-dj42-django-celery-results/Makefile
new file mode 100644
index 000000000000..82f507cf6078
--- /dev/null
+++ b/www/py-dj42-django-celery-results/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= django-celery-results
+PORTVERSION= 2.5.1
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj42-
+DISTNAME= ${PORTNAME:S/-/_/g}-${PORTVERSION}
+
+MAINTAINER= grembo@FreeBSD.org
+COMMENT= Celery result backends for django
+WWW= https://github.com/celery/django-celery-results
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=3.2:www/py-django42@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}celery>=5.3.6:devel/py-celery@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/py-dj42-django-celery-results/distinfo b/www/py-dj42-django-celery-results/distinfo
new file mode 100644
index 000000000000..89582fc7649d
--- /dev/null
+++ b/www/py-dj42-django-celery-results/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1707610742
+SHA256 (django_celery_results-2.5.1.tar.gz) = 3ecb7147f773f34d0381bac6246337ce4cf88a2ea7b82774ed48e518b67bb8fd
+SIZE (django_celery_results-2.5.1.tar.gz) = 80944
diff --git a/www/py-dj42-django-celery-results/pkg-descr b/www/py-dj42-django-celery-results/pkg-descr
new file mode 100644
index 000000000000..da24ab97a379
--- /dev/null
+++ b/www/py-dj42-django-celery-results/pkg-descr
@@ -0,0 +1,6 @@
+Celery Result Backends using the Django ORM/Cache framework.
+
+This extension enables you to store Celery task results using the Django
+ORM. It defines a single model (django_celery_results.models.TaskResult)
+used to store task results, and you can query this database table like any
+other Django model.