aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPichi <pichi@elude.in>2021-07-28 09:55:02 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-07-28 09:57:14 +0000
commit35ee8b366dc57209ad54b85c88b6a094362baa78 (patch)
tree6de4404a489cec0f6b2e04885f140a2f4db7bc53
parentd9c0a9f4288b478e07a1bc998cdf710acfad5df1 (diff)
downloadports-35ee8b366dc57209ad54b85c88b6a094362baa78.tar.gz
ports-35ee8b366dc57209ad54b85c88b6a094362baa78.zip
net/pichi: Update to 1.4.0
-rw-r--r--net/pichi/Makefile10
-rw-r--r--net/pichi/distinfo6
-rw-r--r--net/pichi/files/patch-cmake_Configure.cmake26
-rw-r--r--net/pichi/files/patch-include_pichi_config.hpp.in63
-rw-r--r--net/pichi/files/patch-src_api_egress__manager.cpp26
-rw-r--r--net/pichi/files/patch-src_api_vos.cpp65
-rw-r--r--net/pichi/files/patch-src_net_spawn.cpp14
-rw-r--r--net/pichi/pkg-plist40
8 files changed, 33 insertions, 217 deletions
diff --git a/net/pichi/Makefile b/net/pichi/Makefile
index 889d577edda3..c887e203d6ad 100644
--- a/net/pichi/Makefile
+++ b/net/pichi/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pichi
-DISTVERSION= 1.3.1
+DISTVERSION= 1.4.0
CATEGORIES= net
MAINTAINER= pichi@elude.in
@@ -24,13 +24,9 @@ CMAKE_ON= BUILD_SERVER BUILD_TEST
INSTALL_TARGET= install/strip
TEST_TARGET= test
-OPTIONS_DEFINE= DEVEL STATIC TLS
-OPTIONS_DEFAULT= TLS
+OPTIONS_DEFINE= DEVEL STATIC
OPTIONS_SUB= yes
-TLS_DESC= Enable TLS support ( requiring OpenSSL )
-TLS_CMAKE_BOOL= ENABLE_TLS
-
STATIC_DESC= Static linking
STATIC_CMAKE_BOOL= STATIC_LINK
STATIC_BUILD_DEPENDS= boost-libs>=1.67.0:devel/boost-libs \
@@ -53,13 +49,11 @@ DEVEL_CMAKE_BOOL= INSTALL_DEVEL
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MTLS}
.if ${PORT_OPTIONS:MSTATIC}
USES+= ssl:build
.else
USES+= ssl
.endif
-.endif
post-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
diff --git a/net/pichi/distinfo b/net/pichi/distinfo
index 3242a2cf6f8e..642af0a06d36 100644
--- a/net/pichi/distinfo
+++ b/net/pichi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1599981725
-SHA256 (pichi-router-pichi-1.3.1_GH0.tar.gz) = be1dc4d501387ef3524697ac804bec3ceb235a0c323ef8901532f04b0fab5cac
-SIZE (pichi-router-pichi-1.3.1_GH0.tar.gz) = 2068432
+TIMESTAMP = 0
+SHA256 (pichi-router-pichi-1.4.0_GH0.tar.gz) = 9b6cfadb57f80af516fb8a7d6d1199ad1c03f1c5ba0378a223c0733b12b27482
+SIZE (pichi-router-pichi-1.4.0_GH0.tar.gz) = 2081661
diff --git a/net/pichi/files/patch-cmake_Configure.cmake b/net/pichi/files/patch-cmake_Configure.cmake
deleted file mode 100644
index f0622740d282..000000000000
--- a/net/pichi/files/patch-cmake_Configure.cmake
+++ /dev/null
@@ -1,26 +0,0 @@
---- cmake/Configure.cmake.orig 1970-01-01 00:00:00 UTC
-+++ cmake/Configure.cmake
-@@ -104,6 +104,14 @@ else ()
- set(DEPRECATED_RFC2818_CLASS OFF)
- endif ()
-
-+if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND
-+ CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL "11.0.0")
-+ # From clang 11.0.0, using std::allocator<void> triggers -Wdeprecated-declarations
-+ set(DEPRECATED_ALLOCATOR_VOID ON)
-+else ()
-+ set(DEPRECATED_ALLOCATOR_VOID OFF)
-+endif ()
-+
- # TODO check_cxx_compiler_flag command always gets failed when generating for iOS
- if (IOS)
- set(DISABLE_SHORTEN_64_TO_32_WARNING ON)
-@@ -125,6 +133,7 @@ if (BUILD_SERVER)
- check_function_exists("close" HAS_CLOSE)
- endif ()
-
--configure_file(${CMAKE_SOURCE_DIR}/include/pichi/config.hpp.in ${CMAKE_BINARY_DIR}/include/pichi/config.hpp)
-+configure_file(${CMAKE_SOURCE_DIR}/include/pichi/config.hpp.in
-+ ${CMAKE_BINARY_DIR}/include/pichi/config.hpp)
-
- message(STATUS "Generating config.hpp - done")
diff --git a/net/pichi/files/patch-include_pichi_config.hpp.in b/net/pichi/files/patch-include_pichi_config.hpp.in
deleted file mode 100644
index 91b14474db0d..000000000000
--- a/net/pichi/files/patch-include_pichi_config.hpp.in
+++ /dev/null
@@ -1,63 +0,0 @@
---- include/pichi/config.hpp.in.orig 1970-01-01 00:00:00 UTC
-+++ include/pichi/config.hpp.in
-@@ -25,7 +25,7 @@
- #pragma clang diagnostic ignored "-Wreturn-std-move"
- #include <boost/asio/ip/basic_resolver.hpp>
- #pragma clang diagnostic pop
--#endif // NO_RETURN_STD_MOVE_FOR_BOOST_ASIO && __clang__
-+#endif // NO_RETURN_STD_MOVE_FOR_BOOST_ASIO && __clang__
-
- #cmakedefine DISABLE_SHORTEN_64_TO_32_WARNING
- #if defined(DISABLE_SHORTEN_64_TO_32_WARNING) && defined(__clang__)
-@@ -33,7 +33,7 @@
- #pragma clang diagnostic ignored "-Wshorten-64-to-32"
- #include <boost/asio/basic_socket.hpp>
- #pragma clang diagnostic pop
--#endif // NO_RETURN_STD_MOVE_FOR_BOOST_ASIO && __clang__
-+#endif // NO_RETURN_STD_MOVE_FOR_BOOST_ASIO && __clang__
-
- #cmakedefine DISABLE_C4702_FOR_BEAST_FIELDS
- #if defined(DISABLE_C4702_FOR_BEAST_FIELDS) && defined(_MSC_VER)
-@@ -41,7 +41,7 @@
- #pragma warning(disable : 4702)
- #include <boost/beast/http/fields.hpp>
- #pragma warning(pop)
--#endif // DISABLE_C4702_FOR_BEAST_FIELDS && _MSC_VER
-+#endif // DISABLE_C4702_FOR_BEAST_FIELDS && _MSC_VER
-
- #ifdef __clang__
- #if !__has_feature(c_atomic)
-@@ -49,18 +49,28 @@
- #pragma clang diagnostic ignored "-Wc11-extensions"
- #include <boost/smart_ptr/detail/sp_counted_base_clang.hpp>
- #pragma clang diagnostic pop
--#endif // !__has_feature(c_atomic)
--#endif // __clang__
-+#endif // !__has_feature(c_atomic)
-+#endif // __clang__
-
-+#cmakedefine DEPRECATED_ALLOCATOR_VOID
-+#if defined(DEPRECATED_ALLOCATOR_VOID) && defined(__clang__)
-+#pragma clang diagnostic push
-+#pragma clang diagnostic ignored "-Wdeprecated-declarations"
-+#include <boost/asio/associated_allocator.hpp>
-+#include <boost/asio/impl/executor.hpp>
-+#include <boost/beast/core/async_base.hpp>
-+#pragma clang diagnostic pop
-+#endif // DEPRECATED_ALLOCATOR_VOID && __clang__
-+
- #cmakedefine CMAKE_INSTALL_PREFIX "@CMAKE_INSTALL_PREFIX@"
-
- #ifdef CMAKE_INSTALL_PREFIX
- #define PICHI_PREFIX CMAKE_INSTALL_PREFIX
--#else // CMAKE_INSTALL_PREFIX
-+#else // CMAKE_INSTALL_PREFIX
- #error "CMAKE_INSTALL_PREFIX not defined"
--#endif // CMAKE_INSTALL_PREFIX
-+#endif // CMAKE_INSTALL_PREFIX
-
- #cmakedefine ENABLE_TLS
- #cmakedefine BUILD_TEST
-
--#endif // PICHI_CONFIG_H
-+#endif // PICHI_CONFIG_H
diff --git a/net/pichi/files/patch-src_api_egress__manager.cpp b/net/pichi/files/patch-src_api_egress__manager.cpp
deleted file mode 100644
index 140f6887eb18..000000000000
--- a/net/pichi/files/patch-src_api_egress__manager.cpp
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/api/egress_manager.cpp.orig 1970-01-01 00:00:00 UTC
-+++ src/api/egress_manager.cpp
-@@ -1,5 +1,6 @@
--#include <pichi/api/egress_manager.hpp>
- #include <pichi/config.hpp>
-+// Include config.hpp first
-+#include <pichi/api/egress_manager.hpp>
-
- using namespace std;
-
-@@ -9,7 +10,7 @@ void EgressManager::update(string const& name, EgressV
- {
- #ifndef ENABLE_TLS
- assertFalse(vo.tls_.has_value() && *vo.tls_, PichiError::SEMANTIC_ERROR, "TLS not supported");
--#endif // ENABLE_TLS
-+#endif // ENABLE_TLS
- c_[name] = move(vo);
- }
-
-@@ -25,4 +26,4 @@ EgressManager::ConstIterator EgressManager::end() cons
-
- EgressManager::ConstIterator EgressManager::find(string_view name) const { return c_.find(name); }
-
--} // namespace pichi::api
-\ No newline at end of file
-+} // namespace pichi::api
diff --git a/net/pichi/files/patch-src_api_vos.cpp b/net/pichi/files/patch-src_api_vos.cpp
deleted file mode 100644
index 40a08a8c787d..000000000000
--- a/net/pichi/files/patch-src_api_vos.cpp
+++ /dev/null
@@ -1,65 +0,0 @@
---- src/api/vos.cpp.orig 1970-01-01 00:00:00 UTC
-+++ src/api/vos.cpp
-@@ -1,3 +1,5 @@
-+#include <pichi/config.hpp>
-+// Include config.hpp first
- #include <numeric>
- #include <pichi/api/vos.hpp>
- #include <pichi/common.hpp>
-@@ -57,7 +59,7 @@ static decltype(auto) keyFile_ = "key_file";
- static decltype(auto) destinations_ = "destinations";
- static decltype(auto) balance_ = "balance";
-
--} // namespace IngressVOKey
-+} // namespace IngressVOKey
-
- namespace EgressVOKey {
-
-@@ -73,7 +75,7 @@ static decltype(auto) tls_ = "tls";
- static decltype(auto) insecure_ = "insecure";
- static decltype(auto) caFile_ = "ca_file";
-
--} // namespace EgressVOKey
-+} // namespace EgressVOKey
-
- namespace RuleVOKey {
-
-@@ -84,20 +86,20 @@ static decltype(auto) pattern_ = "pattern";
- static decltype(auto) domain_ = "domain";
- static decltype(auto) country_ = "country";
-
--} // namespace RuleVOKey
-+} // namespace RuleVOKey
-
- namespace RouteVOKey {
-
- static decltype(auto) default_ = "default";
- static decltype(auto) rules_ = "rules";
-
--} // namespace RouteVOKey
-+} // namespace RouteVOKey
-
- namespace ErrorVOKey {
-
- static decltype(auto) message_ = "message";
-
--} // namespace ErrorVOKey
-+} // namespace ErrorVOKey
-
- namespace msg {
-
-@@ -129,7 +131,7 @@ static auto const TOO_LONG_NAME_PASSWORD = "Name or pa
- static auto const MISSING_DESTINATIONS_FIELD = "Missiong destinations field"sv;
- static auto const MISSING_BALANCE_FIELD = "Missiong balance field"sv;
-
--} // namespace msg
-+} // namespace msg
-
- static DelayMode parseDelayMode(json::Value const& v)
- {
-@@ -683,4 +685,4 @@ template <> RouteVO parse(json::Value const& v)
- return rvo;
- }
-
--} // namespace pichi::api
-+} // namespace pichi::api
diff --git a/net/pichi/files/patch-src_net_spawn.cpp b/net/pichi/files/patch-src_net_spawn.cpp
deleted file mode 100644
index fffffb3a5d8d..000000000000
--- a/net/pichi/files/patch-src_net_spawn.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/net/spawn.cpp.orig 1970-01-01 00:00:00 UTC
-+++ src/net/spawn.cpp
-@@ -1,3 +1,5 @@
-+#include <pichi/config.hpp>
-+// Include config.hpp first
- #include <boost/beast/http/error.hpp>
- #include <iostream>
- #include <pichi/exception.hpp>
-@@ -28,4 +30,4 @@ void logException(std::exception_ptr eptr) noexcept
-
- void stubHandler(std::exception_ptr, asio::yield_context) noexcept {}
-
--} // namespace pichi::net
-+} // namespace pichi::net
diff --git a/net/pichi/pkg-plist b/net/pichi/pkg-plist
index 962a59ff43db..a534d9e883fb 100644
--- a/net/pichi/pkg-plist
+++ b/net/pichi/pkg-plist
@@ -9,35 +9,51 @@ bin/pichi
%%DEVEL%%include/pichi/api/egress_manager.hpp
%%DEVEL%%include/pichi/api/ingress_holder.hpp
%%DEVEL%%include/pichi/api/ingress_manager.hpp
-%%DEVEL%%include/pichi/api/iterator.hpp
%%DEVEL%%include/pichi/api/rest.hpp
%%DEVEL%%include/pichi/api/router.hpp
%%DEVEL%%include/pichi/api/server.hpp
%%DEVEL%%include/pichi/api/session.hpp
-%%DEVEL%%include/pichi/api/vos.hpp
-%%DEVEL%%include/pichi/asserts.hpp
-%%DEVEL%%include/pichi/buffer.hpp
-%%DEVEL%%include/pichi/common.hpp
-%%DEVEL%%include/pichi/config.hpp
+%%DEVEL%%include/pichi/common/adapter.hpp
+%%DEVEL%%include/pichi/common/asserts.hpp
+%%DEVEL%%include/pichi/common/buffer.hpp
+%%DEVEL%%include/pichi/common/config.hpp
+%%DEVEL%%include/pichi/common/constants.hpp
+%%DEVEL%%include/pichi/common/endpoint.hpp
+%%DEVEL%%include/pichi/common/enumerations.hpp
+%%DEVEL%%include/pichi/common/exception.hpp
+%%DEVEL%%include/pichi/common/literals.hpp
+%%DEVEL%%include/pichi/common/uri.hpp
%%DEVEL%%include/pichi/crypto/aead.hpp
%%DEVEL%%include/pichi/crypto/base64.hpp
%%DEVEL%%include/pichi/crypto/hash.hpp
%%DEVEL%%include/pichi/crypto/key.hpp
%%DEVEL%%include/pichi/crypto/method.hpp
%%DEVEL%%include/pichi/crypto/stream.hpp
-%%DEVEL%%include/pichi/exception.hpp
%%DEVEL%%include/pichi/net/adapter.hpp
-%%DEVEL%%include/pichi/net/asio.hpp
-%%DEVEL%%include/pichi/net/common.hpp
%%DEVEL%%include/pichi/net/direct.hpp
-%%DEVEL%%include/pichi/net/helpers.hpp
+%%DEVEL%%include/pichi/net/helper.hpp
%%DEVEL%%include/pichi/net/http.hpp
%%DEVEL%%include/pichi/net/reject.hpp
%%DEVEL%%include/pichi/net/socks5.hpp
%%DEVEL%%include/pichi/net/spawn.hpp
%%DEVEL%%include/pichi/net/ssaead.hpp
%%DEVEL%%include/pichi/net/ssstream.hpp
-%%DEVEL%%include/pichi/net/stream.hpp
+%%DEVEL%%include/pichi/net/trojan.hpp
%%DEVEL%%include/pichi/net/tunnel.hpp
-%%DEVEL%%include/pichi/uri.hpp
+%%DEVEL%%include/pichi/stream/test.hpp
+%%DEVEL%%include/pichi/stream/tls.hpp
+%%DEVEL%%include/pichi/stream/traits.hpp
+%%DEVEL%%include/pichi/stream/websocket.hpp
+%%DEVEL%%include/pichi/vo/credential.hpp
+%%DEVEL%%include/pichi/vo/egress.hpp
+%%DEVEL%%include/pichi/vo/error.hpp
+%%DEVEL%%include/pichi/vo/ingress.hpp
+%%DEVEL%%include/pichi/vo/iterator.hpp
+%%DEVEL%%include/pichi/vo/keys.hpp
+%%DEVEL%%include/pichi/vo/messages.hpp
+%%DEVEL%%include/pichi/vo/options.hpp
+%%DEVEL%%include/pichi/vo/parse.hpp
+%%DEVEL%%include/pichi/vo/route.hpp
+%%DEVEL%%include/pichi/vo/rule.hpp
+%%DEVEL%%include/pichi/vo/to_json.hpp
%%DEVEL%%include/pichi.h