aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMilan Obuch <bsd@dino.sk>2022-10-31 21:14:18 +0000
committerJuraj Lutter <otis@FreeBSD.org>2022-10-31 21:57:46 +0000
commit362d1c601c4ce43ad6463dec09e2a7b99b8f170d (patch)
treecd87d7f76ca54fa304e2f25ec32c566012869a7f
parent1441b8233d6bb1e1cc095ac52d7fb3b735712d33 (diff)
downloadports-362d1c601c4ce43ad6463dec09e2a7b99b8f170d.tar.gz
ports-362d1c601c4ce43ad6463dec09e2a7b99b8f170d.zip
mail/claws-mail: Allow for GTK2 or GTK3 variants
Claws Mail team released GTK3 version for some time along with older GTK2. Development focus slowly shifts to GTK3. Add the option to select GTK2 and GTK3 version, keeping GTK2 as default for now. PR: 267043 Approved by: Chris Hutchinson (maintainer)
-rw-r--r--mail/claws-mail/Makefile22
-rw-r--r--mail/claws-mail/Makefile.claws4
-rw-r--r--mail/claws-mail/Makefile.ver9
-rw-r--r--mail/claws-mail/distinfo3
-rw-r--r--mail/claws-mail/files/extra-patch-configure.ac (renamed from mail/claws-mail/files/patch-configure.ac)6
-rw-r--r--mail/claws-mail/pkg-plist6
6 files changed, 40 insertions, 10 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 972a6d89f345..e6eea73f94f5 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -23,17 +23,21 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss \
USES= autoreconf compiler:c++11-lang cpe desktop-file-utils gettext \
gettext-tools gnome pathfix pkgconfig python:3.5+ shebangfix \
ssl xorg
-USE_GNOME= cairo gtk20 librsvg2
+USE_GNOME= cairo librsvg2
USE_XORG= ice sm
SHEBANG_FILES= tools/*.pl tools/*.py tools/tb2claws-mail
OPTIONS_DEFINE= COMPFACE DEBUG DOCS ENCHANT IPV6 LDAP NLS STARTUP \
THEMES
-OPTIONS_DEFAULT= COMPFACE ENCHANT STARTUP THEMES
+OPTIONS_DEFAULT= COMPFACE ENCHANT GTK2 STARTUP THEMES
+OPTIONS_RADIO= BRANCH
+OPTIONS_RADIO_BRANCH= GTK2 GTK3
OPTIONS_SUB= yes
COMPFACE_DESC= X-Face support
ENCHANT_DESC= Spell checking support
+GTK2_DESC= Build GTK2+ release
+GTK3_DESC= Build GTK3+ release
STARTUP_DESC= Startup notification support
THEMES_DESC= Additional themes
@@ -58,8 +62,22 @@ STARTUP_CONFIGURE_ENABLE= startup-notification
THEMES_RUN_DEPENDS= claws-mail-themes>0:x11-themes/claws-mail-themes
+.include <bsd.port.options.mk>
+MASTER_OPTIONS= ${PORT_OPTIONS}
.include "Makefile.claws"
+.if ${PORT_OPTIONS:MGTK2}
+USE_GNOME+= gtk20
+
+PLIST_SUB+= GTK2=""
+.else
+PLIST_SUB+= GTK2="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MGTK3}
+USE_GNOME+= gtk30
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/common/ssl.c
diff --git a/mail/claws-mail/Makefile.claws b/mail/claws-mail/Makefile.claws
index dc05c10dedf5..53ee30e66310 100644
--- a/mail/claws-mail/Makefile.claws
+++ b/mail/claws-mail/Makefile.claws
@@ -13,6 +13,10 @@ CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG} --disable-dbus --disable-static
.include "${.CURDIR}/../claws-mail/Makefile.ver"
.include "${.CURDIR}/../claws-mail/Makefile.claws.plugins"
+.if ${MASTER_OPTIONS:MGTK2}
+EXTRA_PATCHES+= ${.CURDIR}/../claws-mail/files/extra-patch-configure.ac
+.endif
+
.for p in ${CLAWS_PLUGINS}
CONFIGURE_ARGS+= --disable-${p}-plugin
.endfor
diff --git a/mail/claws-mail/Makefile.ver b/mail/claws-mail/Makefile.ver
index 251cf99d6626..919bdfbb00da 100644
--- a/mail/claws-mail/Makefile.ver
+++ b/mail/claws-mail/Makefile.ver
@@ -1 +1,10 @@
+.if !defined(MASTER_OPTIONS)
+MASTER_OPTIONS!= ${MAKE} -C ${.CURDIR}/../claws-mail -V PORT_OPTIONS
+.endif
+
+.if ${MASTER_OPTIONS:MGTK2}
PORTVERSION= 3.19.0
+.endif
+.if ${MASTER_OPTIONS:MGTK3}
+PORTVERSION= 4.1.0
+.endif
diff --git a/mail/claws-mail/distinfo b/mail/claws-mail/distinfo
index 1c824e70b128..827f254ce753 100644
--- a/mail/claws-mail/distinfo
+++ b/mail/claws-mail/distinfo
@@ -1,4 +1,3 @@
-TIMESTAMP = 1652727190
+TIMESTAMP = 1667251029
SHA256 (claws-mail-3.19.0.tar.xz) = 0d0c757a9975da1f97bf5309cd051c18ad6c765fefe9319276aa3a9e48229fa2
-SHA512 (claws-mail-3.19.0.tar.xz) = 88780df55873919197d3c6df5102a8eb89a586e8287419c179e1d0af839435a719814b1e3643aa783a7badeadceafda2dc3cb4a3265432b5ad3a210663922b20
SIZE (claws-mail-3.19.0.tar.xz) = 6543188
diff --git a/mail/claws-mail/files/patch-configure.ac b/mail/claws-mail/files/extra-patch-configure.ac
index 12bc0f761186..7be834dbee9b 100644
--- a/mail/claws-mail/files/patch-configure.ac
+++ b/mail/claws-mail/files/extra-patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac 2022-03-11 12:05:14.000000000 +0100
-+++ configure.ac.patched 2022-05-18 23:30:12.273740000 +0200
-@@ -2116,7 +2116,7 @@
+--- configure.ac.orig 2022-10-31 21:17:54 UTC
++++ configure.ac
+@@ -2116,7 +2116,7 @@ AM_CONDITIONAL(BUILD_DILLO_PLUGIN, test x"$enable_dil
AM_CONDITIONAL(BUILD_FANCY_PLUGIN, test x"$enable_fancy_plugin" != xno)
AM_CONDITIONAL(BUILD_FETCHINFO_PLUGIN, test x"$enable_fetchinfo_plugin" != xno)
AM_CONDITIONAL(BUILD_GDATA_PLUGIN, test x"$enable_gdata_plugin" != xno)
diff --git a/mail/claws-mail/pkg-plist b/mail/claws-mail/pkg-plist
index 32fd820e5fd6..a32b2168b30e 100644
--- a/mail/claws-mail/pkg-plist
+++ b/mail/claws-mail/pkg-plist
@@ -97,7 +97,7 @@ include/claws-mail/gtk/about.h
include/claws-mail/gtk/authors.h
include/claws-mail/gtk/claws-marshal.h
include/claws-mail/gtk/colorlabel.h
-include/claws-mail/gtk/colorsel.h
+%%GTK2%%include/claws-mail/gtk/colorsel.h
include/claws-mail/gtk/combobox.h
include/claws-mail/gtk/description_window.h
include/claws-mail/gtk/filesel.h
@@ -105,7 +105,7 @@ include/claws-mail/gtk/foldersort.h
include/claws-mail/gtk/gtkaspell.h
include/claws-mail/gtk/gtkcmclist.h
include/claws-mail/gtk/gtkcmctree.h
-include/claws-mail/gtk/gtkcmoptionmenu.h
+%%GTK2%%include/claws-mail/gtk/gtkcmoptionmenu.h
include/claws-mail/gtk/gtksctree.h
include/claws-mail/gtk/gtkshruler.h
include/claws-mail/gtk/gtkunit.h
@@ -293,7 +293,7 @@ share/icons/hicolor/64x64/apps/claws-mail.png
%%NLS%%share/locale/nl/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/pl/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/claws-mail.mo
-%%NLS%%share/locale/pt_PT/LC_MESSAGES/claws-mail.mo
+%%GTK2%%%%NLS%%share/locale/pt_PT/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/ro/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/ru/LC_MESSAGES/claws-mail.mo
%%NLS%%share/locale/sk/LC_MESSAGES/claws-mail.mo