aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-02-10 01:16:08 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2022-02-10 01:17:11 +0000
commit36f52d04a92ae11add2693c4d5c2f55246f4a886 (patch)
tree1a03133092801711b5ad3b77186f8c4cc31a74a1
parent24e11f413f38f06d4ff7e09b2b37c3fe50f56e7a (diff)
downloadports-36f52d04a92ae11add2693c4d5c2f55246f4a886.tar.gz
ports-36f52d04a92ae11add2693c4d5c2f55246f4a886.zip
editors/picpas: Fix build
Reported by: pkg-fallout
-rw-r--r--editors/picpas/Makefile1
-rw-r--r--editors/picpas/files/patch-Source_FrameCfgSynEdit.pas12
2 files changed, 13 insertions, 0 deletions
diff --git a/editors/picpas/Makefile b/editors/picpas/Makefile
index fd0bcbe2f9d5..c59aee1d3bcd 100644
--- a/editors/picpas/Makefile
+++ b/editors/picpas/Makefile
@@ -41,6 +41,7 @@ LAZBUILD_ARGS= -d
post-patch:
${REINPLACE_CMD} 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/Source/Globales.pas
${REINPLACE_CMD} 's|0.8.7|${PORTVERSION}|g' ${WRKSRC}/version.txt
+ ${REINPLACE_CMD} '81d' ${WRKSRC}/Source/FrameSyntaxTree.lfm
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/PicPas-freebsd ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/editors/picpas/files/patch-Source_FrameCfgSynEdit.pas b/editors/picpas/files/patch-Source_FrameCfgSynEdit.pas
new file mode 100644
index 000000000000..fdfa911cde8a
--- /dev/null
+++ b/editors/picpas/files/patch-Source_FrameCfgSynEdit.pas
@@ -0,0 +1,12 @@
+--- Source/FrameCfgSynEdit.pas 2022-02-09 20:05:08.675326000 -0500
++++ Source/FrameCfgSynEdit.pas 2022-02-09 20:05:30.737942000 -0500
+@@ -9,7 +9,8 @@
+ interface
+ uses
+ Classes, SysUtils, Forms, StdCtrls, Dialogs, SynEdit, Graphics,
+- Globales, MiConfigXML, MiConfigBasic, SynEditMarkupHighAll, SynEditMarkup;
++ Globales, MiConfigXML, MiConfigBasic, SynEditMarkupHighAll, SynEditMarkup,
++ SynEditTypes;
+ type
+
+ { TfraCfgSynEdit }