aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2021-12-28 17:22:38 +0000
committerCraig Leres <leres@FreeBSD.org>2021-12-28 17:22:38 +0000
commit37566b5e5904eeaef23916a8a37173c36780a505 (patch)
tree886d757686dc88c80809c8461f3e900f2bda6129
parent78a6ffd2c1f8173f2bf90135e5b2d5c8d0df38b0 (diff)
downloadports-37566b5e5904eeaef23916a8a37173c36780a505.tar.gz
ports-37566b5e5904eeaef23916a8a37173c36780a505.zip
devel/arduino-irremote: Update to 3.5.2
Changes since 2.8.1: - Added SendRaw with byte data. - Added compatibility with tone for AVR's. - New TinyIRreceiver does not require a timer. - Added TinyCore 32 / ATtiny3217 support. - Added Apple protocol - Bug fix for USE_OLD_DECODE. - Increase RECORD_GAP_MICROS to 11000. - Fix overflow message. (#793). - Improved handling for HASH decoder. - Tested for ATtiny85. - Added printIRResultMinimal(). - Added missing IRAM_ATTR for ESP32. - Adapted to TinyCore 0.0.7. - Fixed decodeSony 20 bit bug #811. - Replaced delayMicroseconds with customDelayMicroseconds and removed NoInterrupt() for send functions, removed SPIN_WAIT macro, sleepMicros() and sleepUntilMicros(). - Fixed LG checksum error. - Fixed JVC repeat error. - USE_SOFT_SEND_PWM is active by default. - Removed decode_results results. - Fixed LG send bug and added unit test. - Replaced #define DECODE_NEC 1/0 by defining/not defining. - Use LED_BUILTIN instead of FEEDBACK_LED if FeedbackLEDPin is 0. - Use F_CPU instead of SYSCLOCK. - Removed SENDPIN_ON and SENDPIN_OFF macros. - Refactored board specific code for timer and feedback LED. - Extracted common LED feedback functions and implemented feedback for send. - MATCH_MARK() etc. now available as matchMark(). - Added STM32F1 by (by Roger Clark) support. - Added stm32 (by ST) support. Thanks to Paolo Malaspina. - Added ATtiny88 support. - Fix for ESP32 send Error, removed USE_SOFT_SEND_PWM macro. - Added Onkyo protocol. - Support for old 2.x code by backwards compatible decode(decode_results *aResults) function. - Removed USE_OLD_DECODE macro and added NO_LEGACY_COMPATIBILITY macro. - Added ATtiny1604 support. - Added ESP8266 support. - Extended DEBUG output. - Fix errors if LED_BUILTIN is not defined. - Fixed error for AVR timer1. Thanks to alexbarcelo. - Enabled megaAVR 0-series devices. - Added universal decoder for pulse width or pulse distance protocols. - Added LG2 protocol. - Added ATtiny167 (Digispark Pro) support. - organized carrier frequencies. - Compiler switch USE_OPEN_DRAIN_OUTPUT_FOR_SEND_PIN added. - Moved blink13() back to IRrecv class. - Added Kaseikyo convenience functions like sendKaseikyo_Denon(). - Improved / adjusted LG protocol and added class Aircondition_LG based on real hardware supplied by makerspace 201 (https://wiki.hackerspaces.org/ZwoNullEins) from Cologne. - Improved universal decoder for pulse width or pulse distance protocols to support more than 32 bits. - Added mbed support. - Improved ir_DistanceProtocol. - Tone for ESP32. - No deprecation print for ATtinies. - Maintained MagiQuest by E. Stuart Hicks. - Improved print Pronto by Asuki Kono. - Added printActiveIRProtocols() function. - Used IR_SEND_PIN to reduce code size and improved send timing for AVR. - Fixed error with DEBUG in TinyIRReceiver.hpp. - Support for ATmega88 see issue #923. Thanks to Dolmant. - NO_LED_FEEDBACK_CODE replaces and extends DISABLE_LED_FEEDBACK_FOR_RECEIVE. - Removed NO_LEGACY_COMPATIBILITY macro, it was useless now. Reported by: portscout
-rw-r--r--devel/arduino-irremote/Makefile3
-rw-r--r--devel/arduino-irremote/distinfo6
2 files changed, 5 insertions, 4 deletions
diff --git a/devel/arduino-irremote/Makefile b/devel/arduino-irremote/Makefile
index 45714b69c50c..7e6c7685d8d9 100644
--- a/devel/arduino-irremote/Makefile
+++ b/devel/arduino-irremote/Makefile
@@ -1,7 +1,8 @@
# Created by: Craig Leres <leres@FreeBSD.org>
PORTNAME= arduino-irremote
-PORTVERSION= 2.8.1
+PORTVERSION= 3.5.2
+DISTVERSIONPREFIX= v
CATEGORIES= devel
MAINTAINER= leres@FreeBSD.org
diff --git a/devel/arduino-irremote/distinfo b/devel/arduino-irremote/distinfo
index 0ad28d0a9f87..17b5af2d1219 100644
--- a/devel/arduino-irremote/distinfo
+++ b/devel/arduino-irremote/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608781658
-SHA256 (z3t0-Arduino-IRremote-2.8.1_GH0.tar.gz) = 11563bd5bef4fedece8a8629c3a2f7ee69a895c659a82c49c07bdb4cc6ea74af
-SIZE (z3t0-Arduino-IRremote-2.8.1_GH0.tar.gz) = 113245
+TIMESTAMP = 1640660837
+SHA256 (z3t0-Arduino-IRremote-v3.5.2_GH0.tar.gz) = f23aea21e392c5da2d18a3e49d873a63026a62e7a4ccc193c0d497be92123917
+SIZE (z3t0-Arduino-IRremote-v3.5.2_GH0.tar.gz) = 650279