aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2021-09-04 16:16:59 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-09-04 16:18:29 +0000
commit384ca6fe490afc8e19c843ffe273081a16df036b (patch)
treea142199bffdf11e915f6a33a8a1880167100dd22
parent393963898a1ab7bcdb943651173b526e66ea4e74 (diff)
downloadports-384ca6fe490afc8e19c843ffe273081a16df036b.tar.gz
ports-384ca6fe490afc8e19c843ffe273081a16df036b.zip
emulators/virtualbox-ose: don't hardcode compiler version
PR: 257921
-rw-r--r--emulators/virtualbox-ose/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 80cb68c32315..52fdddd4e0e0 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -214,7 +214,7 @@ KMK_FLAGS+= -j${MAKE_JOBS_NUMBER}
# llvm10 in FreeBSD before r364284 miscompiles virtualbox 6.1 causing errors.
# force llvm11 from ports
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300109
-BUILD_DEPENDS+= clang11:devel/llvm${VBOX_LLVM_VER}
+BUILD_DEPENDS+= clang${VBOX_LLVM_VER}:devel/llvm${VBOX_LLVM_VER}
CC= ${LOCALBASE}/bin/clang${VBOX_LLVM_VER}
CXX= ${LOCALBASE}/bin/clang++${VBOX_LLVM_VER}
VBOX_LLVM_VER?= 11