aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-03-13 18:57:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-03-13 18:57:32 +0000
commit3850a032099b4d3deb354b185b640c1f478b7a9d (patch)
tree7016c735d971a06151b78da0873b38e05712700e
parent448d66dd0308f4870d76e76e3fd889fc17cf0c44 (diff)
downloadports-3850a032099b4d3deb354b185b640c1f478b7a9d.tar.gz
ports-3850a032099b4d3deb354b185b640c1f478b7a9d.zip
cad/zcad: try to unbreak the build of the port's Qt5 flavor
- OpenGL components must be fixed in a slightly different way now - Bring back the comment accidentally removed in r497396 (that is commit 0c124531331c) Reported by: pkg-fallout
-rw-r--r--cad/zcad/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/cad/zcad/Makefile b/cad/zcad/Makefile
index 5b26dfd6f2b1..fb70eaea1fb9 100644
--- a/cad/zcad/Makefile
+++ b/cad/zcad/Makefile
@@ -56,8 +56,6 @@ OPTIONS_DEFINE= DOCS
.if ${FLAVOR:Ugtk2:Mgtk2}
MAKE_ENV+= GUI=gtk2
-.elif ${FLAVOR:Ugtk2:Mqt5}
-BROKEN= fails to build
.endif
post-patch:
@@ -77,13 +75,15 @@ post-patch:
post-configure:
# OpenGL component must be fixed and rebuilt locally (to avoid touching
# filesystem outside working directory)
- ${SED} -e 's,Linux,${OPSYS},' \
- ${LAZARUS_DIR}/components/opengl/openglcontext.pas \
- > ${BUILD_WRKSRC}/openglcontext.pas
+ ${SED} -e 's,@paintGL,paintGL,' \
+ ${LAZARUS_DIR}/components/opengl/qlclopenglwidget.pas \
+ > ${BUILD_WRKSRC}/qlclopenglwidget.pas
${CP} ${LAZARUS_DIR}/components/opengl/glgtkglxcontext.pas \
${LAZARUS_DIR}/components/opengl/glqtcontext.pas \
- ${LAZARUS_DIR}/components/opengl/openglcontext.res \
+ ${LAZARUS_DIR}/components/opengl/openglcontext.* \
${BUILD_WRKSRC}
+# Build components that do not come with precompiled *.ppu files (also
+# copy them locally first for the same reason as above)
${CP} -a ${LAZARUS_DIR}/components/fpvectorial \
${LAZARUS_DIR}/components/anchordocking \
${LAZARUS_DIR}/components/lclextensions ${BUILD_WRKSRC}