aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 13:46:54 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 14:09:31 +0000
commit3862fee82cb80ca11316a2ed63574cfa1f14a940 (patch)
treee9ea33638bd745bc7f9fef7833891497c84c7f83
parent63c8147ee1aafa7d42d24407f3905aed7408f182 (diff)
downloadports-3862fee82cb80ca11316a2ed63574cfa1f14a940.tar.gz
ports-3862fee82cb80ca11316a2ed63574cfa1f14a940.zip
games/opensurge: prepare for freetype2 update
Add missing linker command to link against freetype. PR: 251512
-rw-r--r--games/opensurge/files/patch-CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/opensurge/files/patch-CMakeLists.txt b/games/opensurge/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..555f168425ff
--- /dev/null
+++ b/games/opensurge/files/patch-CMakeLists.txt
@@ -0,0 +1,28 @@
+Link against freetype
+
+CMakeFiles/opensurge.dir/src/main.c.o CMakeFiles/opensurge.dir/src/misc/iconlin.c.o -o opensurge -Wl,-rpath,/usr/local/lib: -lm /usr/local/lib/libalure.so /usr/local/lib/libopenal.so -lvorbisfile -lvorbis -logg -lstdc++ -lpthread -ljpgalleg -lloadpng -lpng -lz -lalfont -lalleg && :
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Done_Face
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Done_FreeType
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Done_Glyph
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Get_Char_Index
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Get_Glyph
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Glyph_Copy
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Glyph_To_Bitmap
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Init_FreeType
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Load_Glyph
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_New_Face
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_New_Memory_Face
+ld: error: /usr/local/lib/libalfont.so: undefined reference to FT_Set_Pixel_Sizes
+cc: error: linker command failed with exit code 1 (use -v to see invocation)
+
+--- CMakeLists.txt.orig 2021-08-06 13:40:36 UTC
++++ CMakeLists.txt
+@@ -366,7 +366,7 @@ IF(UNIX)
+ SET(GAME_SRCS ${GAME_SRCS} src/misc/iconlin.c)
+ ADD_EXECUTABLE(${GAME_UNIXNAME} ${GAME_SRCS})
+ SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES LINK_FLAGS ${ALLEGRO_UNIX_LIBS})
+- TARGET_LINK_LIBRARIES(${GAME_UNIXNAME} m ${AUDIO_LIBS} jpgalleg loadpng png z alfont alleg)
++ TARGET_LINK_LIBRARIES(${GAME_UNIXNAME} m ${AUDIO_LIBS} jpgalleg loadpng png z alfont alleg freetype)
+ SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES COMPILE_FLAGS "-Wall -O2 ${CFLAGS} ${CFLAGS_EXTRA}")
+ ENDIF(UNIX)
+