aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-14 02:48:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-14 05:55:27 +0000
commit3957631adb2d00052dea15ea94889907962fbe44 (patch)
treee8618033407964677cabfdba836e8361347ebf96
parent447c4519391ada0a30d184d839e4dc5f183b75c7 (diff)
downloadports-3957631adb2d00052dea15ea94889907962fbe44.tar.gz
ports-3957631adb2d00052dea15ea94889907962fbe44.zip
devel/argobots: New port: Lightweight, low-level threading and tasking framework
-rw-r--r--devel/Makefile1
-rw-r--r--devel/argobots/Makefile38
-rw-r--r--devel/argobots/distinfo3
-rw-r--r--devel/argobots/pkg-descr7
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7e628046652c..90750a0c477e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -188,6 +188,7 @@
SUBDIR += arduino18
SUBDIR += arduinoOTA
SUBDIR += argdata
+ SUBDIR += argobots
SUBDIR += argouml
SUBDIR += argp-standalone
SUBDIR += argparse
diff --git a/devel/argobots/Makefile b/devel/argobots/Makefile
new file mode 100644
index 000000000000..f416577fee45
--- /dev/null
+++ b/devel/argobots/Makefile
@@ -0,0 +1,38 @@
+PORTNAME= argobots
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1-186
+DISTVERSIONSUFFIX= -gdce6e72
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight, low-level threading and tasking framework
+
+LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/grep:textproc/gnugrep # workaround for https://github.com/pmodels/argobots/issues/375
+
+USES= autoreconf gmake libtool
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= pmodels
+
+INSTALL_TARGET= install-strip
+
+BINARY_ALIAS= grep=${LOCALBASE}/bin/grep # for https://github.com/pmodels/argobots/issues/375
+
+PLIST_FILES= include/abt.h \
+ lib/libabt.a \
+ lib/libabt.so \
+ lib/libabt.so.1 \
+ lib/libabt.so.1.1.0 \
+ libdata/pkgconfig/argobots.pc
+
+do-test: # at least one test never finishes, see https://github.com/pmodels/argobots/issues/376
+ @cd ${WRKSRC}/test && \
+ ${GMAKE} check
+
+.include <bsd.port.mk>
diff --git a/devel/argobots/distinfo b/devel/argobots/distinfo
new file mode 100644
index 000000000000..0cb1b45e2327
--- /dev/null
+++ b/devel/argobots/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1657763740
+SHA256 (pmodels-argobots-v1.1-186-gdce6e72_GH0.tar.gz) = dbdcedd479933515360c56a971e2492ea65d6bb170146cf80f5465a66846451e
+SIZE (pmodels-argobots-v1.1-186-gdce6e72_GH0.tar.gz) = 723454
diff --git a/devel/argobots/pkg-descr b/devel/argobots/pkg-descr
new file mode 100644
index 000000000000..95682a6af03c
--- /dev/null
+++ b/devel/argobots/pkg-descr
@@ -0,0 +1,7 @@
+Argobots is a lightweight runtime system that supports integrated
+computation and data movement with massive concurrency. It will
+directly leverage the lowest-level constructs in the hardware and
+OS: lightweight notification mechanisms, data movement engines,
+memory mapping, and data placement strategies.
+
+WWW: https://www.argobots.org/