aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-03 17:46:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-03 17:48:45 +0000
commit3992794ac05f73d75c6a75f57ffc4251c96c2820 (patch)
treef7b51385eb4b728dd5059d1e6a8493d18cb8c0e7
parentdefd093c3e329a320214b092e5dafefb13d2ccd4 (diff)
science/py-emmet-core: New port: Materials API Toolkit for the Materials Project
-rw-r--r--science/Makefile1
-rw-r--r--science/py-emmet-core/Makefile24
-rw-r--r--science/py-emmet-core/distinfo3
-rw-r--r--science/py-emmet-core/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 4400460c89cd..098f547302de 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -331,6 +331,7 @@
SUBDIR += py-dwavebinarycsp
SUBDIR += py-earthpy
SUBDIR += py-eccodes
+ SUBDIR += py-emmet-core
SUBDIR += py-esda
SUBDIR += py-fresnel
SUBDIR += py-gemmi
diff --git a/science/py-emmet-core/Makefile b/science/py-emmet-core/Makefile
new file mode 100644
index 000000000000..2c0fcbdcfa86
--- /dev/null
+++ b/science/py-emmet-core/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= emmet-core
+DISTVERSION= 0.58.0
+CATEGORIES= science python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Materials API Toolkit for the Materials Project
+WWW= https://github.com/materialsproject/emmet
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}monty>=2021.3:devel/py-monty@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pybtex>=0.24:textproc/py-pybtex@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydantic>=1.10.2:devel/py-pydantic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pymatgen>0:science/py-pymatgen@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spglib>=2.0.1:science/py-spglib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7<5.0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python pytest
+USE_PYTHON= distutils autoplist pytest
+
+.include <bsd.port.mk>
diff --git a/science/py-emmet-core/distinfo b/science/py-emmet-core/distinfo
new file mode 100644
index 000000000000..850e2d6b411d
--- /dev/null
+++ b/science/py-emmet-core/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688401676
+SHA256 (emmet-core-0.58.0.tar.gz) = 81e95966f5c05aa6c04d79cc928432a5cb2d02d9ad7f1137f03395d77dc1c814
+SIZE (emmet-core-0.58.0.tar.gz) = 149279
diff --git a/science/py-emmet-core/pkg-descr b/science/py-emmet-core/pkg-descr
new file mode 100644
index 000000000000..d9b2184f9d19
--- /dev/null
+++ b/science/py-emmet-core/pkg-descr
@@ -0,0 +1,3 @@
+emmet is the Materials API Toolkit for the Materials Project.
+Emmet defines the core models, data pipelines, the API server,
+and the convenience CLI.