aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-07 12:14:55 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-07 12:14:55 +0000
commit39be1279f16c6787a126a751bc58a1f4b767eeb5 (patch)
tree9fe5fd677a2ec63efa53888be064571414337440
parent8b6e99c02d6da8b25db80197b38bef1b8ae20f71 (diff)
downloadports-39be1279f16c6787a126a751bc58a1f4b767eeb5.tar.gz
ports-39be1279f16c6787a126a751bc58a1f4b767eeb5.zip
cad/openvsp: fix build on powerpc64
/wrkdirs/usr/ports/cad/openvsp/work/.build/Libraries-prefix/src/Libraries-build/EIGEN-prefix/src/EIGEN/Eigen/src/Core/arch/AltiVec/PacketMath.h:1340:32: error: use of undeclared identifier 'vec_sqrt'; did you mean 'vec_rsqrte'? BF16_TO_F32_UNARY_OP_WRAPPER(vec_sqrt, a);
-rw-r--r--cad/openvsp/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 767c08faf32c..3d1ffb95c02f 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -35,6 +35,7 @@ USE_GNOME= libxml2
USE_XORG= ice sm x11 xau xcb xdamage xdmcp xext xfixes xft \
xinerama xrender xxf86vm
+CXXFLAGS_powerpc64= -mvsx
CMAKE_ARGS= -DVSP_USE_SYSTEM_CMINPACK:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CPPTEST:BOOLEAN=yes \
-DVSP_USE_SYSTEM_CODEELI:BOOLEAN=no \