aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-21 07:23:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-21 08:20:42 +0000
commit39daf5d46d6631b2b23cc37ab0d9e62c02f24a08 (patch)
tree1b4bf5fd5e5093d93c29f2aeaf609f637fa8871a
parenta791ab5f444a0644620261b0e307b6a6709143ab (diff)
downloadports-39daf5d46d6631b2b23cc37ab0d9e62c02f24a08.tar.gz
ports-39daf5d46d6631b2b23cc37ab0d9e62c02f24a08.zip
misc/py-PyWavefront: New port: Library for importing Wavefront .obj files
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-PyWavefront/Makefile26
-rw-r--r--misc/py-PyWavefront/distinfo3
-rw-r--r--misc/py-PyWavefront/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 42fbbba739b2..bcc9b73bcdd3 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -383,6 +383,7 @@
SUBDIR += ptsort
SUBDIR += pubs
SUBDIR += py-PyUserInput
+ SUBDIR += py-PyWavefront
SUBDIR += py-QSpectrumAnalyzer
SUBDIR += py-SimpleSoapy
SUBDIR += py-SoapySDR
diff --git a/misc/py-PyWavefront/Makefile b/misc/py-PyWavefront/Makefile
new file mode 100644
index 000000000000..3bd0302e3cc7
--- /dev/null
+++ b/misc/py-PyWavefront/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= PyWavefront
+DISTVERSION= 1.3.3
+CATEGORIES= misc
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for importing Wavefront .obj files
+WWW= https://github.com/pywavefront/PyWavefront
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= distutils autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= pywavefront
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_WRKSRC= ${WRKSRC}/tests
+
+.include <bsd.port.mk>
diff --git a/misc/py-PyWavefront/distinfo b/misc/py-PyWavefront/distinfo
new file mode 100644
index 000000000000..66aec74b6d53
--- /dev/null
+++ b/misc/py-PyWavefront/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674285574
+SHA256 (pywavefront-PyWavefront-1.3.3_GH0.tar.gz) = 09fd4cd1fb78e9659ee33b82b1b5c7169df97f908d50cd3febfce26c6c61903d
+SIZE (pywavefront-PyWavefront-1.3.3_GH0.tar.gz) = 3531475
diff --git a/misc/py-PyWavefront/pkg-descr b/misc/py-PyWavefront/pkg-descr
new file mode 100644
index 000000000000..b2d66892350d
--- /dev/null
+++ b/misc/py-PyWavefront/pkg-descr
@@ -0,0 +1,3 @@
+PyWavefront reads Wavefront 3D object files (something.obj, something.obj.gz
+and something.mtl) and generates interleaved vertex data for each material
+ready for rendering.