aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2022-10-20 04:06:53 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2022-10-20 04:06:53 +0000
commit39e58330c84e4598164fe3585ed7260410d04f35 (patch)
treeeeac742cb4947ceb5b1be3963b69ea1f51f3a379
parent34947f9792da2e42198e51550182ab516ae63b09 (diff)
downloadports-39e58330c84e4598164fe3585ed7260410d04f35.tar.gz
ports-39e58330c84e4598164fe3585ed7260410d04f35.zip
math/octave-forge-ponchon-savarit: New port.
A toolbox for the Ponchon-Savarit method for octave. Had to make changes to Mk/bsd.octave.mk to accomodate this port.
-rw-r--r--Mk/bsd.octave.mk14
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-ponchon-savarit/Makefile29
-rw-r--r--math/octave-forge-ponchon-savarit/distinfo3
-rw-r--r--math/octave-forge-ponchon-savarit/pkg-descr8
5 files changed, 49 insertions, 6 deletions
diff --git a/Mk/bsd.octave.mk b/Mk/bsd.octave.mk
index b9bbcfb256ad..b65d1a5df118 100644
--- a/Mk/bsd.octave.mk
+++ b/Mk/bsd.octave.mk
@@ -6,15 +6,17 @@
# It is, in effect, a wrapper using the package handling already built
# into math/octave.
-.if !empty(MASTER_SITE_OLD:MR2009_05)
-MASTER_SITES= SF/octave/Octave%20Forge%20Packages/Old%20Monolithic%20Releases/R2009-05-08
-.elif !empty(MASTER_SITE_OLD:MR2009_06)
-MASTER_SITES= SF/octave/Octave%20Forge%20Packages/Old%20Monolithic%20Releases/R2009-06-07
-.else
+.ifndef MASTER_SITES
+ .if !empty(MASTER_SITE_OLD:MR2009_05)
+ MASTER_SITES= SF/octave/Octave%20Forge%20Packages/Old%20Monolithic%20Releases/R2009-05-08
+ .elif !empty(MASTER_SITE_OLD:MR2009_06)
+ MASTER_SITES= SF/octave/Octave%20Forge%20Packages/Old%20Monolithic%20Releases/R2009-06-07
+ .else
MASTER_SITES= SF/octave/Octave%20Forge%20Packages/Individual%20Package%20Releases
+ .endif
.endif
-DISTNAME= ${OCTAVE_PKGNAME}-${DISTVERSIONFULL}
+DISTNAME?= ${OCTAVE_PKGNAME}-${DISTVERSIONFULL}
bsd_octave_mk_MAINTAINER= stephen@FreeBSD.org
diff --git a/math/Makefile b/math/Makefile
index db2287a2a58f..63f3ead8345c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -586,6 +586,7 @@
SUBDIR += octave-forge-outliers
SUBDIR += octave-forge-parallel
SUBDIR += octave-forge-plot
+ SUBDIR += octave-forge-ponchon-savarit
SUBDIR += octave-forge-quaternion
SUBDIR += octave-forge-queueing
SUBDIR += octave-forge-secs1d
diff --git a/math/octave-forge-ponchon-savarit/Makefile b/math/octave-forge-ponchon-savarit/Makefile
new file mode 100644
index 000000000000..70ae150ec5b8
--- /dev/null
+++ b/math/octave-forge-ponchon-savarit/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= octave-forge-ponchon-savarit
+PORTVERSION= 0.1.0
+CATEGORIES= math
+MASTER_SITES= https://github.com/aumpierre-unb/Ponchon-Savarit-for-GNU-Octave/archive/refs/tags/
+DISTNAME= v${PORVERSION}0.1.0
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+WWW= http://octave.sourceforge.net/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= Ponchon-Savarit-for-GNU-Octave-${PORTVERSION}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+do-build:
+ @${DO_NADA}
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-ponchon-savarit/distinfo b/math/octave-forge-ponchon-savarit/distinfo
new file mode 100644
index 000000000000..cd6592ecf2de
--- /dev/null
+++ b/math/octave-forge-ponchon-savarit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1666204732
+SHA256 (octave-forge/v0.1.0.tar.gz) = 3a1dd359d63c67e9fc0b927c5e30a5b55422636d8b08dbeaa050dc2dade4e7d4
+SIZE (octave-forge/v0.1.0.tar.gz) = 151831
diff --git a/math/octave-forge-ponchon-savarit/pkg-descr b/math/octave-forge-ponchon-savarit/pkg-descr
new file mode 100644
index 000000000000..c9a1817970cf
--- /dev/null
+++ b/math/octave-forge-ponchon-savarit/pkg-descr
@@ -0,0 +1,8 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is ponchon-savarit.
+
+ A toolbox for the Ponchon-Savarit method.