aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-02-07 20:13:13 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-02-07 21:15:50 +0000
commit39f63febb0b7deb0568c899a0b3c1ad0ac6820e9 (patch)
treed6365db6d0803ddd380de80d0ca8110ee7149ef5
parent754664fa6f890d56e4f06ec21def63e0ee8ae2d6 (diff)
www/py-django-tasks: Add py-django-tasks 0.6.1
Django Tasks provides an implementation and backport of background workers and tasks in Django, as defined in DEP 0014.
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-tasks/Makefile26
-rw-r--r--www/py-django-tasks/distinfo3
-rw-r--r--www/py-django-tasks/pkg-descr2
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2c6710b435cf..77125dd08523 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1628,6 +1628,7 @@
SUBDIR += py-django-tables2
SUBDIR += py-django-tagging
SUBDIR += py-django-taggit
+ SUBDIR += py-django-tasks
SUBDIR += py-django-tastypie
SUBDIR += py-django-templatetag-sugar
SUBDIR += py-django-timezone-field
diff --git a/www/py-django-tasks/Makefile b/www/py-django-tasks/Makefile
new file mode 100644
index 000000000000..f5268ccaca6e
--- /dev/null
+++ b/www/py-django-tasks/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= django-tasks
+PORTVERSION= 0.6.1
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= django_tasks-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Implementation and backport of background workers and tasks in Django
+WWW= https://github.com/RealOrangeOne/django-tasks
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django-stubs-ext>=0:www/py-django-stubs-ext@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django42>=4.2:www/py-django42@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-tasks/distinfo b/www/py-django-tasks/distinfo
new file mode 100644
index 000000000000..eb923f72d139
--- /dev/null
+++ b/www/py-django-tasks/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1738606371
+SHA256 (django_tasks-0.6.1.tar.gz) = 4086e7eb9e965f79c4ac76f5c3690ec3bf41c461585237b71b4bde729ced9826
+SIZE (django_tasks-0.6.1.tar.gz) = 26575
diff --git a/www/py-django-tasks/pkg-descr b/www/py-django-tasks/pkg-descr
new file mode 100644
index 000000000000..5d7bb4328913
--- /dev/null
+++ b/www/py-django-tasks/pkg-descr
@@ -0,0 +1,2 @@
+Django Tasks provides an implementation and backport of background workers and
+tasks in Django, as defined in DEP 0014.