aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTino Engel <tino.engel@mail.de>2025-01-08 22:07:52 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2025-01-17 12:34:02 +0000
commit3a3b1819c6c13e83ca98034f47b7b3b0f6325084 (patch)
treeaa509677b641756f29cf84e9db2347ac6a648f2f
parentbc71b6fa41d942faa02c983b849f1b51b5a2cbe8 (diff)
x11/wlopm: update to 1.0.0
CHANGELOG: - Add bash completions. - Fix installation on FreeBSD (thanks to Isaac Freund). - Follow (new) C standard by replacing noop() function (thanks to Ben Buse). - Allow compiling with clang via -Wno-strict-prototypes. - Fix file permissions of man page. PR: 283942
-rw-r--r--x11/wlopm/Makefile2
-rw-r--r--x11/wlopm/distinfo6
-rw-r--r--x11/wlopm/files/patch-Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/x11/wlopm/Makefile b/x11/wlopm/Makefile
index aca7d49a76a1..c04099e52cad 100644
--- a/x11/wlopm/Makefile
+++ b/x11/wlopm/Makefile
@@ -1,6 +1,6 @@
PORTNAME= wlopm
DISTVERSIONPREFIX= v
-DISTVERSION= 0.1.0
+DISTVERSION= 1.0.0
CATEGORIES= x11 wayland
MASTER_SITES= https://git.sr.ht/~leon_plickat/${PORTNAME}/archive/
DISTNAME= ${DISTVERSIONFULL}
diff --git a/x11/wlopm/distinfo b/x11/wlopm/distinfo
index fbeda9111949..784b5ea631e7 100644
--- a/x11/wlopm/distinfo
+++ b/x11/wlopm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1700117590
-SHA256 (wlopm/v0.1.0.tar.gz) = f9a7ec03a412e602420ab11d0eea872f6d30dfe5cfee93cd3d0289e4fbbb3aa1
-SIZE (wlopm/v0.1.0.tar.gz) = 19004
+TIMESTAMP = 1736373535
+SHA256 (wlopm/v1.0.0.tar.gz) = 15f31bbd855131943397dded3a26003f2f5056e4c6a1a93d35ff7697b3f1e439
+SIZE (wlopm/v1.0.0.tar.gz) = 19451
diff --git a/x11/wlopm/files/patch-Makefile b/x11/wlopm/files/patch-Makefile
index b98b847e0173..8286dfc8c7e9 100644
--- a/x11/wlopm/files/patch-Makefile
+++ b/x11/wlopm/files/patch-Makefile
@@ -4,8 +4,8 @@
BINDIR=$(PREFIX)/bin
MANDIR=$(PREFIX)/share/man
--CFLAGS+=-Wall -Werror -Wextra -Wpedantic -Wno-unused-parameter -Wconversion -Wformat-security -Wformat -Wsign-conversion -Wfloat-conversion -Wunused-result
-+CFLAGS+=-Wall -Wextra -Wpedantic -Wno-unused-parameter -Wconversion -Wformat-security -Wformat -Wsign-conversion -Wfloat-conversion -Wunused-result
+-CFLAGS+=-Wall -Werror -Wextra -Wpedantic -Wno-unused-parameter -Wconversion -Wformat-security -Wformat -Wsign-conversion -Wfloat-conversion -Wunused-result -Wno-strict-prototypes
++CFLAGS+=-Wall -Wextra -Wpedantic -Wno-unused-parameter -Wconversion -Wformat-security -Wformat -Wsign-conversion -Wfloat-conversion -Wunused-result -Wno-strict-prototypes
LIBS=-lwayland-client
OBJ=wlopm.o wlr-output-power-management-unstable-v1.o
GEN=wlr-output-power-management-unstable-v1.c wlr-output-power-management-unstable-v1.h