aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-02-20 09:19:38 +0000
committerWen Heping <wen@FreeBSD.org>2024-02-20 09:21:43 +0000
commit3a57a3175c1ac40d83d27aa6bafb7fbd8ee01a40 (patch)
treee244a32590133c4ed8a392fb568b29a118853b0a
parentd265f6434120b266251062cbc26e898b717953ff (diff)
databases/mongodb70: Fix build with python-3.11
PR: 275494 Approved by: portmgr(blanket, fix build)
-rw-r--r--databases/mongodb70/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/mongodb70/Makefile b/databases/mongodb70/Makefile
index d9f1b806b361..df98a51d859e 100644
--- a/databases/mongodb70/Makefile
+++ b/databases/mongodb70/Makefile
@@ -122,6 +122,12 @@ post-patch:
${RM} -rf ${WRKSRC}/src/third_party/zlib-*
${RM} -rf ${WRKSRC}/src/third_party/zstandard
+# fix build with python-3.11
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/util.py
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/preprocessor.py
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/backend/base.py
+ ${REINPLACE_CMD} -e 's#rU#r#g' ${WRKDIR}/spidermonkey-${MOZJS_TAG}/python/mozbuild/mozbuild/action/process_define_files.py
+
do-configure:
# Replacement of ${WRKSRC}/src/third_party/mozjs/get-sources.sh
${LN} -sF ${WRKDIR}/spidermonkey-${MOZJS_TAG} ${WRKSRC}/src/third_party/mozjs/mozilla-release