aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMitchell Clay <mclay@astate.edu>2023-03-29 15:16:03 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2023-03-30 01:25:49 +0000
commit3b5dd3c9d7989e900155de9d15d68a6deef012d5 (patch)
treeffa09de9939528e963e41b472ffb101ac6635fae
parent6f49e3e7dd1606711baef45f8ed4b9dac45e2727 (diff)
emulators/nestopia: update to 1.52.0 and take maintainership
Changelog: http://0ldsk00l.ca/nestopia/ PR: 269940 Reported by: Mitchell Clay <mclay@astate.edu> (new maintainer) Reviewed by: diizzy
-rw-r--r--emulators/nestopia/Makefile21
-rw-r--r--emulators/nestopia/distinfo6
-rw-r--r--emulators/nestopia/files/patch-configure.ac11
3 files changed, 26 insertions, 12 deletions
diff --git a/emulators/nestopia/Makefile b/emulators/nestopia/Makefile
index 64e1d37af590..a9bc31646738 100644
--- a/emulators/nestopia/Makefile
+++ b/emulators/nestopia/Makefile
@@ -1,27 +1,30 @@
PORTNAME= nestopia
-DISTVERSION= 1.51.1
+DISTVERSION= 1.52.0
CATEGORIES= emulators
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mclay@astate.edu
COMMENT= Portable NES/Famicom emulator
WWW= http://0ldsk00l.ca/nestopia/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
-LIB_DEPENDS= libao.so:audio/libao \
- libepoxy.so:graphics/libepoxy \
- libfltk.so:x11-toolkits/fltk
+BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive \
+ fltk>=0:x11-toolkits/fltk
+LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libfltk.so:x11-toolkits/fltk \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libpng.so:graphics/png
-USES= autoreconf desktop-file-utils gl gnome libarchive \
+USES= autoreconf gl gnome jpeg libarchive \
localbase:ldflags pkgconfig sdl
USE_CXXSTD= c++98
USE_GITHUB= yes
-GH_ACCOUNT= rdanbrook
+GH_ACCOUNT= 0ldsk00l
GNU_CONFIGURE= yes
-USE_GL= glu
+USE_GL= gl glu
USE_SDL= sdl2
+USE_XORG= xrender xcursor xfixes xext xft xinerama x11
OPTIONS_DEFINE= DOCS JACK
diff --git a/emulators/nestopia/distinfo b/emulators/nestopia/distinfo
index 21e737817a30..89db2b386e85 100644
--- a/emulators/nestopia/distinfo
+++ b/emulators/nestopia/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1630122040
-SHA256 (rdanbrook-nestopia-1.51.1_GH0.tar.gz) = 6c2198ed5f885b160bf7e22a777a5e139a7625444ec47625cd07a36627e94b3f
-SIZE (rdanbrook-nestopia-1.51.1_GH0.tar.gz) = 1578970
+TIMESTAMP = 1680098557
+SHA256 (0ldsk00l-nestopia-1.52.0_GH0.tar.gz) = eae1d2f536ae8585edb8d723caf905f4ae65349edee4ffbee45f9f52b5e3b06c
+SIZE (0ldsk00l-nestopia-1.52.0_GH0.tar.gz) = 1589971
diff --git a/emulators/nestopia/files/patch-configure.ac b/emulators/nestopia/files/patch-configure.ac
new file mode 100644
index 000000000000..c75e01482174
--- /dev/null
+++ b/emulators/nestopia/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2023-03-03 20:18:56 UTC
++++ configure.ac
+@@ -83,6 +83,8 @@ AC_SUBST(FLTK_CFLAGS,"$(fltk-config --use-gl --use-ima
+ AS_CASE([${host_os}],
+ [darwin*],
+ [AC_SUBST(FLTK_LIBS,"$(fltk-config --use-gl --use-images --ldflags)")],
++ [freebsd*],
++ [AC_SUBST(FLTK_LIBS,"-lGL $(fltk-config --use-gl --use-images --ldflags)")],
+ [linux*],
+ [AC_SUBST(FLTK_LIBS,"-lGL $(fltk-config --use-gl --use-images --ldflags)")]
+ )