aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2022-04-10 08:28:17 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2022-04-10 08:28:17 +0000
commit3b86347c82ef71a0486447b40684d1c3a0496cbe (patch)
tree48ab04d05c985f82b0ec2947971f4810309ad585
parentfb258e9f229dcbf2b793f96718b9aab0916bd755 (diff)
math/octave: fix pkg-plist.
- This installed a number of files whose path name is derived from the directory in which the port is built. This is a band-aid fix which deletes those files. This will enable the installation to work if the ports directory is something other than /usr/ports. Reported by: pkg-fallout@
-rw-r--r--math/octave/Makefile4
-rw-r--r--math/octave/pkg-plist17
2 files changed, 4 insertions, 17 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 4f4b2c85b989..060d7fcbbe36 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -2,6 +2,7 @@
PORTNAME= octave
PORTVERSION= ${OCTAVE_VERSION}
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= GNU
@@ -116,8 +117,11 @@ pre-configure:
${REINPLACE_CMD} 's+"makeinfo"+"${LOCALBASE}/bin/makeinfo"+' ${WRKSRC}/libinterp/corefcn/help.cc
${REINPLACE_CMD} 's/"-qt=$$qt_version"/"-qt=qt$$qt_version"/' ${WRKSRC}/configure
+RM_STUFF=${WRKSRC:C+/++:C+/.*++}
+
post-install:
(cd ${STAGEDIR}${DATADIR} && ${LN} -s ${PORTVERSION}/imagelib .)
+ ${RM} -r ${STAGEDIR}${DATADIR}/${PORTVERSION}/etc/tests/fixed/${WRKDIR:C+/++:C+/.*++}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
index fbf0f5b5045d..aac620126767 100644
--- a/math/octave/pkg-plist
+++ b/math/octave/pkg-plist
@@ -1211,23 +1211,6 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/transpose.tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/try.tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/unwind.tst
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@cell/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@char/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@double/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@function_handle/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@int16/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@int32/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@int64/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@int8/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@logical/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@single/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@struct/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@uint16/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@uint32/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@uint64/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/@uint8/tbcover.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/bc-overloads.tst
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/usr/ports/math/octave/work/octave-%%OCTAVE_VERSION%%/test/tbcover.m
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/while.tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/Cell.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/__contourc__.cc-tst